Modify

Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#4924 closed defect (duplicate)

Exception while send data

Reported by: rodrigo@… Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. Open JOSM
  2. Load and edit some data
  3. Click on "Upload Changes"

What is the expected result?
Send changes to server

What happens instead?
The exception informed below

Please provide any additional information below. Attach a screenshot if possible.

If i use some old versions, this does not happen. This happen in both test and stable versions, with a fresh .josm directory or not, with or without plugins.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2010-04-20 01:31:24
Last Changed Author: ce
Revision: 3196
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2010-04-19 21:06:13 +0200 (Mon, 19 Apr 2010)
Last Changed Rev: 3196

Memory Usage: 69 MB / 247 MB (11 MB allocated, but free)
Java version: 1.6.0_19, Sun Microsystems Inc., Java HotSpot(TM) Client VM
Operating system: Linux

Dataset consistency test:
No problems found


Plugins: AddrInterpolation,dataimport,editgpx,photo_geotagging,remotecontrol,turnrestrictions,wmsplugin
Plugin wmsplugin (Version: 20566)
Plugin editgpx (Version: 19683)
Plugin dataimport (Version: 20431)
Plugin remotecontrol (Version: 19946)
Plugin AddrInterpolation (Version: 19422)
Plugin photo_geotagging (Version: 19873)
Plugin turnrestrictions (Version: 20745)

java.lang.IllegalArgumentException: Unmatched braces in the pattern.
	at java.text.MessageFormat.applyPattern(MessageFormat.java:476)
	at java.text.MessageFormat.<init>(MessageFormat.java:350)
	at java.text.MessageFormat.format(MessageFormat.java:811)
	at org.openstreetmap.josm.tools.I18n.tr(I18n.java:38)
	at org.openstreetmap.josm.gui.io.UploadStrategySelectionPanel.updateNumRequestsLabels(UploadStrategySelectionPanel.java:359)
	at org.openstreetmap.josm.gui.io.UploadStrategySelectionPanel.setNumUploadedObjects(UploadStrategySelectionPanel.java:231)
	at org.openstreetmap.josm.gui.io.UploadStrategySelectionPanel.propertyChange(UploadStrategySelectionPanel.java:378)
	at java.beans.PropertyChangeSupport.firePropertyChange(PropertyChangeSupport.java:339)
	at java.beans.PropertyChangeSupport.firePropertyChange(PropertyChangeSupport.java:276)
	at java.beans.PropertyChangeSupport.firePropertyChange(PropertyChangeSupport.java:297)
	at java.awt.Component.firePropertyChange(Component.java:8168)
	at javax.swing.JComponent.firePropertyChange(JComponent.java:4456)
	at org.openstreetmap.josm.gui.io.UploadedObjectsSummaryPanel.setUploadedPrimitives(UploadedObjectsSummaryPanel.java:120)
	at org.openstreetmap.josm.gui.io.UploadDialog.setUploadedPrimitives(UploadDialog.java:246)
	at org.openstreetmap.josm.actions.UploadAction.uploadData(UploadAction.java:163)
	at org.openstreetmap.josm.actions.UploadAction.actionPerformed(UploadAction.java:192)
	at javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:1995)
	at javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.java:2318)
	at javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:387)
	at javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:242)
	at javax.swing.plaf.basic.BasicButtonListener.mouseReleased(BasicButtonListener.java:236)
	at java.awt.AWTEventMulticaster.mouseReleased(AWTEventMulticaster.java:272)
	at java.awt.Component.processMouseEvent(Component.java:6263)
	at javax.swing.JComponent.processMouseEvent(JComponent.java:3267)
	at java.awt.Component.processEvent(Component.java:6028)
	at java.awt.Container.processEvent(Container.java:2041)
	at java.awt.Component.dispatchEventImpl(Component.java:4630)
	at java.awt.Container.dispatchEventImpl(Container.java:2099)
	at java.awt.Component.dispatchEvent(Component.java:4460)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4574)
	at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4238)
	at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4168)
	at java.awt.Container.dispatchEventImpl(Container.java:2085)
	at java.awt.Window.dispatchEventImpl(Window.java:2478)
	at java.awt.Component.dispatchEvent(Component.java:4460)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:599)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:269)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:184)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:174)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:169)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:161)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:122)

Attachments (0)

Change History (2)

comment:1 Changed 12 years ago by bastiK

Resolution: duplicate
Status: newclosed

comment:2 Changed 12 years ago by bastiK

Closed as duplicate of #4943.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.