Modify

Opened 10 years ago

Closed 8 years ago

#4549 closed defect (fixed)

"Join Node to Way" should be called "Join Way to Node"

Reported by: avarab@… Owned by: team
Priority: minor Milestone:
Component: Core Version: latest
Keywords: Cc:

Description (last modified by simon04)

When you select a way y and a node x like this:

y
|
| x----
|
y

"Join Node to Way" will actually move the way y to include node x. Hence it should be called "Join Way to Node" and not "Join Node to Way" since it's moving the way to the node, and not the other way around.

Attachments (1)

joinnodeway.png (541 bytes) - added by simon04 8 years ago.

Download all attachments as: .zip

Change History (9)

comment:1 Changed 10 years ago by mjulius

I don't agree. A way is a list of nodes and the new node is joined to that list. Maybe it would be more accurate to call this "Include Node in Way", but I don't think this is worth the trouble.

comment:2 in reply to:  1 Changed 10 years ago by Ldp

Replying to mjulius:

I don't agree. A way is a list of nodes and the new node is joined to that list. Maybe it would be more accurate to call this "Include Node in Way", but I don't think this is worth the trouble.

You seem to be confusing internal details with UI usability and expectancy. Internal details are of no importance whatsoever to a mapper doing some editing.

I expect 'Join node to way' to move the node to be on top of the way and add it to the way.

If I want to do the reverse, I grab a virtual node (another misnomer) from the way and ctrl-drop it onto the node. Don't need 'Join node to way' to perform that.

comment:3 in reply to:  1 ; Changed 10 years ago by avarab@…

Replying to mjulius:

I don't agree. A way is a list of nodes and the new node is joined to that list. Maybe it would be more accurate to call this "Include Node in Way", but I don't think this is worth the trouble.

I can see your point but as Ldp points out a user is more likely to think about this visually. I.e. "Join Node to Way" would imply that Node is to be moved to where Way is now. But "Include Node in Way" would be less ambiguous and seems like a better solution.

Actually what would really help the usability is if the icon had a little arrow indicating which item is the one that's going to be moved. Unfortunately I don't have the graphics skills to submit one.

comment:4 Changed 10 years ago by stoecker

Ticket #5021 has been marked as a duplicate of this ticket.

Changed 8 years ago by simon04

Attachment: joinnodeway.png added

comment:5 in reply to:  3 Changed 8 years ago by simon04

Description: modified (diff)

Replying to avar:

Actually what would really help the usability is if the icon had a little arrow indicating which item is the one that's going to be moved.

I tried to add an arrow to the icon: attachment:joinnodeway.png

"Include Node in Way" is unambiguous, however, it makes the shortcut unintuitive …

comment:6 Changed 8 years ago by simon04

In [4787/josm]:

see #4549 - add little arrow to "Join Node to Way" icon to indicate which item is going to be moved

comment:7 Changed 8 years ago by simon04

In [4788/josm]:

see #4549 - alter tooltip text of "Join Node to Way" to clarify

comment:8 Changed 8 years ago by simon04

Resolution: fixed
Status: newclosed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.