Modify

Opened 12 years ago

Closed 12 years ago

#4548 closed defect (fixed)

OsmTransferException when Open Location does not return pure XML

Reported by: mjulius Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: template_report Cc:

Description

I have tried to do download http://osm.nix.is/latest/Iceland.osm.bz2

Build-Date: 2010-02-17 12:44:31		
Revision: 3001
Is-Local-Build: true

Memory Usage: 115 MB / 247 MB (45 MB allocated, but free)
Java version: 1.6.0_18, Sun Microsystems Inc., Java HotSpot(TM) Client VM
Operating system: Windows XP


Plugins: measurement,multipoly,openstreetbugs,remotecontrol,slippymap,validator,wmsplugin
Plugin openstreetbugs Version: 19366
Plugin wmsplugin Version: 19306
Plugin remotecontrol Version: 19298
Plugin validator Version: 19335
Plugin slippymap Version: 19302
Plugin multipoly Version: 19138
Plugin measurement Version: 19058

org.openstreetmap.josm.io.OsmTransferException: org.openstreetmap.josm.io.IllegalDataException: Content is not allowed in prolog.
	at org.openstreetmap.josm.io.OsmServerLocationReader.parseOsm(OsmServerLocationReader.java:37)
	at org.openstreetmap.josm.actions.downloadtasks.DownloadOsmTask$DownloadTask.realRun(DownloadOsmTask.java:91)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.doRealRun(PleaseWaitRunnable.java:83)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.run(PleaseWaitRunnable.java:129)
	at java.util.concurrent.Executors$Run

Attachments (0)

Change History (6)

comment:1 Changed 12 years ago by Gubaer

Hmm, where's the problem? JOSM fortunatelly refuses to open a compressed input stream as plain XML.

comment:2 Changed 12 years ago by mjulius

Well, as the Unexpected Exception dialog states: "This is always a coding error." So at least there should be a friendly message popping up saying that JOSM can not use the data it got from the server.

On the other hand it would be nice if JOSM could open bz2 (or gz, or zip) compressed data from a server location just like it can from a local filesystem. But, that would be a separate enhancement ticket.

comment:3 in reply to:  2 Changed 12 years ago by Gubaer

Replying to mjulius:

Well, as the Unexpected Exception dialog states: "This is always a coding error." So at least there should be a friendly message popping up saying that JOSM can not use the data it got from the server.

You're right, didn't get that at first hand.

comment:4 Changed 12 years ago by mjulius

Ticket #4588 has been marked as a duplicate of this ticket.

comment:5 Changed 12 years ago by Gubaer

Should be fixed in r3069 (doesn't read compressed streams yet, but displays a better error message)

comment:6 Changed 12 years ago by Gubaer

Resolution: fixed
Status: newclosed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.