Modify

Opened 10 years ago

Closed 6 years ago

#4588 closed enhancement (fixed)

Open Location (Ctrl+L) should cope with certain URLs that don't lead to xml data

Reported by: jstein Owned by: team
Priority: normal Milestone:
Component: Core Version: latest
Keywords: template_report Cc:

Description (last modified by Don-vip)

What steps will reproduce the problem?

  1. Ctrl+L
  2. http://www.openstreetmap.org/?lat=50.11195&lon=8.64288&zoom=15&layers=B000FTF
  3. Press OK

What is the expected result?
opening Location or Message about wrong dataformat

What happens instead?
This Error occoured

Please provide any additional information below. Attach a screenshot if
possible.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2010-02-18 12:40:06
Last Changed Author: Gubaer
Revision: 3015
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2010-02-18 12:24:10 +0100 (Thu, 18 Feb 2010)
Last Changed Rev: 3015

Memory Usage: 132 MB / 254 MB (70 MB allocated, but free)
Java version: 1.6.0_16, Sun Microsystems Inc., Java HotSpot(TM) Client VM
Operating system: Linux

Dataset consistency test:
No problems found


Plugins: AddrInterpolation,PicLayer,buildings_tools,editgpx,lakewalker,multipoly,openstreetbugs,osmarender,tageditor,terracer,wmsplugin
Plugin openstreetbugs Version: 19283
Plugin wmsplugin Version: 19306
Plugin editgpx Version: 19052
Plugin PicLayer Version: 19062
Plugin tageditor Version: 18976
Plugin buildings_tools Version: 28
Plugin lakewalker Version: 19294
Plugin osmarender Version: 19296
Plugin AddrInterpolation Version: 18874
Plugin terracer Version: 19234
Plugin multipoly Version: 19138

org.openstreetmap.josm.io.OsmTransferException: org.openstreetmap.josm.io.IllegalDataException: The reference to entity "zoom" must end with the ';' delimiter.
	at org.openstreetmap.josm.io.OsmServerLocationReader.parseOsm(OsmServerLocationReader.java:37)
	at org.openstreetmap.josm.actions.downloadtasks.DownloadOsmTask$DownloadTask.realRun(DownloadOsmTask.java:91)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.doRealRun(PleaseWaitRunnable.java:83)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.run(PleaseWaitRunnable.java:129)
	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:441)
	at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
	at java.util.concurrent.FutureTask.run(FutureTask.java:138)
	at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
	at java.lang.Thread.run(Thread.java:619)
Caused by: org.openstreetmap.josm.io.IllegalDataException: The reference to entity "zoom" must end with the ';' delimiter.
	at org.openstreetmap.josm.io.OsmReader.parseDataSet(OsmReader.java:570)
	at org.openstreetmap.josm.io.OsmServerLocationReader.parseOsm(OsmServerLocationReader.java:31)
	... 9 more
Caused by: org.xml.sax.SAXParseException: The reference to entity "zoom" must end with the ';' delimiter.
	at com.sun.org.apache.xerces.internal.util.ErrorHandlerWrapper.createSAXParseException(ErrorHandlerWrapper.java:195)
	at com.sun.org.apache.xerces.internal.util.ErrorHandlerWrapper.fatalError(ErrorHandlerWrapper.java:174)
	at com.sun.org.apache.xerces.internal.impl.XMLErrorReporter.reportError(XMLErrorReporter.java:388)
	at com.sun.org.apache.xerces.internal.impl.XMLScanner.reportFatalError(XMLScanner.java:1414)
	at com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl.scanEntityReference(XMLDocumentFragmentScannerImpl.java:1841)
	at com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl$FragmentContentDriver.next(XMLDocumentFragmentScannerImpl.java:3024)
	at com.sun.org.apache.xerces.internal.impl.XMLDocumentScannerImpl.next(XMLDocumentScannerImpl.java:648)
	at com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl.scanDocument(XMLDocumentFragmentScannerImpl.java:510)
	at com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(XML11Configuration.java:807)
	at com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(XML11Configuration.java:737)
	at com.sun.org.apache.xerces.internal.parsers.XMLParser.parse(XMLParser.java:107)
	at com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser.parse(AbstractSAXParser.java:1205)
	at com.sun.org.apache.xerces.internal.jaxp.SAXParserImpl$JAXPSAXParser.parse(SAXParserImpl.java:522)
	at javax.xml.parsers.SAXParser.parse(SAXParser.java:395)
	at org.openstreetmap.josm.io.OsmReader.parseDataSet(OsmReader.java:551)
	... 10 more

Attachments (0)

Change History (7)

comment:1 Changed 10 years ago by mjulius

Resolution: duplicate
Status: newclosed

comment:2 Changed 10 years ago by mjulius

Closed as duplicate of #4548.

comment:3 Changed 10 years ago by bastiK

Resolution: duplicate
Status: closedreopened
Summary: Ctrl+L + http...Open Location (Ctrl+L) should cope with certain URLs that don't lead to xml data

Open Location should be less harsh and treat certain url types in a special way:

open as if it was entered in bbox tab of download dialog

should be translated to http://www.openstreetmap.org/api/0.6/way/27796130.

(Also give a proper message box for unexpected data, not "this is always a coding error".)

comment:4 Changed 10 years ago by mjulius

Type: defectenhancement

comment:5 Changed 10 years ago by Gubaer

(In [3069]) see #4588: Open Location (Ctrl+L) should cope with certain URLs that don't lead to xml data

comment:6 Changed 10 years ago by Gubaer

(Also give a proper message box for unexpected data, not "this is always a coding error".)

r3069 fixes this sub-issue only.

comment:7 Changed 6 years ago by Don-vip

Description: modified (diff)
Resolution: fixed
Status: reopenedclosed

Fixed in r4996.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.