Modify

Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#4547 closed defect (duplicate)

Java error after uploading changeset removing several duplicate nodes on same position

Reported by: Claudius Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. Removed several (more than 65 in one example; More than 150 in another example) duplicate nodes on one (!) position
  2. upload the changes

What is the expected result?
Upload should finish and repaint should take place.

What happens instead?
NullPointerException

Please provide any additional information below. Attach a screenshot if
possible.

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2010-02-17 02:31:41
Last Changed Author: mjulius
Revision: 2998
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2010-02-16 20:36:17 +0100 (Tue, 16 Feb 2010)
Last Changed Rev: 2998

Memory Usage: 62 MB / 62 MB (37 MB allocated, but free)
Java version: 1.6.0_17, Apple Inc., Java HotSpot(TM) Client VM
Operating system: Mac OS X

Dataset consistency test:
No problems found


Plugins: remotecontrol,validator,wmsplugin
Plugin wmsplugin Version: 18953
Plugin remotecontrol Version: 18678
Plugin validator Version: 19200

org.openstreetmap.josm.io.OsmTransferException: java.lang.NullPointerException
	at org.openstreetmap.josm.gui.io.UploadPrimitivesTask.cleanupAfterUpload(UploadPrimitivesTask.java:225)
	at org.openstreetmap.josm.gui.io.UploadPrimitivesTask.realRun(UploadPrimitivesTask.java:294)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.doRealRun(PleaseWaitRunnable.java:83)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.run(PleaseWaitRunnable.java:129)
	at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
	at java.lang.Thread.run(Thread.java:637)
Caused by: java.lang.NullPointerException
	at org.openstreetmap.josm.data.osm.QuadBuckets$QBLevel.next_sibling(QuadBuckets.java:278)
	at org.openstreetmap.josm.data.osm.QuadBuckets$QBLevel.nextSibling(QuadBuckets.java:315)
	at org.openstreetmap.josm.data.osm.QuadBuckets$QBLevel.nextNode(QuadBuckets.java:347)
	at org.openstreetmap.josm.data.osm.QuadBuckets$QBLevel.nextContentNode(QuadBuckets.java:352)
	at org.openstreetmap.josm.data.osm.QuadBuckets$QuadBucketIterator.next_content_node(QuadBuckets.java:852)
	at org.openstreetmap.josm.data.osm.QuadBuckets$QuadBucketIterator.peek(QuadBuckets.java:899)
	at org.openstreetmap.josm.data.osm.QuadBuckets$QuadBucketIterator.hasNext(QuadBuckets.java:877)
	at org.openstreetmap.josm.data.osm.DataSet.cleanupDeleted(DataSet.java:940)
	at org.openstreetmap.josm.data.osm.DataSet.clenupDeletedPrimitives(DataSet.java:931)
	at org.openstreetmap.josm.gui.layer.OsmDataLayer.cleanupAfterUpload(OsmDataLayer.java:467)
	at org.openstreetmap.josm.gui.io.UploadPrimitivesTask$1.run(UploadPrimitivesTask.java:213)
	at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:199)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:633)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:296)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:211)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:205)
	at java.awt.Dialog$1.run(Dialog.java:1045)
	at java.awt.Dialog$3.run(Dialog.java:1097)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.awt.Dialog.show(Dialog.java:1095)
	at java.awt.Component.show(Component.java:1563)
	at java.awt.Component.setVisible(Component.java:1515)
	at java.awt.Window.setVisible(Window.java:841)
	at java.awt.Dialog.setVisible(Dialog.java:985)
	at org.openstreetmap.josm.gui.progress.PleaseWaitProgressMonitor$3.run(PleaseWaitProgressMonitor.java:83)
	at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:209)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:633)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:296)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:211)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:201)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:196)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:188)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:122)

Attachments (0)

Change History (2)

comment:1 Changed 10 years ago by mjulius

Resolution: duplicate
Status: newclosed

comment:2 Changed 10 years ago by mjulius

Closed as duplicate of #4536.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.