Modify

Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#4536 closed defect (fixed)

Exception after upload

Reported by: bilbo Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: Cc:

Description

Sometimes (about in 1 of 50 uploads) when I try to upload something to server, it get uploaded successfully, but then after upload I got this exception. If I dismiss the exception, I can find out (by redownloading affected area) that my changes were already uploaded to server, but JOSM still think there are some modified objects to upload (which have been in fact already uploaded) and upload attempt will then lead to a conflict - basically you have to redownload working area to resume editing.

Build-Date: 2010-02-15 04:07:18
Revision: 2989
Is-Local-Build: true

Memory Usage: 887 MB / 989 MB (87 MB allocated, but free)
Java version: 1.6.0_17, Sun Microsystems Inc., Java HotSpot(TM) 64-Bit Server VM
Operating system: Linux

Dataset consistency test:
No problems found

Plugins: openstreetbugs,wmsplugin,tracer,remotecontrol,buildings_tools,validator,terracer2,graphview,multipoly,measurement
Plugin openstreetbugs Version: 19463
Plugin wmsplugin Version: 19626
Plugin tracer Version: 19985
Plugin remotecontrol Version: 19471
Plugin buildings_tools Version: 30
Plugin validator Version: 19688
Plugin terracer2 Version: ${version.entry.commit.revision}
Plugin graphview Version: 19441
Plugin measurement Version: 19681
Plugin multipoly Version: 19456

org.openstreetmap.josm.io.OsmTransferException: java.lang.NullPointerException

at org.openstreetmap.josm.gui.io.UploadPrimitivesTask.cleanupAfterUpload(UploadPrimitivesTask.java:224)
at org.openstreetmap.josm.gui.io.UploadPrimitivesTask.realRun(UploadPrimitivesTask.java:293)
at org.openstreetmap.josm.gui.PleaseWaitRunnable.doRealRun(PleaseWaitRunnable.java:82)
at org.openstreetmap.josm.gui.PleaseWaitRunnable.run(PleaseWaitRunnable.java:128)
at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
at java.lang.Thread.run(Thread.java:619)

Caused by: java.lang.NullPointerException

at org.openstreetmap.josm.data.osm.QuadBuckets$QBLevel.next_sibling(QuadBuckets.java:278)
at org.openstreetmap.josm.data.osm.QuadBuckets$QBLevel.nextSibling(QuadBuckets.java:315)
at org.openstreetmap.josm.data.osm.QuadBuckets$QBLevel.nextNode(QuadBuckets.java:347)
at org.openstreetmap.josm.data.osm.QuadBuckets$QBLevel.nextContentNode(QuadBuckets.java:352)
at org.openstreetmap.josm.data.osm.QuadBuckets$QuadBucketIterator.next_content_node(QuadBuckets.java:852)
at org.openstreetmap.josm.data.osm.QuadBuckets$QuadBucketIterator.peek(QuadBuckets.java:899)
at org.openstreetmap.josm.data.osm.QuadBuckets$QuadBucketIterator.hasNext(QuadBuckets.java:877)
at org.openstreetmap.josm.data.osm.DataSet.cleanupDeleted(DataSet.java:918)
at org.openstreetmap.josm.data.osm.DataSet.clenupDeletedPrimitives(DataSet.java:909)
at org.openstreetmap.josm.gui.layer.OsmDataLayer.cleanupAfterUpload(OsmDataLayer.java:467)
at org.openstreetmap.josm.gui.io.UploadPrimitivesTask$1.run(UploadPrimitivesTask.java:212)
at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:199)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:597)
at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:269)
at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:184)
at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:178)
at java.awt.Dialog$1.run(Dialog.java:1045)
at java.awt.Dialog$3.run(Dialog.java:1097)
at java.security.AccessController.doPrivileged(Native Method)
at java.awt.Dialog.show(Dialog.java:1095)
at java.awt.Component.show(Component.java:1563)
at java.awt.Component.setVisible(Component.java:1515)
at java.awt.Window.setVisible(Window.java:841)
at java.awt.Dialog.setVisible(Dialog.java:985)
at org.openstreetmap.josm.gui.progress.PleaseWaitProgressMonitor$3.run(PleaseWaitProgressMonitor.java:83)
at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:209)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:597)
at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:269)
at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:184)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:174)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:169)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:161)
at java.awt.EventDispatchThread.run(EventDispatchThread.java:122)

Attachments (0)

Change History (4)

comment:1 Changed 10 years ago by Gubaer

This reminds me that I've been running into the same issue, but that I forgot to report it.

comment:2 Changed 10 years ago by jttt

Resolution: fixed
Status: newclosed

(In [3000]) Fix #4536 Exception after upload

comment:3 Changed 10 years ago by mjulius

Ticket #4544 has been marked as a duplicate of this ticket.

comment:4 Changed 10 years ago by mjulius

Ticket #4547 has been marked as a duplicate of this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.