Modify

Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#4544 closed defect (duplicate)

NPE after uploading

Reported by: anonymous Owned by: team
Priority: normal Milestone:
Component: Core Version: latest
Keywords: Cc:

Description

org.openstreetmap.josm.io.OsmTransferException: java.lang.NullPointerException
        at org.openstreetmap.josm.gui.io.UploadPrimitivesTask.cleanupAfterUpload
(UploadPrimitivesTask.java:225)
        at org.openstreetmap.josm.gui.io.UploadPrimitivesTask.realRun(UploadPrim
itivesTask.java:294)
        at org.openstreetmap.josm.gui.PleaseWaitRunnable.doRealRun(PleaseWaitRun
nable.java:83)
        at org.openstreetmap.josm.gui.PleaseWaitRunnable.run(PleaseWaitRunnable.
java:129)
        at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source
)
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
        at java.lang.Thread.run(Unknown Source)
Caused by: java.lang.NullPointerException
        at org.openstreetmap.josm.data.osm.QuadBuckets$QBLevel.next_sibling(Quad
Buckets.java:278)
        at org.openstreetmap.josm.data.osm.QuadBuckets$QBLevel.nextSibling(QuadB
uckets.java:315)
        at org.openstreetmap.josm.data.osm.QuadBuckets$QBLevel.nextNode(QuadBuck
ets.java:347)
        at org.openstreetmap.josm.data.osm.QuadBuckets$QBLevel.nextContentNode(Q
uadBuckets.java:352)
        at org.openstreetmap.josm.data.osm.QuadBuckets$QuadBucketIterator.next_c
ontent_node(QuadBuckets.java:852)
        at org.openstreetmap.josm.data.osm.QuadBuckets$QuadBucketIterator.peek(Q
uadBuckets.java:899)
        at org.openstreetmap.josm.data.osm.QuadBuckets$QuadBucketIterator.hasNex
t(QuadBuckets.java:877)
        at org.openstreetmap.josm.data.osm.DataSet.cleanupDeleted(DataSet.java:9
40)
        at org.openstreetmap.josm.data.osm.DataSet.clenupDeletedPrimitives(DataS
et.java:931)
        at org.openstreetmap.josm.gui.layer.OsmDataLayer.cleanupAfterUpload(OsmD
ataLayer.java:467)
        at org.openstreetmap.josm.gui.io.UploadPrimitivesTask$1.run(UploadPrimit
ivesTask.java:213)
        at java.awt.event.InvocationEvent.dispatch(Unknown Source)
        at java.awt.EventQueue.dispatchEvent(Unknown Source)
        at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
        at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
        at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
        at java.awt.Dialog$1.run(Unknown Source)
        at java.awt.Dialog$3.run(Unknown Source)
        at java.security.AccessController.doPrivileged(Native Method)
        at java.awt.Dialog.show(Unknown Source)
        at java.awt.Component.show(Unknown Source)
        at java.awt.Component.setVisible(Unknown Source)
        at java.awt.Window.setVisible(Unknown Source)
        at java.awt.Dialog.setVisible(Unknown Source)
        at org.openstreetmap.josm.gui.progress.PleaseWaitProgressMonitor$3.run(P
leaseWaitProgressMonitor.java:83)
        at java.awt.event.InvocationEvent.dispatch(Unknown Source)
        at java.awt.EventQueue.dispatchEvent(Unknown Source)
        at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
        at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
        at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
        at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
        at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
        at java.awt.EventDispatchThread.run(Unknown Source)
org.openstreetmap.josm.io.OsmTransferException: java.lang.NullPointerException
        at org.openstreetmap.josm.gui.io.UploadPrimitivesTask.cleanupAfterUpload
(UploadPrimitivesTask.java:225)
        at org.openstreetmap.josm.gui.io.UploadPrimitivesTask.realRun(UploadPrim
itivesTask.java:294)
        at org.openstreetmap.josm.gui.PleaseWaitRunnable.doRealRun(PleaseWaitRun
nable.java:83)
        at org.openstreetmap.josm.gui.PleaseWaitRunnable.run(PleaseWaitRunnable.
java:129)
        at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source
)
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
        at java.lang.Thread.run(Unknown Source)
Caused by: java.lang.NullPointerException
        at org.openstreetmap.josm.data.osm.QuadBuckets$QBLevel.next_sibling(Quad
Buckets.java:278)
        at org.openstreetmap.josm.data.osm.QuadBuckets$QBLevel.nextSibling(QuadB
uckets.java:315)
        at org.openstreetmap.josm.data.osm.QuadBuckets$QBLevel.nextNode(QuadBuck
ets.java:347)
        at org.openstreetmap.josm.data.osm.QuadBuckets$QBLevel.nextContentNode(Q
uadBuckets.java:352)
        at org.openstreetmap.josm.data.osm.QuadBuckets$QuadBucketIterator.next_c
ontent_node(QuadBuckets.java:852)
        at org.openstreetmap.josm.data.osm.QuadBuckets$QuadBucketIterator.peek(Q
uadBuckets.java:899)
        at org.openstreetmap.josm.data.osm.QuadBuckets$QuadBucketIterator.hasNex
t(QuadBuckets.java:877)
        at org.openstreetmap.josm.data.osm.DataSet.cleanupDeleted(DataSet.java:9
40)
        at org.openstreetmap.josm.data.osm.DataSet.clenupDeletedPrimitives(DataS
et.java:931)
        at org.openstreetmap.josm.gui.layer.OsmDataLayer.cleanupAfterUpload(OsmD
ataLayer.java:467)
        at org.openstreetmap.josm.gui.io.UploadPrimitivesTask$1.run(UploadPrimit
ivesTask.java:213)
        at java.awt.event.InvocationEvent.dispatch(Unknown Source)
        at java.awt.EventQueue.dispatchEvent(Unknown Source)
        at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
        at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
        at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
        at java.awt.Dialog$1.run(Unknown Source)
        at java.awt.Dialog$3.run(Unknown Source)
        at java.security.AccessController.doPrivileged(Native Method)
        at java.awt.Dialog.show(Unknown Source)
        at java.awt.Component.show(Unknown Source)
        at java.awt.Component.setVisible(Unknown Source)
        at java.awt.Window.setVisible(Unknown Source)
        at java.awt.Dialog.setVisible(Unknown Source)
        at org.openstreetmap.josm.gui.progress.PleaseWaitProgressMonitor$3.run(P
leaseWaitProgressMonitor.java:83)
        at java.awt.event.InvocationEvent.dispatch(Unknown Source)
        at java.awt.EventQueue.dispatchEvent(Unknown Source)
        at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
        at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
        at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
        at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
        at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
        at java.awt.EventDispatchThread.run(Unknown Source)

Attachments (0)

Change History (2)

comment:1 Changed 10 years ago by mjulius

Resolution: duplicate
Status: newclosed

comment:2 Changed 10 years ago by mjulius

Closed as duplicate of #4536.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.