Modify

Opened 10 years ago

Closed 10 years ago

#4545 closed defect (fixed)

tables in josm gets blank

Reported by: vsandre Owned by: anonymous
Priority: major Milestone:
Component: Core Version: latest
Keywords: table relation upload r-2010-01-blocker Cc:

Description

All properties of a changeset gets blank if you use the up/down/left/right keys to navigate through the table.

Attachments (1)

josm_upload_dialogue.png (8.3 KB) - added by vsandre 10 years ago.

Download all attachments as: .zip

Change History (12)

Changed 10 years ago by vsandre

Attachment: josm_upload_dialogue.png added

comment:1 Changed 10 years ago by vsandre

Keywords: table relation r-2010-01-blocker added; dialogue removed
Priority: normalmajor
Summary: Upload dialogue changeset properties gets blanktables in josm gets blank

The behaviour appears not only in the upload dialogue but in the relation properties dialogue, too.

Because it is a substantial feature, I set it to release blocker.

comment:2 Changed 10 years ago by Gubaer

Doesn't happen here (Windows 7, Java 1.5)

What's your environment? Linux/Ubuntu?

comment:3 in reply to:  2 ; Changed 10 years ago by anonymous

Replying to Gubaer:

What's your environment? Linux/Ubuntu?

Windows 7 32bit, Sun Java 1.6.0_18

I found no problems while testing it with Ubuntu OpenJDK 1.6.0, too.

OpenJDK Runtime Environment (IcedTea6 1.6.1) (6b16-1.6.1-3ubuntu1)
OpenJDK Client VM (build 14.0-b16, mixed mode, sharing)

comment:4 Changed 10 years ago by Gubaer

Owner: changed from team to vsandre
Status: newneedinfo

OK, looks like a glitch in a particular OS/JVM/WM combination. Waiting for input from vsandre.

comment:5 Changed 10 years ago by vsandre

Owner: changed from vsandre to anonymous
Status: needinfonew

I have tested some older josm version. The bug was introduced between 2971 and 2976. All version including 2971 works for me.

comment:6 in reply to:  5 Changed 10 years ago by anonymous

Replying to vsandre:

I have tested some older josm version. The bug was introduced between 2971 and 2976. All version including 2971 works for me.

Probably r2974

comment:7 in reply to:  5 Changed 10 years ago by Gubaer

Replying to vsandre:

I have tested some older josm version. The bug was introduced between 2971 and 2976. All version including 2971 works for me.

OK. And what's your OS/JVM/WM combination?

comment:8 in reply to:  3 Changed 10 years ago by vsandre

Replying to anonymous:

Replying to Gubaer:

What's your environment? Linux/Ubuntu?

Windows 7 32bit, Sun Java 1.6.0_18

that's it. ;-)

comment:9 Changed 10 years ago by Gubaer

ah, anonymous was you ;-) OK then, I'll see what I can do.

comment:10 Changed 10 years ago by mjulius

Ticket #4575 has been marked as a duplicate of this ticket.

comment:11 Changed 10 years ago by Gubaer

Resolution: fixed
Status: newclosed

(In [3022]) fixed #4545: tables in josm gets blank

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain anonymous.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.