Modify

Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#4364 closed defect (fixed)

editing an "advanced preference" will disable all plugins

Reported by: telegnom Owned by: Gubaer
Priority: normal Milestone:
Component: Core Version: latest
Keywords: Cc:

Description

I usually start JOSM with several plugins. I edited a setting in the "Advanced Preferences" and restarted JOSM. Then when restarting JOSM no plugins were loaded. I could reproduce the error several times.

What todo to reproduce the error:

Start JOSM with some plugins -> open the preference dialog -> click on "advanced preferences" (the button with the white page and the wrench) -> edit any value -> confirm with ok -> restart josm -> all plugins have been disabled

This error occurs in version 2833

Attachments (3)

josm_2833_error_1.png (57.2 KB) - added by telegnom 11 years ago.
plugins loaded
josm_2833_error_2.png (71.7 KB) - added by telegnom 11 years ago.
editing anything
josm_2833_error_3.png (36.4 KB) - added by telegnom 11 years ago.
all plugins are gone

Download all attachments as: .zip

Change History (8)

Changed 11 years ago by telegnom

Attachment: josm_2833_error_1.png added

plugins loaded

Changed 11 years ago by telegnom

Attachment: josm_2833_error_2.png added

editing anything

Changed 11 years ago by telegnom

Attachment: josm_2833_error_3.png added

all plugins are gone

comment:1 Changed 11 years ago by stoecker

Owner: changed from team to Gubaer

@Gubaer: I think here lies the reason for the other "plugin vanishs" report.

comment:2 Changed 11 years ago by malenki

Happens also with Josm version 2841.

comment:3 Changed 11 years ago by telegnom

There was no such error in the latest version of yesterday (2813)

comment:4 Changed 11 years ago by Gubaer

Resolution: fixed
Status: newclosed

(In [2855]) fixed #4364: editing an "advanced preference" will disable all plugins
fixed #4351: Button sizes in plugin preferences different (last button is smaller)

comment:5 in reply to:  1 Changed 11 years ago by Ldp

Replying to stoecker:

@Gubaer: I think here lies the reason for the other "plugin vanishs" report.

#4354 could conceivably have been the same issue.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Gubaer.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.