Modify

Opened 11 years ago

Closed 10 years ago

Last modified 10 years ago

#4363 closed defect (duplicate)

validator: "end of way close to other way" - don't warn if layer tag is different (was: check for noexit=yes)

Reported by: skyper Owned by: team
Priority: minor Milestone:
Component: Core Version: latest
Keywords: validator noexit Cc:

Description

If there exists a tag noexit=yes on the last node of a way,

Please do not warn about "end of way close to other way"

Attachments (2)

validator_noexit.osm (6.8 KB) - added by skyper 11 years ago.
osm
bug_4363.osm (3.3 KB) - added by skyper 10 years ago.
layer example

Download all attachments as: .zip

Change History (12)

Changed 11 years ago by skyper

Attachment: validator_noexit.osm added

osm

comment:1 Changed 11 years ago by skyper

Keywords: validator noexit added
Priority: trivialminor

comment:2 Changed 10 years ago by skyper

Component: Core validatorCore

Validator is in Core now but still warns.

I also think it should not warn about a node with a different layer-tag.

r3695

comment:3 Changed 10 years ago by bastiK

Resolution: fixed
Status: newclosed

In [3699/josm]:

fixed #4363 - validator: check for noexit=yes before warning about "end of way close to other way"

comment:4 Changed 10 years ago by bastiK

Haven't done the layer part, please give example

comment:5 Changed 10 years ago by anonymous

Here you go

Please also add railway=buffer_stop.

Thanks a lot !
skyper

Changed 10 years ago by skyper

Attachment: bug_4363.osm added

layer example

comment:6 Changed 10 years ago by skyper

JOSM also warns if the layer tag is on the way. A bridge for example.

comment:7 in reply to:  4 Changed 10 years ago by skyper

Replying to bastiK:

Haven't done the layer part, please give example

Do we need a seperate ticket for that ? Or do you remember ?

comment:8 Changed 10 years ago by bastiK

Resolution: fixed
Status: closedreopened
Summary: validator: check for noexit=yes before warning about "end of way close to other way"validator: "end of way close to other way" - don't warn if layer tag is different (was: check for noexit=yes)

comment:9 Changed 10 years ago by bastiK

Resolution: duplicate
Status: reopenedclosed

comment:10 Changed 10 years ago by bastiK

Closed as duplicate of #3531.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.