Modify

Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#4159 closed defect (fixed)

NPE when deleting a data layer

Reported by: Daeron Owned by: team
Priority: normal Milestone:
Component: Core Version: latest
Keywords: Cc:

Description

I got a NPE when I deleted a data-layer. I also had one WMS-layer.

Build-Date: 2009-12-13 00:20:01		
Revision: 2623
Is-Local-Build: true

Memory Usage: 442 MB / 910 MB (137 MB allocated, but free)
Java version: 1.6.0_17


Plugins: PicLayer,lakewalker,measurement,validator,wmsplugin
Plugin PicLayer Version: 19062
Plugin lakewalker Version: 18962
Plugin measurement Version: 19058
Plugin validator Version: 19072
Plugin wmsplugin Version: 18953

java.lang.NullPointerException
	at org.openstreetmap.josm.data.osm.event.DatasetEventManager.activeLayerChange(DatasetEventManager.java:71)
	at org.openstreetmap.josm.gui.MapView.fireActiveLayerChanged(MapView.java:107)
	at org.openstreetmap.josm.gui.MapView.removeLayer(MapView.java:327)
	at org.openstreetmap.josm.Main.removeLayer(Main.java:188)
	at org.openstreetmap.josm.gui.dialogs.LayerListDialog$DeleteLayerAction.actionPerformed(LayerListDialog.java:313)
	at javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:1995)
	at javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.java:2318)
	at javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:387)
	at javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:242)
	at javax.swing.plaf.basic.BasicButtonListener.mouseReleased(BasicButtonListener.java:236)
	at java.awt.AWTEventMulticaster.mouseReleased(AWTEventMulticaster.java:272)
	at java.awt.Component.processMouseEvent(Component.java:6263)
	at javax.swing.JComponent.processMouseEvent(JComponent.java:3255)
	at java.awt.Component.processEvent(Component.java:6028)
	at java.awt.Container.processEvent(Container.java:2041)
	at java.awt.Component.dispatchEventImpl(Component.java:4630)
	at java.awt.Container.dispatchEventImpl(Container.java:2099)
	at java.awt.Component.dispatchEvent(Component.java:4460)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4574)
	at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4238)
	at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4168)
	at java.awt.Container.dispatchEventImpl(Container.java:2085)
	at java.awt.Window.dispatchEventImpl(Window.java:2475)
	at java.awt.Component.dispatchEvent(Component.java:4460)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:599)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:269)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:184)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:174)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:169)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:161)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:122)

Attachments (0)

Change History (4)

comment:1 Changed 12 years ago by Gubaer

Resolution: fixed
Status: newclosed

(In [2625]) fixed #4159: NPE when deleting a data layer

comment:2 Changed 12 years ago by anonymous

Ticket #4158 has been marked as a duplicate of this ticket.

comment:3 Changed 12 years ago by anonymous

Ticket #4173 has been marked as a duplicate of this ticket.

comment:4 Changed 12 years ago by anonymous

Ticket #4174 has been marked as a duplicate of this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.