Modify

Opened 14 years ago

Closed 14 years ago

Last modified 14 years ago

#4173 closed defect (duplicate)

Crash when removing layer above slippymap

Reported by: orrc Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. Have the slippymap plugin active
  2. Open a .osm file
  3. The .osm is rendered, with the slippymap layer beneath
  4. In Layers, select the .osm layer and press the "Delete layer" button

What is the expected result?
The loaded layer is removed, leaving only the underlying slippy map.

What happens instead?
Crash.

Please provide any additional information below. Attach a screenshot if
possible.

Build-Date: 2009-12-13 02:31:40
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Author: jttt
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last Changed Date: 2009-12-12 21:25:10 +0100 (Sat, 12 Dec 2009)
Last Changed Rev: 2623
Repository Root: http://josm.openstreetmap.de/svn
Revision: 2623

Memory Usage: 63 MB / 63 MB (10 MB allocated, but free)
Java version: 1.5.0_20


Plugins: slippymap
Plugin slippymap Version: 19070

java.lang.NullPointerException
	at org.openstreetmap.josm.data.osm.event.DatasetEventManager.activeLayerChange(DatasetEventManager.java:71)
	at org.openstreetmap.josm.gui.MapView.fireActiveLayerChanged(MapView.java:107)
	at org.openstreetmap.josm.gui.MapView.removeLayer(MapView.java:327)
	at org.openstreetmap.josm.Main.removeLayer(Main.java:188)
	at org.openstreetmap.josm.gui.dialogs.LayerListDialog$DeleteLayerAction.actionPerformed(LayerListDialog.java:313)
	at javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:1882)
	at javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.java:2202)
	at javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:420)
	at javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:258)
	at javax.swing.plaf.basic.BasicButtonListener.mouseReleased(BasicButtonListener.java:236)
	at java.awt.AWTEventMulticaster.mouseReleased(AWTEventMulticaster.java:231)
	at java.awt.Component.processMouseEvent(Component.java:5602)
	at javax.swing.JComponent.processMouseEvent(JComponent.java:3135)
	at java.awt.Component.processEvent(Component.java:5367)
	at java.awt.Container.processEvent(Container.java:2010)
	at java.awt.Component.dispatchEventImpl(Component.java:4068)
	at java.awt.Container.dispatchEventImpl(Container.java:2068)
	at java.awt.Component.dispatchEvent(Component.java:3903)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4256)
	at java.awt.LightweightDispatcher.processMouseEvent(Container.java:3936)
	at java.awt.LightweightDispatcher.dispatchEvent(Container.java:3866)
	at java.awt.Container.dispatchEventImpl(Container.java:2054)
	at java.awt.Window.dispatchEventImpl(Window.java:1801)
	at java.awt.Component.dispatchEvent(Component.java:3903)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:463)
	at java.awt.EventDispatchThread.pumpOneEventForHierarchy(EventDispatchThread.java:269)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:190)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:184)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:176)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:110)

Attachments (0)

Change History (2)

comment:1 by jttt, 14 years ago

Resolution: duplicate
Status: newclosed

comment:2 by anonymous, 14 years ago

Closed as duplicate of #4159.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.