Modify

Opened 14 years ago

Closed 14 years ago

Last modified 14 years ago

#4158 closed defect (duplicate)

error when opening file

Reported by: anonymous Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: template_report Cc:

Description

opened gpx-file by commandline option -> error

Build-Date: 2009-12-12 23:14:11		
Revision: 2623
Is-Local-Build: true

Memory Usage: 37 MB / 595 MB (12 MB allocated, but free)
Java version: 1.6.0_15



java.lang.NullPointerException
	at org.openstreetmap.josm.data.osm.event.DatasetEventManager.activeLayerChange(DatasetEventManager.java:71)
	at org.openstreetmap.josm.gui.MapView.fireActiveLayerChanged(MapView.java:107)
	at org.openstreetmap.josm.gui.MapView.setActiveLayer(MapView.java:581)
	at org.openstreetmap.josm.gui.MapView.addLayer(MapView.java:248)
	at org.openstreetmap.josm.Main.addLayer(Main.java:246)
	at org.openstreetmap.josm.io.GpxImporter$1.run(GpxImporter.java:56)
	at org.openstreetmap.josm.io.GpxImporter.importData(GpxImporter.java:67)
	at org.openstreetmap.josm.actions.OpenFileAction.openFile(OpenFileAction.java:60)
	at org.openstreetmap.josm.Main.downloadFromParamString(Main.java:498)
	at org.openstreetmap.josm.Main.postConstructorProcessCmdLine(Main.java:377)
	at org.openstreetmap.josm.gui.MainApplication$2.run(MainApplication.java:164)
	at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:209)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:597)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:269)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:184)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:174)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:169)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:161)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:122)

Attachments (0)

Change History (2)

comment:1 by jttt, 14 years ago

Resolution: duplicate
Status: newclosed

comment:2 by anonymous, 14 years ago

Closed as duplicate of #4159.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.