Modify

Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#3871 closed defect (duplicate)

Error merging layers

Reported by: anonymous Owned by: team
Priority: normal Milestone:
Component: Core Version: latest
Keywords: Cc:

Description

First layer opened:
downloaded area: 49.6712, 8.6127, 49.6862, 8.6311

Second layer:
Edit, Open Address:
http://www.openstreetmap.org/api/0.6/relation/223649
Create new layer was selected.

After that I did 'Edit, Merge Layers'.
Result could was the error message you find below.

Opening the second layer without creating a new layer (which probably does an internal merge) did also result into an error, but without detailed description.
Error happens in both versions: tested and latest.

thanks for josm and having a look at this!!!! Great stuff!!

regards

Peter

Repository Root: http://josm.openstreetmap.de/svn
Build-Date: 2009-11-08 02:31:21
Last Changed Author: jttt
Revision: 2405
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
URL: http://josm.openstreetmap.de/svn/trunk
Last Changed Date: 2009-11-07 20:28:14 +0100 (Sat, 07 Nov 2009)
Last Changed Rev: 2405

Memory Usage: 75 MB / 485 MB (38 MB allocated, but free)
Java version: 1.6.0_07

Plugins: editgpxmeasurementopenvisibleremotecontroltageditorutilspluginvalidatorwmsplugin
Plugin editgpx Version: 18426
Plugin measurement Version: 17377
Plugin openvisible Version: 17536
Plugin remotecontrol Version: 18503
Plugin tageditor Version: 18500
Plugin utilsplugin Version: 18503
Plugin validator Version: 18453
Plugin wmsplugin Version: 18408

org.openstreetmap.josm.data.osm.DataIntegrityProblemException: Primitive cannot be included in more than one Dataset

at org.openstreetmap.josm.data.osm.OsmPrimitive.setDataset(OsmPrimitive.java:142)
at org.openstreetmap.josm.data.osm.DataSet.addPrimitive(DataSet.java:192)
at org.openstreetmap.josm.data.osm.visitor.MergeVisitor.mergePrimitive(MergeVisitor.java:137)
at org.openstreetmap.josm.data.osm.visitor.MergeVisitor.visit(MergeVisitor.java:146)
at org.openstreetmap.josm.data.osm.Way.visit(Way.java:127)
at org.openstreetmap.josm.data.osm.visitor.MergeVisitor.merge(MergeVisitor.java:340)
at org.openstreetmap.josm.gui.layer.OsmDataLayer.mergeFrom(OsmDataLayer.java:280)
at org.openstreetmap.josm.gui.layer.OsmDataLayer.mergeFrom(OsmDataLayer.java:269)
at org.openstreetmap.josm.actions.MergeLayerAction.merge(MergeLayerAction.java:37)
at org.openstreetmap.josm.actions.MergeLayerAction.actionPerformed(MergeLayerAction.java:46)
at javax.swing.AbstractButton.fireActionPerformed(Unknown Source)
at javax.swing.AbstractButton$Handler.actionPerformed(Unknown Source)
at javax.swing.DefaultButtonModel.fireActionPerformed(Unknown Source)
at javax.swing.DefaultButtonModel.setPressed(Unknown Source)
at javax.swing.AbstractButton.doClick(Unknown Source)
at javax.swing.plaf.basic.BasicMenuItemUI.doClick(Unknown Source)
at javax.swing.plaf.basic.BasicMenuItemUI$Handler.mouseReleased(Unknown Source)
at java.awt.AWTEventMulticaster.mouseReleased(Unknown Source)
at java.awt.Component.processMouseEvent(Unknown Source)
at javax.swing.JComponent.processMouseEvent(Unknown Source)
at java.awt.Component.processEvent(Unknown Source)
at java.awt.Container.processEvent(Unknown Source)
at java.awt.Component.dispatchEventImpl(Unknown Source)
at java.awt.Container.dispatchEventImpl(Unknown Source)
at java.awt.Component.dispatchEvent(Unknown Source)
at java.awt.LightweightDispatcher.retargetMouseEvent(Unknown Source)
at java.awt.LightweightDispatcher.processMouseEvent(Unknown Source)
at java.awt.LightweightDispatcher.dispatchEvent(Unknown Source)
at java.awt.Container.dispatchEventImpl(Unknown Source)
at java.awt.Window.dispatchEventImpl(Unknown Source)
at java.awt.Component.dispatchEvent(Unknown Source)
at java.awt.EventQueue.dispatchEvent(Unknown Source)
at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.run(Unknown Source)

Attachments (0)

Change History (2)

comment:1 Changed 12 years ago by anonymous

Resolution: duplicate
Status: newclosed

comment:2 Changed 12 years ago by anonymous

Closed as duplicate of #3863.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.