Modify

Opened 12 years ago

Closed 12 years ago

#3870 closed defect (fixed)

Exception during upload

Reported by: Daeron Owned by: team
Priority: normal Milestone:
Component: Core Version: latest
Keywords: Cc:

Description

I just uploaded some changes, and got an exception:

Build-Date: 2009-11-08 18:54:19
Revision: 2412
Is-Local-Build: true

...

org.openstreetmap.josm.io.OsmTransferException: org.openstreetmap.josm.data.osm.DataIntegrityProblemException: Id cannot be changed after primitive was added to the dataset
        at org.openstreetmap.josm.io.OsmApi.uploadDiff(OsmApi.java:430)
        at org.openstreetmap.josm.io.OsmServerWriter.uploadChangesAsDiffUpload(OsmServerWriter.java:116)
        at org.openstreetmap.josm.io.OsmServerWriter.uploadOsm(OsmServerWriter.java:163)
        at org.openstreetmap.josm.actions.UploadAction$UploadPrimitivesTask.realRun(UploadAction.java:637)
        at org.openstreetmap.josm.gui.PleaseWaitRunnable.doRealRun(PleaseWaitRunnable.java:63)
        at org.openstreetmap.josm.gui.PleaseWaitRunnable.run(PleaseWaitRunnable.java:105)
        at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
        at java.lang.Thread.run(Thread.java:619)
Caused by: org.openstreetmap.josm.data.osm.DataIntegrityProblemException: Id cannot be changed after primitive was added to the dataset
        at org.openstreetmap.josm.data.osm.OsmPrimitive.setOsmId(OsmPrimitive.java:388)
        at org.openstreetmap.josm.io.DiffResultReader.visit(DiffResultReader.java:100)
        at org.openstreetmap.josm.data.osm.Node.visit(Node.java:100)
        at org.openstreetmap.josm.io.DiffResultReader.parseDiffResult(DiffResultReader.java:85)
        at org.openstreetmap.josm.io.OsmApi.uploadDiff(OsmApi.java:424)

The changes were uploaded correctly, but the changeset was not closed.

Attachments (0)

Change History (1)

comment:1 Changed 12 years ago by jttt

Resolution: fixed
Status: newclosed

(In [2415]) Fixed #3870 Exception during upload

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.