Modify

Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#3872 closed defect (duplicate)

Problem while downloading a specific map area from the OSM server

Reported by: Atalanttore Owned by: team
Priority: normal Milestone:
Component: Core Version: latest
Keywords: Cc:

Description

Hi

I'm using JOSM version 2405 and experienced a problem while downloading a specific map area from the OSM server. It appeared an error message (see attachment) and the log was:

GET http://www.openstreetmap.org/api/0.6/map?bbox=12.498836517333984,49.07262890419715,12.512741088867188,49.07993798570057
java.lang.reflect.InvocationTargetException
	at java.awt.EventQueue.invokeAndWait(EventQueue.java:1000)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.doRealRun(PleaseWaitRunnable.java:68)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.run(PleaseWaitRunnable.java:105)
	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)
	at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334)
	at java.util.concurrent.FutureTask.run(FutureTask.java:166)
GET http://www.openstreetmap.org/api/0.6/trackpoints?bbox=12.498836517333984,49.07262890419715,12.512741088867188,49.07993798570057&page=0	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)

	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
	at java.lang.Thread.run(Thread.java:636)
Caused by: org.openstreetmap.josm.data.osm.DataIntegrityProblemException: Primitive cannot be included in more than one Dataset
	at org.openstreetmap.josm.data.osm.OsmPrimitive.setDataset(OsmPrimitive.java:142)
	at org.openstreetmap.josm.data.osm.DataSet.addPrimitive(DataSet.java:192)
	at org.openstreetmap.josm.data.osm.visitor.MergeVisitor.mergePrimitive(MergeVisitor.java:137)
	at org.openstreetmap.josm.data.osm.visitor.MergeVisitor.visit(MergeVisitor.java:141)
	at org.openstreetmap.josm.data.osm.Node.visit(Node.java:88)
	at org.openstreetmap.josm.data.osm.visitor.MergeVisitor.merge(MergeVisitor.java:340)
	at org.openstreetmap.josm.gui.layer.OsmDataLayer.mergeFrom(OsmDataLayer.java:280)
	at org.openstreetmap.josm.actions.downloadtasks.DownloadOsmTask$DownloadTask.finish(DownloadOsmTask.java:159)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable$1.run(PleaseWaitRunnable.java:70)
	at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:216)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:602)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:275)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:200)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:194)
	at java.awt.Dialog$1.run(Dialog.java:1072)
	at java.awt.Dialog$3.run(Dialog.java:1126)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.awt.Dialog.show(Dialog.java:1124)
	at java.awt.Component.show(Component.java:1464)
	at java.awt.Component.setVisible(Component.java:1416)
	at java.awt.Window.setVisible(Window.java:842)
	at java.awt.Dialog.setVisible(Dialog.java:1011)
	at org.openstreetmap.josm.gui.progress.PleaseWaitProgressMonitor$3.run(PleaseWaitProgressMonitor.java:79)
	at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:226)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:602)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:275)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:200)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:190)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:185)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:177)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:138)
GET http://www.openstreetmap.org/api/0.6/trackpoints?bbox=12.498836517333984,49.07262890419715,12.512741088867188,49.07993798570057&page=1

Attachments (1)

Fehler.png (6.5 KB) - added by Atalanttore 13 years ago.
Error message

Download all attachments as: .zip

Change History (3)

Changed 13 years ago by Atalanttore

Attachment: Fehler.png added

Error message

comment:1 Changed 13 years ago by anonymous

Resolution: duplicate
Status: newclosed

comment:2 Changed 13 years ago by anonymous

Closed as duplicate of #3863.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.