Modify

Opened 12 years ago

Closed 12 years ago

#3307 closed defect (fixed)

[PATCH] Programmfehler - java.lang.NullPointerException in graphview

Reported by: anonymous Owned by: team
Priority: normal Milestone:
Component: Plugin Version:
Keywords: Cc:

Description

Wenn JOSM gestartet wird (Version 1981 + neueste Plugins) kommt ein Programmfehler:

Path: trunk
URL: http://josm.openstreetmap.de/svn/trunk
Repository Root: http://josm.openstreetmap.de/svn
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Revision: 1981
Node Kind: directory
Last Changed Author: stoecker
Last Changed Rev: 1981
Last Changed Date: 2009-08-18 15:21:37 +0200 (Tue, 18 Aug 2009)

Memory Usage: 19 MB / 63 MB (3 MB allocated, but free)
Java version: 1.6.0_15

Plugins: DirectUpload
editgpx
graphview
openstreetbugs
plastic_laf
utilsplugin
validator
wmsplugin
Plugin plastic_laf Version: 14016
Plugin DirectUpload Version: 16583
Plugin editgpx Version: 16793
Plugin graphview Version: 16836
Plugin openstreetbugs Version: 17035
Plugin utilsplugin Version: 16735
Plugin validator Version: 17175
Plugin wmsplugin Version: 16872

java.lang.NullPointerException

at org.openstreetmap.josm.gui.dialogs.ToggleDialog$3.actionPerformed(ToggleDialog.java:169)
at org.openstreetmap.josm.gui.dialogs.ToggleDialog$5.run(ToggleDialog.java:235)
at java.awt.event.InvocationEvent.dispatch(Unknown Source)
at java.awt.EventQueue.dispatchEvent(Unknown Source)
at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.run(Unknown Source)

Attachments (4)

docked.patch (1.7 KB) - added by plaicy 12 years ago.
preferences.backup.txt (4 bytes) - added by anonymous 12 years ago.
preferences (79 bytes) - added by plaicy 12 years ago.
graphview-lazy-toggledialog.patch (1.2 KB) - added by plaicy 12 years ago.

Download all attachments as: .zip

Change History (13)

comment:1 Changed 12 years ago by vsandre

Owner: changed from team to anonymous
Status: newneedinfo

Kann deinen Fehler unter Windows und mit deinen Plugins nicht nachvollziehen. Kannst du weitere Informationen zu deinem System geben?

I could not reproduce your error while using Windows and your plugins. Give more information about your system, please.

Changed 12 years ago by plaicy

Attachment: docked.patch added

comment:2 Changed 12 years ago by plaicy

Kannst du bitte außerdem deine Konfigurationsdatei schicken (ohne persönliche Daten). Wenigstens alle Zeilen mit dem Inhalt ".docked".

Could you please add your configuration file (personal data skipped). At least I need the lines containing ".docked".

The problem is caused by ToggleDialog.parent=null. I have attached a patch for testing. But I can not reproduce it here. That's why I need the configuration data.

comment:3 Changed 12 years ago by anonymous

Die einzige Zeile mit "Docked" ist folgende: graphview.docked=false

Ich füge die Datei hier als Attachment an. Löscht Du Sie bitte wieder, wenn Du sie hast? Muss ja nicht auf immer und wenig hier bleiben. Danke.

Den Patch kann ich selber leider nicht nutzen, da ich nur die kompelierte JAR-Datei habe. (Windows)

comment:4 in reply to:  3 Changed 12 years ago by plaicy

Replying to anonymous:

Ich füge die Datei hier als Attachment an. Löscht Du Sie bitte wieder, wenn Du sie hast? Muss ja nicht auf immer und wenig hier bleiben. Danke.

Ich habe die jetzt heruntergeladen. Reproduzieren konnte ich den Fehler aber damit leider nicht. Wie ich Anhänge wieder lösche weiß ich nicht.

Den Patch kann ich selber leider nicht nutzen, da ich nur die kompelierte JAR-Datei habe. (Windows)

Eventuell hilft es wenn du die Zeile mit "docked" entfernst. Außerdem eventuell noch graphview.minimized=true. Wenn das nichts hilft und es dringend ist. Schreibe mir sonst eine E-Mail (username+gmail+dot+com). Ich kann dir dann eine compilierte Version (mit patch) zuschicken.

comment:5 Changed 12 years ago by plaicy

Owner: changed from anonymous to plaicy
Status: needinfoassigned

Ich kann den Fehler jetzt doch reproduzieren (hatte erst das graphview-plugin nicht heruntergeladen).

I can reproduce this bug.

comment:6 Changed 12 years ago by anonymous

Wenn ich die zwei Zeilen lösche, funktioniert der Start wieder fehlerfrei. Danke!

Changed 12 years ago by anonymous

Attachment: preferences.backup.txt added

Changed 12 years ago by plaicy

Attachment: preferences added

Changed 12 years ago by plaicy

comment:7 Changed 12 years ago by plaicy

Component: CorePlugin
Owner: changed from plaicy to team
Priority: minornormal
Status: assignednew
Summary: Programmfehler - java.lang.NullPointerException[PATCH] Programmfehler - java.lang.NullPointerException in graphview

I attached very short preference file which reproduce the error (graphview plugin must be downloaded). Manually this bug can be reproduced if the graphview was undocked the last time josm was closed.

I also attach a patch for graphview plugin. But I do not use graphview: This patch is not tested much.

comment:8 Changed 12 years ago by plaicy

see also #3315 and #3316. I have created separate ticks because it has to be changed in each plugin. Otherwise undock status will not be restored correctly.

comment:9 Changed 12 years ago by tordanik

Resolution: fixed
Status: newclosed

patch applied in rev. 17210

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.