Modify

Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#3306 closed defect (fixed)

[PATCH] Restriction "no-u-turn" dont work when "via-way" has wrong orientation

Reported by: anonymous Owned by: dmuecke
Priority: minor Milestone:
Component: Core Version:
Keywords: Cc:

Description

The restriction "no-u-turn" dont work when "via-way" has wrong orientation. More (in german) see here: http://forum.openstreetmap.org/viewtopic.php?id=4438

Attachments (5)

no_u_turn.osm (40.2 KB) - added by anonymous 10 years ago.
no-u-turn-demo
no_u_turn.png (148.5 KB) - added by anonymous 10 years ago.
Picture 1.png (28.8 KB) - added by dmuecke 10 years ago.
correct u-turn signs
uturn.txt (3.1 KB) - added by dmuecke 10 years ago.
test_restriction.osm (32.2 KB) - added by dmuecke 10 years ago.

Download all attachments as: .zip

Change History (27)

comment:1 Changed 10 years ago by dmuecke

Owner: changed from team to dmuecke
Status: newassigned

comment:2 Changed 10 years ago by dmuecke

Summary: Restriction "no-u-turn" dont work when "via-way" has wrong orientation[PATCH] Restriction "no-u-turn" dont work when "via-way" has wrong orientation

JOSM does suppress now drawing u-turn sign if via isn't a node and doesn't mark it an error any longer. Attached patch should fix the issue.

comment:3 Changed 10 years ago by stoecker

Why do you disable drawing the turn-sign in case of via ways?

comment:4 Changed 10 years ago by dmuecke

Signs looking odd. I would expect to see no left turn signs rather.

comment:5 Changed 10 years ago by Dennis

The patch isn't integrated in version 1998?
I have no Compiler for testing the patch.
-- Dennis

comment:6 Changed 10 years ago by dmuecke

Not as long as Trac resolution status isn't fixed.

comment:7 Changed 10 years ago by stoecker

I'm not happy with the current patch. First I do not like disabling the icon and second I think the patch is not exactly how it should be (I can't describe better ATM).

comment:8 Changed 10 years ago by Dennis

Okay, that right too. Thanks. I am a little confused, because I ha've read over the word "suppress" yesterday... ;)

comment:9 Changed 10 years ago by dmuecke

Summary: [PATCH] Restriction "no-u-turn" dont work when "via-way" has wrong orientationRestriction "no-u-turn" dont work when "via-way" has wrong orientation

After taking a nap I think I know what to change. The place on the map where u-turn restriction signs were drawn is wrong.
I'm going to fix it when I'm back from holiday.

comment:10 Changed 10 years ago by dmuecke

Summary: Restriction "no-u-turn" dont work when "via-way" has wrong orientation[PATCH] Restriction "no-u-turn" dont work when "via-way" has wrong orientation

Issue fixed, patch attached!

comment:11 Changed 10 years ago by stoecker

Some minor things: The "oneway" check needs to use the OsmUtils to check for "true" value. Also could you please add all the relevant test and error cases in data/restriction.osm, so we have a reproducable test-file.

Changed 10 years ago by anonymous

Attachment: no_u_turn.osm added

no-u-turn-demo

comment:12 Changed 10 years ago by anonymous

File uploaded. When you change the orientation of the oneway, you see the problem. (The postion of the icon is changes and the other restriction is marked with an "*")

Changed 10 years ago by anonymous

Attachment: no_u_turn.png added

comment:13 Changed 10 years ago by stoecker

Sorry when I was unclear. During your coding you have thought about all correct and wrong cases (at least I hope so :-). In data directory there is a file restriction.osm which is a test-file for this. Please add all possible cases there (correct ones as well as faulty ones), so the correctness of the display can be verified anytime in future.

Changed 10 years ago by dmuecke

Attachment: Picture 1.png added

correct u-turn signs

comment:14 Changed 10 years ago by dmuecke

Added 2 more test cases in restriction.osm (05.1 and E15).

Changed 10 years ago by dmuecke

Attachment: uturn.txt added

Changed 10 years ago by dmuecke

Attachment: test_restriction.osm added

comment:15 Changed 10 years ago by dmuecke

I've removed restriction.osm from patch file and added it as separate file called test_restriction.osm. Diff did create far too much differences making it pointless for code review.

comment:16 Changed 10 years ago by stoecker

Resolution: fixed
Status: assignedclosed

(In [2087]) fixed #3306 - wrong handling of restriction via ways

comment:17 Changed 10 years ago by stoecker

Applied. Sorry, not much of your patch survived the changes I did.

comment:18 Changed 10 years ago by dmuecke

Resolution: fixed
Status: closedreopened

No probs!
Look at E15! It shows no u turn sign wrongly.

comment:19 Changed 10 years ago by dmuecke

It shows it only in test_restriction.osm

comment:20 Changed 10 years ago by dmuecke

E12 seems also not longer working.

comment:21 Changed 10 years ago by stoecker

Resolution: fixed
Status: reopenedclosed

Don't know why, but you mixed "oneway=-1". Your error example is actually correct. Reversed way and -1 is the same is correctway and oneway=yes.

Regarding E13 - Display of symbols is not suppressed when the to way is affected, as this way is not required for positioning ATM. This is a strict separation between draw as best as possible and validator. I know there may be other opinions, but it is a choice done also for multipolygons and we must be consistent.

So also in the future the fact "is displayed" does still not mean "is correct". We anyway do not check all possible errors in the display routine.

comment:22 Changed 10 years ago by dmuecke

Ok, thanks for clarification.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain dmuecke.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.