Modify

Opened 12 years ago

Closed 12 years ago

#2990 closed defect (fixed)

alert on starting josm

Reported by: mk67 Owned by: mk67
Priority: major Milestone:
Component: Plugin Version: latest
Keywords: Cc:

Description (last modified by stoecker)

note i've detach windows from general window. No other message after that.

Path: trunk
URL: http://josm.openstreetmap.de/svn/trunk
Repository Root: http://josm.openstreetmap.de/svn
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Revision: 1803
Node Kind: directory
Last Changed Author: stoecker
Last Changed Rev: 1803
Last Changed Date: 2009-07-17 20:56:20 +0200 (Fri, 17 Jul 2009)

Memory Usage: 49 MB / 910 MB (5 MB allocated, but free)
Java version: 1.6.0_14

Plugins: Create_grid_of_waysDirectUploadIntersect_wayPicLayerbuildings_toolscadastre-frcolorschemeopenvisibleroutingusertoolsutilspluginvalidatorwalkingpaperswmsplugin
Plugin Create_grid_of_ways Version: 16290
Plugin DirectUpload Version: 15828
Plugin Intersect_way Version: 12781
Plugin PicLayer Version: 16302
Plugin buildings_tools Version: 19
Plugin colorscheme Version: 16383
Plugin openvisible Version: 15707
Plugin routing Version: 16409
Plugin usertools Version: 14125
Plugin utilsplugin Version: 16290
Plugin validator Version: 16439
Plugin walkingpapers Version: 16571
Plugin wmsplugin Version: 16442
Plugin cadastre-fr Version: 16160

java.lang.NullPointerException

at org.openstreetmap.josm.gui.dialogs.ToggleDialog$3.actionPerformed(ToggleDialog.java:166)
at org.openstreetmap.josm.gui.dialogs.ToggleDialog$5.run(ToggleDialog.java:232)
at java.awt.event.InvocationEvent.dispatch(Unknown Source)
at java.awt.EventQueue.dispatchEvent(Unknown Source)
at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.run(Unknown Source)

Attachments (1)

preferences (137 bytes) - added by anonymous 12 years ago.

Download all attachments as: .zip

Change History (5)

comment:1 Changed 12 years ago by stoecker

Description: modified (diff)
Owner: changed from team to mk67
Status: newneedinfo

Which windows did you detach? Please add your preferences (strip username/password first).

comment:2 Changed 12 years ago by anonymous

I can reproduce this bug.

  1. move .josm away (fresh preference)
  2. start josm
  3. download and select osmbugsplugin
  4. quit josm
  5. replace preferences with attached preferences
  6. start josm

java.lang.NullPointerException

at org.openstreetmap.josm.gui.dialogs.ToggleDialog$3.actionPerformed(ToggleDialog.java:169)
at org.openstreetmap.josm.gui.dialogs.ToggleDialog$5.run(ToggleDialog.java:235)

[...]

the error is caused by ToggleDialog.parent==null

Changed 12 years ago by anonymous

Attachment: preferences added

comment:3 Changed 12 years ago by plaicy

Component: CorePlugin

I have not looked carefully. The reporter has no osmbugsplugin installed. It would be nice if the reporter add preference file (all lines containing ".docked"). See #3307, #3315, and #3316.

comment:4 Changed 12 years ago by Gubaer

Resolution: fixed
Status: needinfoclosed

Should be fixed with recent refactoring of ToggleDialog.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain mk67.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.