Modify

Opened 2 years ago

Closed 2 years ago

Last modified 22 months ago

#22004 closed defect (invalid)

False positive: Split roundabouts are no area

Reported by: skyper Owned by: team
Priority: normal Milestone:
Component: Core validator Version: tested
Keywords: template_report roundabout area linear Cc:

Description (last modified by skyper)

What steps will reproduce the problem?

  1. Have a roundabout split in several pieces without download area (highway=* + junction=roundabout)
  2. Run Validator

What is the expected result?

No warnings

What happens instead?

Informal warnings: A linear object highway=* without area=yes has a tag indicating that it is an area.

Please provide any additional information below. Attach a screenshot if possible.

I think this warning is rather new or something was changed but I do not find the ticket or commit.

Relative:URL: ^/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2022-04-04 22:26:00 +0200 (Mon, 04 Apr 2022)
Revision:18427
Build-Date:2022-04-05 01:30:55
URL:https://josm.openstreetmap.de/svn/trunk

Identification: JOSM/1.5 (18427 en) Linux Debian GNU/Linux 11 (bullseye)
Java version: 17.0.2+8-Debian-1deb11u1, Debian, OpenJDK 64-Bit Server VM

Attachments (0)

Change History (4)

comment:1 by skyper, 2 years ago

Description: modified (diff)

comment:2 by skyper, 2 years ago

Resolution: invalid
Status: newclosed

Oh, I did not think about mappaint styles interacting here but it is mentioned in #17623.
I had a patched style for #20102 active.

comment:3 by skyper, 2 years ago

Summary: False positive: Split roundabout are no areaFalse positive: Split roundabouts are no area

comment:4 by skyper, 22 months ago

Ticket #22288 has been marked as a duplicate of this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.