Modify

Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#22288 closed defect (duplicate)

False positives in "A linear object highway=* without area=yes has a tag indicating that it is an area"

Reported by: skyper Owned by: skyper
Priority: normal Milestone:
Component: Core validator Version: latest
Keywords: template_report roundabout area Cc:

Description

What steps will reproduce the problem?

  1. Have a roundabout split in pieces of highway=* plus junction=roundabout (e.g. way/60788523)
  2. Run validator

What is the expected result?

No warning

What happens instead?

For each way an informal warning:
A linear object highway=primary without area=yes has a tag indicating that it is an area.

Please provide any additional information below. Attach a screenshot if possible.

Relative:URL: ^/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2022-08-15 00:31:37 +0200 (Mon, 15 Aug 2022)
Revision:18537
Build-Date:2022-08-15 01:31:00
URL:https://josm.openstreetmap.de/svn/trunk

Attachments (0)

Change History (4)

comment:1 by skyper, 2 years ago

Version: latest

comment:2 by taylor.smock, 2 years ago

Owner: changed from team to skyper
Status: newneedinfo

This appears to be from #17623 in combination with a paintstyle that makes way[junction=roundabout] an area (the paint style has one of the keys set from wiki:Help/Styles/MapCSSImplementation#Areastyles ). Do you have any third-party paint styles installed?

comment:3 by skyper, 2 years ago

Resolution: duplicate
Status: needinfoclosed

Closed as duplicate of #22004.
Oh dam it, I had a modified default style. Second time I made this error.

comment:4 by taylor.smock, 2 years ago

No worries, stuff happens.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain skyper.
as The resolution will be set.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.