Modify

Opened 8 weeks ago

Closed 6 weeks ago

#20143 closed defect (fixed)

Restart doesn't work with new macOS package built with jpackage

Reported by: @… Owned by: Don-vip
Priority: normal Milestone: 20.12
Component: Core restart Version:
Keywords: template_report macosx worker pool thread jpackage Cc: Stereo

Description (last modified by Don-vip)

What steps will reproduce the problem?

  1. buildings plugin malfunctioned, updated to 17329 (Mac) - problem remains can't use buildings plugin

What is the expected result?

What happens instead?

Please provide any additional information below. Attach a screenshot if possible.

Revision:17329
Is-Local-Build:true
Build-Date:2020-11-22 22:31:51

Identification: JOSM/1.5 (17329 SVN en_AU) Mac OS X 10.16
OS Build number: macOS 11.0.1 (20B29)
Memory Usage: 676 MB / 8192 MB (164 MB allocated, but free)
Java version: 15.0.1+9, Azul Systems, Inc., OpenJDK 64-Bit Server VM
Look and Feel: com.apple.laf.AquaLookAndFeel
Screen: Display 69733632 1440x900 (scaling 2.0x2.0), Display 478183893 1920x1080 (scaling 1.0x1.0)
Maximum Screen Size: 1920x1080
Best cursor sizes: 16x16 -> 16x16, 32x32 -> 32x32
VM arguments: [-Dapple.awt.application.appearance=system, --module-path=/Applications/JOSM.app/Contents/app/mods]

Plugins:
+ Mapillary (1.5.27)
+ OpeningHoursEditor (35640)
+ apache-commons (35524)
+ apache-http (35589)
+ buildings_tools
+ ext_tools (35640)
+ imagery_offset_db (35640)
+ javafx-osx (35458)
+ jna (35458)
+ mapwithai (1.7.1.1)
+ reverter (35640)
+ scripting (30798)
+ terracer (35640)
+ todo (30306)
+ utilsplugin2 (35640)
+ wikipedia (1.1.4)

Map paint styles:
+ https://github.com/hotosm/HDM-JOSM-style/archive/master.zip
+ https://josm.openstreetmap.de/josmfile?page=Styles/MapWithAI&zip=1

Last errors/warnings:
- 00013.181 E: java.lang.UnsatisfiedLinkError: <josm.userdata>/plugins/javafx/libjfxmedia_avf.dylib: dlopen(<josm.userdata>/plugins/javafx/libjfxmedia_avf.dylib, 1): Library not loaded: @rpath/libgstreamer-lite.dylib
- 00013.864 E: java.lang.UnsatisfiedLinkError: <josm.userdata>/plugins/javafx/libfxplugins.dylib: dlopen(<josm.userdata>/plugins/javafx/libfxplugins.dylib, 1): Library not loaded: @rpath/libgstreamer-lite.dylib
- 00025.339 W: Ext_Tools warning: can not load file <josm.userdata>/plugins/ext_tools/tools.cfg
- 00025.340 W: Ext_Tools warning: can not load file <josm.userdata>/plugins/ext_tools/repo.cfg
- 00567.609 W: Could not load Mapillary brand image!
- 00654.330 E: Unable to load class org.openstreetmap.josm.plugins.buildings_tools.BuildingsToolsPlugin from plugin buildings_tools using classloader PluginClassLoader [urls=[]]: java.lang.ClassNotFoundException: org.openstreetmap.josm.plugins.buildings_tools.BuildingsToolsPlugin
- 00654.331 E: org.openstreetmap.josm.plugins.PluginException: An error occurred in plug-in buildings_tools. Cause: java.lang.ClassNotFoundException: org.openstreetmap.josm.plugins.buildings_tools.BuildingsToolsPlugin
- 00654.342 W: Disable plug-in - <html>Could not load plugin 'buildings_tools' because the plugin<br>main class 'org.openstreetmap.josm.plugins.buildings_tools.BuildingsToolsPlugin' was not found.<br>Delete from preferences?</html>
- 00878.215 E: java.io.IOException: Unable to find suitable java runtime at <java.home>/bin/java
- 00975.442 E: Handled by bug report queue: java.util.concurrent.RejectedExecutionException: Task java.util.concurrent.FutureTask@4deb45ff[Not completed, task = java.util.concurrent.Executors$RunnableAdapter@7c4e8023[Wrapped task = org.openstreetmap.josm.gui.preferences.imagery.CacheSettingsPanel$$Lambda$1340/0x0000000800912978@6badf68b]] rejected from org.openstreetmap.josm.gui.progress.swing.ProgressMonitorExecutor@3f239c00[Terminated, pool size = 0, active threads = 0, queued tasks = 0, completed tasks = 26]


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: AWT-EventQueue-0 (20) of main
java.util.concurrent.RejectedExecutionException: Task java.util.concurrent.FutureTask@4deb45ff[Not completed, task = java.util.concurrent.Executors$RunnableAdapter@7c4e8023[Wrapped task = org.openstreetmap.josm.gui.preferences.imagery.CacheSettingsPanel$$Lambda$1340/0x0000000800912978@6badf68b]] rejected from org.openstreetmap.josm.gui.progress.swing.ProgressMonitorExecutor@3f239c00[Terminated, pool size = 0, active threads = 0, queued tasks = 0, completed tasks = 26]
	at java.base/java.util.concurrent.ThreadPoolExecutor$AbortPolicy.rejectedExecution(Unknown Source)
	at java.base/java.util.concurrent.ThreadPoolExecutor.reject(Unknown Source)
	at java.base/java.util.concurrent.ThreadPoolExecutor.execute(Unknown Source)
	at org.openstreetmap.josm.gui.progress.swing.ProgressMonitorExecutor.execute(ProgressMonitorExecutor.java:40)
	at java.base/java.util.concurrent.AbstractExecutorService.submit(Unknown Source)
	at org.openstreetmap.josm.gui.preferences.imagery.CacheSettingsPanel.<init>(CacheSettingsPanel.java:76)
	at org.openstreetmap.josm.gui.preferences.imagery.ImageryPreference.<init>(ImageryPreference.java:61)
	at org.openstreetmap.josm.gui.preferences.imagery.ImageryPreference.<init>(ImageryPreference.java:53)
	at org.openstreetmap.josm.gui.preferences.imagery.ImageryPreference$Factory.createPreferenceSetting(ImageryPreference.java:69)
	at org.openstreetmap.josm.gui.preferences.PreferenceTabbedPane.buildGui(PreferenceTabbedPane.java:491)
	at org.openstreetmap.josm.gui.preferences.PreferenceDialog.build(PreferenceDialog.java:86)
	at org.openstreetmap.josm.gui.preferences.PreferenceDialog.<init>(PreferenceDialog.java:56)
	at org.openstreetmap.josm.actions.PreferencesAction.run(PreferencesAction.java:109)
	at org.openstreetmap.josm.actions.PreferencesAction.actionPerformed(PreferencesAction.java:104)
	at org.openstreetmap.josm.gui.MainApplication$DefaultNativeOsCallback.handlePreferences(MainApplication.java:1430)
	at org.openstreetmap.josm.tools.PlatformHookOsx.invoke(PlatformHookOsx.java:195)
	at com.sun.proxy.$Proxy2.handlePreferences(Unknown Source)
	at java.desktop/com.apple.eawt._AppEventHandler$_PreferencesDispatcher.performUsing(Unknown Source)
	at java.desktop/com.apple.eawt._AppEventHandler$_PreferencesDispatcher.performUsing(Unknown Source)
	at java.desktop/com.apple.eawt._AppEventHandler$_AppEventDispatcher$1.run(Unknown Source)
	at java.desktop/java.awt.event.InvocationEvent.dispatch(Unknown Source)
	at java.desktop/java.awt.EventQueue.dispatchEventImpl(Unknown Source)
	at java.desktop/java.awt.EventQueue$4.run(Unknown Source)
	at java.desktop/java.awt.EventQueue$4.run(Unknown Source)
	at java.base/java.security.AccessController.doPrivileged(Unknown Source)
	at java.base/java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.desktop/java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.desktop/java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.desktop/java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.desktop/java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.desktop/java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.desktop/java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.desktop/java.awt.EventDispatchThread.run(Unknown Source)

Attachments (0)

Change History (21)

comment:1 Changed 8 weeks ago by Don-vip

Owner: changed from team to @…
Status: newneedinfo

Your plugin looks corrupted, can you please try to delete the buildings_tools.jar file and download it again from JOSM preferences?

comment:2 Changed 7 weeks ago by Don-vip

Resolution: duplicate
Status: needinfoclosed

Closed as duplicate of #13784.

comment:3 Changed 7 weeks ago by Don-vip

Cc: Stereo added
Description: modified (diff)
Keywords: macosx worker pool thread added
Priority: normalmajor
Resolution: duplicate
Status: closedreopened
Summary: buildings plugin malfunctioned, updated to 17329 (Mac) - problem remains can't use buildings pluginRejectedExecutionException - MainApplication.worker in terminated state on macOS with new Java 15 build

comment:4 Changed 7 weeks ago by Don-vip

Ticket #20184 has been marked as a duplicate of this ticket.

comment:5 Changed 7 weeks ago by Don-vip

Ticket #20185 has been marked as a duplicate of this ticket.

comment:6 Changed 7 weeks ago by Don-vip

@siwilde can you please try to update your plugins (especially javafx which I updated today) and try again?

Last edited 7 weeks ago by Don-vip (previous) (diff)

comment:7 Changed 7 weeks ago by Stereo

(Note that the new macOS builds don't support javafx.)

comment:8 Changed 7 weeks ago by anonymous

why? I upgraded to JavaFX 15.0.1 to see if it solves the problem.

comment:9 Changed 7 weeks ago by Stereo

It's not supported by jpackage: https://openjdk.java.net/jeps/392

As far as I know, no plugins use JavaFX anymore.

comment:10 in reply to:  9 Changed 7 weeks ago by Don-vip

Replying to Stereo:

It's not supported by jpackage: https://openjdk.java.net/jeps/392

I still don't see why it would affect our JavaFX plugin. The link you gave is just the specification of jpackage.

As far as I know, no plugins use JavaFX anymore.

You can check plugin and see that matsim and StreetSide depend on it.

Last edited 7 weeks ago by Don-vip (previous) (diff)

comment:11 Changed 6 weeks ago by GerdP

Ticket #20200 has been marked as a duplicate of this ticket.

comment:12 Changed 6 weeks ago by Don-vip

Component: CoreCore restart
Milestone: 20.12
Priority: majorcritical

Every ticket contains this error:

- 00878.215 E: java.io.IOException: Unable to find suitable java runtime at <java.home>/bin/java

This error can only happen from a call to RestartAction.restartJOSM so it seems we have two problems:

  1. Restart doesn't work with this new package
  2. Worst, it fails after having stopped the main thread executor so it leaves JOSM in a very unusable state

@Stereo do you confirm that if you try to restart, you cannot download OSM data after?

comment:13 Changed 6 weeks ago by Don-vip

Owner: changed from @… to Don-vip
Status: reopenednew

comment:14 Changed 6 weeks ago by Don-vip

Status: newassigned

comment:15 Changed 6 weeks ago by Don-vip

Milestone: 20.12
Resolution: duplicate
Status: assignedclosed

Closed as duplicate of #13784.
The error message was already in #13784 so it's the same problem (I wasn't sure before). It's just way more likely to happen now with this package.

comment:16 Changed 6 weeks ago by Don-vip

Keywords: jpackage added
Milestone: 20.12
Resolution: duplicate
Status: closedreopened
Summary: RejectedExecutionException - MainApplication.worker in terminated state on macOS with new Java 15 buildRestart doesn't work with new macOS package built with jpackage

comment:17 Changed 6 weeks ago by Stereo

See also #20028, possibly duplicate.

comment:18 Changed 6 weeks ago by Don-vip

Ticket #20028 has been marked as a duplicate of this ticket.

comment:19 Changed 6 weeks ago by Don-vip

Env:

java.home: /Users/don-vip/josm/core/app/JOSM.app/Contents/runtime/Contents/Home
java.class.path: /Users/don-vip/josm/core/app/JOSM.app/Contents/app/josm-custom.jar:/Users/don-vip/josm/core/app/JOSM.app/Contents/app/JOSM.app/Contents/Java/josm-custom.jar
java.library.path: /Users/don-vip/Library/Java/Extensions:/Library/Java/Extensions:/Network/Library/Java/Extensions:/System/Library/Java/Extensions:/usr/lib/java:.
jnlpx.origFilenameArg: null
sun.java.command: org.openstreetmap.josm.gui.MainApplication

comment:20 Changed 6 weeks ago by Don-vip

Priority: criticalnormal

comment:21 Changed 6 weeks ago by Don-vip

Resolution: fixed
Status: reopenedclosed

In 17396/josm:

fix #20143 - make restart work with new macOS package built with jpackage

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Don-vip.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.