Modify

Opened 4 years ago

Closed 3 months ago

Last modified 3 months ago

#13784 closed defect (fixed)

RejectedExecutionException - MainApplication.worker in terminated state if restart fails to locate java runtime

Reported by: anonymous Owned by: Don-vip
Priority: critical Milestone: 20.12
Component: Core restart Version: latest
Keywords: template_report download restart executor task rejection Cc:

Description (last modified by Don-vip)

What steps will reproduce the problem?

  1. while restarting (because of adding new plugin to load along a way), immediatly after clicking to load the data (small zone).
URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2016-09-06 00:16:07 +0200 (Tue, 06 Sep 2016)
Build-Date:2016-09-05 22:21:00
Revision:10966
Relative:URL: ^/trunk

Identification: JOSM/1.5 (10966 fr) Windows 7 64-Bit
Memory Usage: 626 MB / 1806 MB (154 MB allocated, but free)
Java version: 1.8.0_91-b14, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: \Display0 1440x900, \Display1 1440x900
Maximum Screen Size: 1440x900

Plugins:
+ DirectDownload (32699)
+ HouseNumberTaggingTool (32699)
+ ImportImagePlugin (32699)
+ Mapillary (32882)
+ OpeningHoursEditor (32699)
+ PicLayer (32796)
+ SeaChart (32699)
+ SeaMapEditor (32767)
+ apache-commons (32699)
+ apache-http (32699)
+ buildings_tools (32944)
+ download_along
+ ejml (32680)
+ fieldpapers (v0.4.0)
+ geotools (32813)
+ importvec (32699)
+ jts (32699)
+ log4j (32699)
+ measurement (32936)
+ osmarender (32699)
+ pdfimport (32796)
+ reverter (32796)
+ utilsplugin2 (32815)

Tagging presets:
+ https://josm.openstreetmap.de/josmfile?page=Presets/Diving&zip=1
+ %UserProfile%\Google Drive\SIG\JOSM, pré-réglages\plongée.xml
+ %UserProfile%\Downloads\JOSM Presets\Presets_Camp_site_extends-preset.xml
+ %UserProfile%\Downloads\JOSM Presets\Presets_CampingForOverlanders-preset.xml
+ %UserProfile%\Downloads\JOSM Presets\Presets_LaneAttributes-preset.xml
+ %UserProfile%\Downloads\JOSM Presets\Presets_OpenSeaMap-PresetForSeamarks-preset.xml
+ %UserProfile%\Downloads\JOSM Presets\Presets_Diving-preset.xml

Last errors/warnings:
- W: java.net.ConnectException: Connection refused: connect
- W: java.net.ConnectException: Connection refused: connect
- W: java.net.ConnectException: Connection refused: connect
- W: java.net.ConnectException: Connection refused: connect
- W: java.net.ConnectException: Connection refused: connect
- W: Unable to get color from '' for color preference 'extrude.main.line'
- W: Unable to get color from '' for color preference 'improve.way.accuracy.helper.line'
- W: Unable to get color from '' for color preference 'make.parallel.helper.line'
- W: Invalid jar file ''<josm.pref>\plugins\download_along.jar.new'' (exists: false, canRead: false)
- E: java.io.IOException: Unable to find suitable java runtime at <java.home>\bin\java.exe


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: AWT-EventQueue-0 (20) of main
java.util.concurrent.RejectedExecutionException: Task java.util.concurrent.FutureTask@59024486 rejected from org.openstreetmap.josm.gui.progress.ProgressMonitorExecutor@688b6e87[Terminated, pool size = 0, active threads = 0, queued tasks = 0, completed tasks = 224]
	at java.util.concurrent.ThreadPoolExecutor$AbortPolicy.rejectedExecution(Unknown Source)
	at java.util.concurrent.ThreadPoolExecutor.reject(Unknown Source)
	at java.util.concurrent.ThreadPoolExecutor.execute(Unknown Source)
	at org.openstreetmap.josm.gui.progress.ProgressMonitorExecutor.execute(ProgressMonitorExecutor.java:36)
	at java.util.concurrent.AbstractExecutorService.submit(Unknown Source)
	at org.openstreetmap.josm.actions.downloadtasks.DownloadOsmTask.download(DownloadOsmTask.java:124)
	at org.openstreetmap.josm.actions.downloadtasks.DownloadOsmTask.download(DownloadOsmTask.java:116)
	at org.openstreetmap.josm.actions.downloadtasks.DownloadOsmTask.download(DownloadOsmTask.java:75)
	at org.openstreetmap.josm.actions.DownloadAction.actionPerformed(DownloadAction.java:51)
	at javax.swing.AbstractButton.fireActionPerformed(Unknown Source)
	at javax.swing.AbstractButton$Handler.actionPerformed(Unknown Source)
	at javax.swing.DefaultButtonModel.fireActionPerformed(Unknown Source)
	at javax.swing.DefaultButtonModel.setPressed(Unknown Source)
	at javax.swing.plaf.basic.BasicButtonListener.mouseReleased(Unknown Source)
	at java.awt.AWTEventMulticaster.mouseReleased(Unknown Source)
	at java.awt.Component.processMouseEvent(Unknown Source)
	at javax.swing.JComponent.processMouseEvent(Unknown Source)
	at java.awt.Component.processEvent(Unknown Source)
	at java.awt.Container.processEvent(Unknown Source)
	at java.awt.Component.dispatchEventImpl(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Unknown Source)
	at java.awt.LightweightDispatcher.processMouseEvent(Unknown Source)
	at java.awt.LightweightDispatcher.dispatchEvent(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Window.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
	at java.awt.EventQueue.access$500(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.run(Unknown Source)

Attachments (0)

Change History (16)

comment:1 Changed 4 years ago by Don-vip

Ticket #13902 has been marked as a duplicate of this ticket.

comment:2 Changed 4 years ago by Don-vip

Ticket #14563 has been marked as a duplicate of this ticket.

comment:3 Changed 4 years ago by Don-vip

Description: modified (diff)
Keywords: download restart executor task rejection added
Summary: while restarting (because of adding new plugin to load along a way), immediatly after clicking to load the data (small zone).RejectedExecutionException: DownloadOsmTask (after restart)

comment:4 Changed 3 months ago by Don-vip

Ticket #15555 has been marked as a duplicate of this ticket.

comment:5 Changed 3 months ago by Don-vip

Priority: normalmajor
Summary: RejectedExecutionException: DownloadOsmTask (after restart)RejectedExecutionException - MainApplication.worker in terminated state

comment:6 Changed 3 months ago by Don-vip

Ticket #16632 has been marked as a duplicate of this ticket.

comment:7 Changed 3 months ago by Don-vip

Ticket #20143 has been marked as a duplicate of this ticket.

comment:8 Changed 3 months ago by Don-vip

Ticket #20184 has been marked as a duplicate of this ticket.

comment:9 Changed 3 months ago by Don-vip

Component: CoreCore restart
Milestone: 20.12
Owner: changed from team to Don-vip
Priority: majorcritical
Status: newassigned
Summary: RejectedExecutionException - MainApplication.worker in terminated stateRejectedExecutionException - MainApplication.worker in terminated state if restart fails to locate java runtime

comment:10 Changed 3 months ago by Don-vip

Ticket #20143 has been marked as a duplicate of this ticket.

comment:11 Changed 3 months ago by Don-vip

From #20143:

Every ticket contains this error:

- 00878.215 E: java.io.IOException: Unable to find suitable java runtime at <java.home>/bin/java

This error can only happen from a call to RestartAction.restartJOSM so it seems we have two problems:

  1. Restart doesn't work with the new macOS package (#20143)
  2. Worst, it fails after having stopped the main thread executor so it leaves JOSM in a very unusable state

comment:12 Changed 3 months ago by Stereo

Resolution: duplicate
Status: assignedclosed

Closed as duplicate of #20028.

comment:13 Changed 3 months ago by Stereo

(Is it correct to close this one as a duplicate?)

comment:14 in reply to:  13 Changed 3 months ago by Don-vip

Resolution: duplicate
Status: closedreopened

Replying to Stereo:

(Is it correct to close this one as a duplicate?)

No. Please leave this to me.

comment:15 Changed 3 months ago by Don-vip

Resolution: fixed
Status: reopenedclosed

In 17390/josm:

fix #13784 - restart robustness

comment:16 Changed 3 months ago by Don-vip

In 17391/josm:

see #13784 - restart robustness

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Don-vip.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.