Modify

Opened 18 months ago

Closed 16 months ago

Last modified 16 months ago

#20142 closed defect (fixed)

man page: josm.dir.name is not properly documented

Reported by: skyper Owned by: team
Priority: normal Milestone:
Component: Ubuntu package Version: latest
Keywords: template_report man page Cc:

Description (last modified by skyper)

What steps will reproduce the problem?

  1. Install the package
  2. Look at man-page

What is the expected result?

josm.name.dir=<JOSM> josm.dir.name=<JOSM> respectively josm.name.dir=<JOSM-latest> josm.dir.name=<JOSM-latest>

What happens instead?

josm.name=<JOSM> respectively josm.name=<JOSM-latest>

Please provide any additional information below. Attach a screenshot if possible.

The option is not correctly documented while the wiki is correct.

Relative:URL: ^/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2020-11-22 22:54:01 +0100 (Sun, 22 Nov 2020)
Revision:17330
Build-Date:2020-11-23 02:30:49
URL:https://josm.openstreetmap.de/svn/trunk

Attachments (0)

Change History (12)

comment:1 Changed 18 months ago by skyper

Summary: josm.name.dirman page: josm.name.dir

comment:2 Changed 18 months ago by skyper

Summary: man page: josm.name.dirman page: josm.name.dir is not properly documented

comment:3 Changed 18 months ago by simon04

It should be josm.dir.name, not josm.name.dir?

comment:4 Changed 18 months ago by simon04

Resolution: fixed
Status: newclosed

In 17345/josm:

fix #20142 - Fix josm.dir.name in man pages

comment:5 in reply to:  3 Changed 18 months ago by skyper

Replying to simon04:

It should be josm.dir.name, not josm.name.dir?

Yes, thanks.

comment:6 Changed 18 months ago by skyper

Description: modified (diff)

comment:7 Changed 18 months ago by skyper

Summary: man page: josm.name.dir is not properly documentedman page: josm.dir.name is not properly documented

comment:8 Changed 16 months ago by Hb---

Resolution: fixed
Status: closedreopened

The name JOSM-latest is not used for any directory when starting up a downloaded josm-latest.jar on linux.

Both josm-tested.jar and josm-latest.jar create

/home/username/.config/JOSM/
/home/username/.local/share/JOSM/
/home/username/.cache/JOSM/

if /home/username/.josm/ is not found on start up.

Both releases use the same directory structure. I doubt that this is different when installed as package.

comment:9 Changed 16 months ago by skyper

Resolution: fixed
Status: reopenedclosed

Yes, the packages work as expected. The trick is the start script under /usr/bin/josm or /usr/bin/josm-latest which includes the setting.

comment:10 in reply to:  9 Changed 16 months ago by skyper

Replying to skyper:

Yes, the packages work as expected. The trick is the start script under /usr/bin/josm or /usr/bin/josm-latest which includes the setting.

Forgot to mention, that there are two packages available:

  • tested, which uses JOSM
  • latest, which uses JOSM-latest

comment:11 Changed 16 months ago by Hb---

Thanks for the explanation. I took that good solution as an example for wiki/Help/CommandLineOptions

Currently the wiki Download#GNUDebian states:

The repository contains two packages:

  • josm – Provides the tested version (stable). Replaces the package from the official Ubuntu repository.
  • josm-latest – The latest version (nightly). Can be installed parallel to the josm package. The default preference folder is ~/.josm-latest.

At least the capitalization in the last sentence seems to be wrong. Please check this. I suggest:

The default JOSM folder name here is JOSM-latest.

comment:12 Changed 16 months ago by skyper

I did adjust Help/CommandLineOptions (diff) and the Download page section (diff).

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.