Modify

Opened 4 months ago

Closed 4 weeks ago

#19582 closed defect (fixed)

Stays silent if download is incomplete cause of timeouts

Reported by: skyper Owned by: GerdP
Priority: normal Milestone:
Component: Plugin reverter Version:
Keywords: template_report incomplete download silent timeout Cc:

Description

What steps will reproduce the problem?

  1. Revert one way and all deleted objects to new layer. I used way and CS 83164338
  2. Get one conflict
  3. Try to select the object in mapview.
  4. Select object with conflict through conflict list panel

What is the expected result?

  • I should be able to select the way in mapview
  • No artifacts going to screen {0,0}

What happens instead?

  • No way to select the way in mapview
  • Artifacts once selected through conflict list panel


Please provide any additional information below. Attach a screenshot if possible.

Did not see this kind of artifact for a while now but here it is (again?). Remembered me about all the trouble changing to ODbL.

Relative:URL: ^/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2020-07-25 14:35:24 +0200 (Sat, 25 Jul 2020)
Revision:16808
Build-Date:2020-07-26 01:30:54
URL:https://josm.openstreetmap.de/svn/trunk

Dataset consistency test: No problems found

Plugins:
+ reverter (35499)

Last errors/warnings:
- W: Conflicts detected - <html>There was 1 conflict detected.</html>

Attachments (1)

19582-core.patch (638 bytes) - added by GerdP 5 weeks ago.
Patch for core

Download all attachments as: .zip

Change History (14)

comment:1 Changed 4 months ago by skyper

Damn, forgot to take the screenshot, and now, I cannot reproduce it. Could it be that the reverter plugin did not download all data cause of communication problems (timeouts)? I know "download parent" does silently fail a lot.

comment:2 Changed 4 months ago by skyper

Component: CorePlugin reverter
Keywords: download silent timeout added; conflict select way child node removed
Owner: changed from team to Upliner
Summary: Unable to select and artifacts to screen {0,0} once selected with a way with remaining conflict and incomplete or deleted child nodesStays silent if download is incomplete cause of timeouts

For the selection problem, see similar issue on #13678.

Probably a reverter problem but the same issue is present in core at least with "download (incomplete) members", see #19333.

#19412 and #19566 show that there is a general problem in connection failures.

comment:3 Changed 5 weeks ago by GerdP

Owner: changed from Upliner to GerdP
Status: newassigned

Changed 5 weeks ago by GerdP

Attachment: 19582-core.patch added

Patch for core

comment:4 Changed 5 weeks ago by GerdP

I am not sure how to handle incomplete reverts. They may be caused by timeouts as well as the user pressing "Cancel".
The plugin doesn't only generate commands, it also adds downloaded objects to the data layer. It is rather easy to show a notification or a popup but it is much more difficult to work out what to do with the data that was already used to update the layer, esp. when multiple changesets are reverted.
I think it would be better to always create a new layer and maybe automatically merge it with the current edit layer if user
requests that.

comment:5 Changed 5 weeks ago by skyper

+1
There is already the option for a new layer which could be reused.
If merge layers works properly, we could rely on it and have reverter only handle the download of objects.

comment:6 Changed 5 weeks ago by GerdP

I didn't mean to remove the creation of commands. I like to be able to use undo/redo to see what changed.

comment:7 Changed 4 weeks ago by GerdP

In 17290/josm:

see #19582: Stays silent if download is incomplete cause of timeouts

  • re-throw OsmTransferException (19582-core.patch)

comment:8 in reply to:  6 Changed 4 weeks ago by skyper

Replying to GerdP:

I didn't mean to remove the creation of commands. I like to be able to use undo/redo to see what changed.

I see, understandable and useful. In fact, undo of merge would be useful. Merge layers seems more complicated than merge selection. New ticket?

comment:9 Changed 4 weeks ago by skyper

Undo of merge is covered by #7489.

I also stumbled over #19467 which would explain some of my problems with merge layers.

comment:10 Changed 4 weeks ago by GerdP

In 35638/osm:

see #19582: Stays silent if download is incomplete cause of timeouts

  • rethrow OsmTransferException instead of only logging a warning so that a popup is shown
  • show a Notification if revert was cancelled, as it sometimes reacts a bit late

This will only improve reverter with JOSM 17920 or later, plugin is compatible with older versions.

comment:11 Changed 4 weeks ago by GerdP

In 35639/osm:

see #19582: Stays silent if download is incomplete cause of timeouts
dist

comment:12 Changed 4 weeks ago by GerdP

I'v e postponed the complex handling of incomplete reverts. Let's see if this helps or not.

comment:13 Changed 4 weeks ago by GerdP

Resolution: fixed
Status: assignedclosed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain GerdP.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.