Modify

Opened 22 months ago

Closed 20 months ago

Last modified 18 months ago

#19581 closed defect (fixed)

[Patch] Fixing duplicated nodes does not work

Reported by: skyper Owned by: GerdP
Priority: normal Milestone: 20.11
Component: Core validator Version:
Keywords: template_report fix duplicate nodes Cc:

Description (last modified by skyper)

Edit: Oh, the fix does not work at all.

What steps will reproduce the problem?

  1. Have two areas with Mixed type duplicated nodes (josm_Mixed_type_duplicated_nodes_example.osm.xz)
  2. Run Validator
  3. Take a look at the number of duplicated nodes reported
  4. Select the nodes using select button in validator panel
  5. Take a look at the selection in selection list panel (2 nodes)
  6. Click on fix button in validator panel
  7. Take a look at the selection in selection list panel (2 nodes)
  8. Fix all reported duplicated nodes
  9. Run validator
  10. Take a look at the number of duplicated nodes reported

What is the expected result?

Nodes are merge with the fix and on the second run of validator no warnings will show up only one node should be listed in the selection list panel.

What happens instead?

Displayed selection in selection list panel does not change. Still both nodes.
Nodes are not merged.
Same number of warnings after second validator run.

Please provide any additional information below. Attach a screenshot if possible.

I tried to select the younger one (higher id) which should be deleted and it works but deleting the node deletes both, so I think it is hopefully only a problem of updating the display of the selection list.

Or did I find a critical bug?

Relative:URL: ^/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2020-07-25 14:35:24 +0200 (Sat, 25 Jul 2020)
Revision:16808
Build-Date:2020-07-26 01:30:54
URL:https://josm.openstreetmap.de/svn/trunk

Attachments (2)

josm_Mixed_type_duplicated_nodes_example.osm.xz (5.0 KB) - added by skyper 22 months ago.
example file
19581.patch (931 bytes) - added by GerdP 22 months ago.
also check if there is a download area, if not, don't offer auto fix

Download all attachments as: .zip

Change History (17)

Changed 22 months ago by skyper

example file

comment:1 Changed 22 months ago by skyper

Description: modified (diff)
Summary: Wrong selection after merging nodes using "fix" buttonFixing duplicated nodes does not work

Fix does not work at all.

comment:2 Changed 22 months ago by skyper

Description: modified (diff)
Keywords: selection removed

Might be related to deleting nodes outside download area.

comment:3 in reply to:  2 ; Changed 22 months ago by GerdP

Replying to skyper:

Might be related to deleting nodes outside download area.

Yes, for your example file the test should not offer an autofix. If you download the area and use the fix it works as expected.
So, once again a problem caused by working with incomplete data.

comment:4 in reply to:  3 Changed 22 months ago by skyper

Replying to GerdP:

Replying to skyper:

Might be related to deleting nodes outside download area.

Yes, for your example file the test should not offer an autofix. If you download the area and use the fix it works as expected.
So, once again a problem caused by working with incomplete data.

In this case, it is not a special scenario. My example is small compared to the huge forest multipolygons in the Black Forest. There it is definitely not possible to download the whole area.

Why should`t there be an autofix ? If I select all nodes in advance and download their parents this is a safe action and merging hundreds of node pairs step by step is work for a machine and not for a human being.

Last edited 22 months ago by skyper (previous) (diff)

Changed 22 months ago by GerdP

Attachment: 19581.patch added

also check if there is a download area, if not, don't offer auto fix

comment:5 Changed 22 months ago by GerdP

I did not commit the simple patch because the new release is comming soon.

comment:6 Changed 22 months ago by skyper

Why not use the dialog about deleting nodes outside of download area instead of disabling this action?

comment:7 in reply to:  5 ; Changed 22 months ago by Klumbumbus

Replying to GerdP:

the new release is comming soon.

You can release it too if you want. See wiki:/DevelopersGuide/Releasing. I don't do it because I can't care for possible hotfixes (and I don't know how i18n updates work.)

comment:8 Changed 22 months ago by GerdP

Oh, really? I thought this requires access to server tools. Anyway, I'm cycling next month, so I'll not even have access to svn.

comment:9 Changed 20 months ago by Don-vip

Ticket #19855 has been marked as a duplicate of this ticket.

comment:10 Changed 20 months ago by Don-vip

Milestone: 20.10
Owner: changed from team to GerdP
Summary: Fixing duplicated nodes does not work[Patch] Fixing duplicated nodes does not work

comment:11 in reply to:  7 Changed 20 months ago by GerdP

Replying to Klumbumbus:

Replying to GerdP:

the new release is comming soon.

You can release it too if you want. See wiki:/DevelopersGuide/Releasing. I don't do it because I can't care for possible hotfixes (and I don't know how i18n updates work.)

Same for me. How do I "Do a last translation update"? Is it even possible on a Windows system? Besides that there are lots of other actions that I've never done so far. So, thanks to those who invest the time to release a new version!

comment:12 Changed 20 months ago by Don-vip

i18n update for JOSM core is just "ant updatecore" in i18n folder, then commit the modified .lang files. It works on Windows but you need to install some unix tools in your PATH (perl, wget, this kind of stuff)

comment:13 Changed 20 months ago by GerdP

Resolution: fixed
Status: newclosed

In 17096/josm:

fix #19581: Fixing duplicated nodes does not work

  • also check if there is a download area, if not, don't offer auto fix

comment:14 Changed 20 months ago by Klumbumbus

Ticket #19916 has been marked as a duplicate of this ticket.

comment:15 Changed 18 months ago by Don-vip

Milestone: 20.1020.11

Milestone renamed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain GerdP.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.