Modify

Opened 20 months ago

Closed 20 months ago

Last modified 20 months ago

#19916 closed defect (duplicate)

Duplicate node autofix fails silently

Reported by: zelonewolf@… Owned by: team
Priority: normal Milestone:
Component: Core validator Version:
Keywords: template_report Cc: GerdP

Description

What steps will reproduce the problem?

  1. Go to File->Download Object
  2. Download way 852236340
  3. Repeat this for way 856973532
  4. Press validate
  5. Click "Natural Duplicated Nodes (17)" and press Fix
  6. Press validate again

What is the expected result?

Duplicated nodes are fixed

What happens instead?

Duplicated nodes are not fixed, and running the validator again still returns the duplicate nodes.

Please provide any additional information below. Attach a screenshot if possible.

Duplicated node fixes DO work when data is downloaded from the slippymap. However, if data is downloaded by direct object ID download, or via an overpass query, duplicated node auto-fixes do not work.

A Ctrl+Alt+D (download referrers) does not fix the issue.

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2020-10-03 13:42:38 +0200 (Sat, 03 Oct 2020)
Build-Date:2020-10-04 01:30:47
Revision:17084
Relative:URL: ^/trunk

Identification: JOSM/1.5 (17084 en) Windows 10 64-Bit
OS Build number: Windows 10 Home 1903 (18362)
Memory Usage: 1069 MB / 1820 MB (883 MB allocated, but free)
Java version: 1.8.0_251-b08, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Look and Feel: com.sun.java.swing.plaf.windows.WindowsLookAndFeel
Screen: \Display0 1920x1080 (scaling 1.0x1.0)
Maximum Screen Size: 1920x1080
Best cursor sizes: 16x16 -> 32x32, 32x32 -> 32x32
Dataset consistency test: No problems found

Plugins:
+ FastDraw (35499)
+ RelationDissolve (0.2.0)
+ apache-commons (35524)
+ auto_tools (73)
+ conflation (0.6.6)
+ contourmerge (v0.1.6)
+ ejml (35313)
+ geotools (35169)
+ jaxb (35092)
+ jts (35122)
+ log4j (35092)
+ merge-overlap (35248)
+ opendata (35513)
+ reverter (35556)
+ shrinkwrap (v1.0.3)
+ undelete (35521)
+ utilsplugin2 (35487)

Last errors/warnings:
- 00007.182 W: Update plugins - You updated your JOSM software. To prevent problems the plugins should be updated as well.  Update plugins now?
- 00020.114 W: Region [TMS_BLOCK_v2] : Problem verifying disk.

Attachments (1)

dupe_node_issue.joz (3.3 KB) - added by zelonewolf@… 20 months ago.
Attaching JOSM session demonstrating the issue.

Download all attachments as: .zip

Change History (2)

Changed 20 months ago by zelonewolf@…

Attachment: dupe_node_issue.joz added

Attaching JOSM session demonstrating the issue.

comment:1 Changed 20 months ago by Klumbumbus

Cc: GerdP added
Resolution: duplicate
Status: newclosed

Closed as duplicate of #19581.
The (non working) fix button for duplicate nodes for layers without downloaded area was disabled in r17096.

Last edited 20 months ago by Klumbumbus (previous) (diff)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.