Modify

Opened 7 months ago

Last modified 7 months ago

#19566 reopened enhancement

In case of OSM server failure provide generic error message

Reported by: mkoniecz Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. break OSM server? Mock OSM server and return empty error?

What is the expected result?

I get generic error message, not an empty message

What happens instead?

I get an empty error message

Please provide any additional information below. Attach a screenshot if possible.

Relative:URL: ^/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2020-06-30 19:13:42 +0200 (Tue, 30 Jun 2020)
Revision:16731
Build-Date:2020-07-01 01:30:51
URL:https://josm.openstreetmap.de/svn/trunk

Identification: JOSM/1.5 (16731 en_GB) Linux Ubuntu 20.04 LTS
Memory Usage: 508 MB / 976 MB (139 MB allocated, but free)
Java version: 11.0.7+10-post-Ubuntu-3ubuntu1, Ubuntu, OpenJDK 64-Bit Server VM
Look and Feel: javax.swing.plaf.metal.MetalLookAndFeel
Screen: :0.0 1920x1080 (scaling 1.0x1.0)
Maximum Screen Size: 1920x1080
Best cursor sizes: 16x16 -> 16x16, 32x32 -> 32x32
Java package: openjdk-11-jre:amd64-11.0.7+10-3ubuntu1
Java ATK Wrapper package: libatk-wrapper-java:all-0.37.1-1
libcommons-logging-java: libcommons-logging-java:all-1.2-2
fonts-noto: fonts-noto:-
Dataset consistency test: No problems found

Plugins:
+ buildings_tools (35500)
+ measurement (35405)
+ reverter (35499)
+ todo (30306)

Last errors/warnings:
- E: Communication with OSM server failed - null

Attachments (1)

screen.png (19.2 KB) - added by mkoniecz 7 months ago.

Download all attachments as: .zip

Change History (4)

Changed 7 months ago by mkoniecz

Attachment: screen.png added

comment:1 Changed 7 months ago by mkoniecz

Seems similar but not exact clone of #19565

comment:2 Changed 7 months ago by skyper

Resolution: duplicate
Status: newclosed

Closed as duplicate of #19412.

comment:3 Changed 7 months ago by skyper

Resolution: duplicate
Status: closedreopened

Damn, sorry, closed the wrong ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as reopened The owner will remain team.
as The resolution will be set.
to The owner will be changed from team to the specified user.
The owner will change to mkoniecz
as duplicate The resolution will be set to duplicate.The specified ticket will be cross-referenced with this ticket

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.