Modify

#19550 closed defect (duplicate)

Gridify plugin is broken

Reported by: DressyPear4 Owned by: JeroenHoek
Priority: normal Milestone:
Component: Plugin Gridify Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. Create a polygon with four nodes
  2. Go to "More Tools" "Gridify"
  3. Error message
  4. (Version 16538 is ok)
URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2020-06-30 19:13:42 +0200 (Tue, 30 Jun 2020)
Build-Date:2020-07-01 01:30:51
Revision:16731
Relative:URL: ^/trunk

Identification: JOSM/1.5 (16731 pt_BR) Windows 10 64-Bit
OS Build number: Windows 10 Home 2004 (19041)
Memory Usage: 247 MB / 989 MB (41 MB allocated, but free)
Java version: 1.8.0_261-b12, Oracle Corporation, Java HotSpot(TM) Client VM
Look and Feel: com.sun.java.swing.plaf.windows.WindowsLookAndFeel
Screen: \Display0 1366x768 (scaling 1.0x1.0)
Maximum Screen Size: 1366x768
Best cursor sizes: 16x16 -> 32x32, 32x32 -> 32x32
Dataset consistency test: No problems found

Plugins:
+ FastDraw (35499)
+ OpeningHoursEditor (35414)
+ PicLayer (35405)
+ RelationDissolve (0.2.0)
+ SimplifyArea (35405)
+ apache-commons (35362)
+ apache-http (35092)
+ buildings_tools (35500)
+ contourmerge (v0.1.6)
+ editgpx (35248)
+ ejml (35313)
+ ext_tools (35499)
+ geotools (35169)
+ gridify (1588746833)
+ jaxb (35092)
+ jna (35092)
+ jts (35122)
+ log4j (35092)
+ mapwithai (1.6.1)
+ opendata (35405)
+ osm-obj-info (56)
+ reverter (35499)
+ tageditor (35258)
+ turnlanes (35405)
+ turnlanes-tagging (283)
+ turnrestrictions (35405)
+ utilsplugin2 (35487)

Tagging presets:
+ https://josm.openstreetmap.de/josmfile?page=Presets/Towers&zip=1

Map paint styles:
- https://josm.openstreetmap.de/josmfile?page=Styles/Lane_and_Road_Attributes&zip=1
- https://raw.githubusercontent.com/species/josm-preset-traffic_sign_direction/master/direction.mapcss
+ https://josm.openstreetmap.de/josmfile?page=Styles/MapWithAI&zip=1

Validator rules:
+ https://raw.githubusercontent.com/OSMBrasil/validador-josm/master/Rules_Brazilian-Specific.validator.mapcss

Last errors/warnings:
- W: java.util.zip.ZipException: error in opening zip file
- W: PluginException: : org.openstreetmap.josm.plugins.PluginException: Arquivo jar inválido '<josm.pref>\plugins\javafx-windows.jar.new'
- W: Falha ao digitalizar o arquivo 'javafx-windows.jar.new' para informações do plugin. Ignorando.
- W: Falha na instalação do plugin '<josm.pref>\plugins\javafx-windows.jar', do arquivo de download temporário '<josm.pref>\plugins\javafx-windows.jar.new'. error in opening zip file: java.util.zip.ZipException: error in opening zip file
- E: Handled by bug report queue: org.openstreetmap.josm.tools.JosmRuntimeException: Fatal: não foi possível localizar imagem 'cancel.png'. Este é um problema grave de configuração. JOSM vai parar de trabalhar.


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: AWT-EventQueue-0 (16) of main
org.openstreetmap.josm.tools.JosmRuntimeException: Fatal: não foi possível localizar imagem 'cancel.png'. Este é um problema grave de configuração. JOSM vai parar de trabalhar.
	at org.openstreetmap.josm.tools.ImageProvider.getResource(ImageProvider.java:706)
	at org.openstreetmap.josm.tools.ImageProvider.get(ImageProvider.java:666)
	at org.openstreetmap.josm.tools.ImageProvider.get(ImageProvider.java:812)
	at org.openstreetmap.josm.gui.ExtendedDialog.setButtonIcons(ExtendedDialog.java:187)
	at nl.jeroenhoek.josm.gridify.ui.GridifySettingsDialog.<init>(GridifySettingsDialog.java:106)
	at nl.jeroenhoek.josm.gridify.GridifyAction.performGridifyAction(GridifyAction.java:106)
	at nl.jeroenhoek.josm.gridify.GridifyAction.actionPerformed(GridifyAction.java:66)
	at javax.swing.AbstractButton.fireActionPerformed(Unknown Source)
	at javax.swing.AbstractButton$Handler.actionPerformed(Unknown Source)
	at javax.swing.DefaultButtonModel.fireActionPerformed(Unknown Source)
	at javax.swing.DefaultButtonModel.setPressed(Unknown Source)
	at javax.swing.AbstractButton.doClick(Unknown Source)
	at javax.swing.plaf.basic.BasicMenuItemUI.doClick(Unknown Source)
	at javax.swing.plaf.basic.BasicMenuItemUI$Handler.mouseReleased(Unknown Source)
	at java.awt.AWTEventMulticaster.mouseReleased(Unknown Source)
	at java.awt.Component.processMouseEvent(Unknown Source)
	at javax.swing.JComponent.processMouseEvent(Unknown Source)
	at java.awt.Component.processEvent(Unknown Source)
	at java.awt.Container.processEvent(Unknown Source)
	at java.awt.Component.dispatchEventImpl(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Unknown Source)
	at java.awt.LightweightDispatcher.processMouseEvent(Unknown Source)
	at java.awt.LightweightDispatcher.dispatchEvent(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Window.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
	at java.awt.EventQueue.access$500(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.run(Unknown Source)

Attachments (0)

Change History (1)

comment:1 Changed 15 months ago by simon04

Component: CorePlugin Gridify
Owner: changed from team to JeroenHoek
Resolution: duplicate
Status: newclosed

Closed as duplicate of #19487.
Already fixed, please update your plugins.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain JeroenHoek.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.