Modify

Opened 3 weeks ago

Closed 12 days ago

Last modified 11 days ago

#19551 closed defect (fixed)

[PATCH] Crash when Name Suggestion Index is enabled

Reported by: taylor.smock Owned by: team
Priority: normal Milestone: 20.07
Component: Core Version:
Keywords: template_report Cc: simon04

Description

What steps will reproduce the problem?

  1. Enable Name Suggestion Index
  2. Load a layer (it was crashing on the Irving gas station preset)

What is the expected result?

No crash. :)

What happens instead?

Crash :(

Please provide any additional information below. Attach a screenshot if possible.

Revision:16792
Is-Local-Build:true
Build-Date:2020-07-17 20:25:20

Identification: JOSM/1.5 (16792 SVN en) Linux Fedora release 32 (Thirty Two)
Memory Usage: 624 MB / 3990 MB (233 MB allocated, but free)
Java version: 14.0.1+7, Red Hat, Inc., OpenJDK 64-Bit Server VM
Look and Feel: javax.swing.plaf.metal.MetalLookAndFeel
Screen: :0.0 2560x1440 (scaling 1.0x1.0), :0.1 2560x1440 (scaling 1.0x1.0)
Maximum Screen Size: 2560x1440
Best cursor sizes: 16x16 -> 16x16, 32x32 -> 32x32
apache-commons-compress: apache-commons-compress:noarch-1.19
apache-commons-jcs-core: apache-commons-jcs-core:noarch-2.2
apache-commons-logging: apache-commons-logging:noarch-1.2
jsonp: jsonp:noarch-1.0.4
metadata-extractor2: metadata-extractor2:noarch-2.10.1
signpost-core: signpost-core:noarch-1.2.1.2
svgsalamander: svgsalamander:noarch-1.1.2
Dataset consistency test: No problems found

Plugins:
+ Mapillary (1.5.23)
+ OpenStreetCam (317)
+ apache-commons (35362)
+ apache-http (35092)
+ auto_tools (73)
+ buildings_tools (35500)
+ continuosDownload (91)
+ ejml (35313)
+ geotools (35169)
+ imagery-xml-bounds (35313)
+ imagery_offset_db (35405)
+ javafx-unixoid (35458)
+ jaxb (35092)
+ jna (35092)
+ jts (35122)
+ mapwithai (1.6.1)
+ opendata (35405)
+ osm-obj-info (56)
+ terracer (35499)
+ utilsplugin2 (35487)

Tagging presets:
+ https://raw.githubusercontent.com/osmlab/name-suggestion-index/master/dist/name-suggestions.presets.xml
+ https://josm.openstreetmap.de/josmfile?page=Presets/ParkingLanes&zip=1

Map paint styles:
+ https://josm.openstreetmap.de/josmfile?page=Styles/HiDPISupport&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Styles/Coloured_Streets&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Surface&zip=1
- https://raw.githubusercontent.com/species/josm-preset-wheelchair/master/sidewalks_kerbs.mapcss
+ https://josm.openstreetmap.de/josmfile?page=Styles/Maxspeed&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Styles/Lane_and_Road_Attributes&zip=1
+ https://raw.githubusercontent.com/species/josm-preset-traffic_sign_direction/master/direction.mapcss
- https://josm.openstreetmap.de/josmfile?page=Styles/TigerReviewedNo&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Styles/MapWithAI&zip=1
+ resource://mapcss/Mapillary.mapcss

Last errors/warnings:
- E: java.lang.UnsatisfiedLinkError: <josm.pref>/plugins/javafx/libavplugin-56.so: libgstreamer-lite.so: cannot open shared object file: No such file or directory
- E: java.lang.UnsatisfiedLinkError: <josm.pref>/plugins/javafx/libavplugin-57.so: libgstreamer-lite.so: cannot open shared object file: No such file or directory
- E: java.lang.UnsatisfiedLinkError: <josm.pref>/plugins/javafx/libavplugin-ffmpeg-56.so: libgstreamer-lite.so: cannot open shared object file: No such file or directory
- E: java.lang.UnsatisfiedLinkError: <josm.pref>/plugins/javafx/libavplugin-ffmpeg-57.so: libgstreamer-lite.so: cannot open shared object file: No such file or directory
- E: java.lang.UnsatisfiedLinkError: <josm.pref>/plugins/javafx/libfxplugins.so: libgstreamer-lite.so: cannot open shared object file: No such file or directory
- W: Failed to load Mappaint styles from 'resource://mapcss/Mapillary.mapcss'. Exception was: java.io.IOException: Failed to open input stream for resource 'resource://mapcss/Mapillary.mapcss'
- E: java.io.IOException: Failed to open input stream for resource 'resource://mapcss/Mapillary.mapcss'
- W: Initializing map style resource://mapcss/Mapillary.mapcss completed in 11 ms (1 errors, 0 warnings)
- E: Handled by bug report queue: java.lang.NullPointerException
- E: Handled by bug report queue: java.lang.NullPointerException


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: AWT-EventQueue-0 (20) of main
java.lang.NullPointerException
	at org.openstreetmap.josm.tools.ImageProvider.lambda$getPadded$4(ImageProvider.java:1603)
	at java.base/java.util.Comparator.lambda$comparing$77a9974f$1(Comparator.java:469)
	at java.base/java.util.TimSort.countRunAndMakeAscending(TimSort.java:360)
	at java.base/java.util.TimSort.sort(TimSort.java:220)
	at java.base/java.util.Arrays.sort(Arrays.java:1306)
	at java.base/java.util.ArrayList.sort(ArrayList.java:1720)
	at java.base/java.util.stream.SortedOps$RefSortingSink.end(SortedOps.java:392)
	at java.base/java.util.stream.AbstractPipeline.copyIntoWithCancel(AbstractPipeline.java:503)
	at java.base/java.util.stream.AbstractPipeline.copyInto(AbstractPipeline.java:488)
	at java.base/java.util.stream.AbstractPipeline.wrapAndCopyInto(AbstractPipeline.java:474)
	at java.base/java.util.stream.FindOps$FindOp.evaluateSequential(FindOps.java:150)
	at java.base/java.util.stream.AbstractPipeline.evaluate(AbstractPipeline.java:234)
	at java.base/java.util.stream.ReferencePipeline.findFirst(ReferencePipeline.java:543)
	at org.openstreetmap.josm.tools.ImageProvider.getPadded(ImageProvider.java:1607)
	at org.openstreetmap.josm.tools.ImageProvider.getPadded(ImageProvider.java:1574)
	at org.openstreetmap.josm.gui.PrimitiveRenderer.renderer(PrimitiveRenderer.java:81)
	at org.openstreetmap.josm.gui.PrimitiveRenderer.getListCellRendererComponent(PrimitiveRenderer.java:51)
	at org.openstreetmap.josm.gui.PrimitiveRenderer.getListCellRendererComponent(PrimitiveRenderer.java:31)
	at java.desktop/javax.swing.plaf.basic.BasicListUI.updateLayoutState(BasicListUI.java:1439)
	at java.desktop/javax.swing.plaf.basic.BasicListUI.maybeUpdateLayoutState(BasicListUI.java:1389)
	at java.desktop/javax.swing.plaf.basic.BasicListUI.getPreferredSize(BasicListUI.java:648)
	at java.desktop/javax.swing.JComponent.getPreferredSize(JComponent.java:1680)
	at java.desktop/javax.swing.ScrollPaneLayout.layoutContainer(ScrollPaneLayout.java:795)
	at java.desktop/java.awt.Container.layout(Container.java:1537)
	at java.desktop/java.awt.Container.doLayout(Container.java:1526)
	at java.desktop/java.awt.Container.validateTree(Container.java:1722)
	at java.desktop/java.awt.Container.validateTree(Container.java:1731)
	at java.desktop/java.awt.Container.validateTree(Container.java:1731)
	at java.desktop/java.awt.Container.validateTree(Container.java:1731)
	at java.desktop/java.awt.Container.validateTree(Container.java:1731)
	at java.desktop/java.awt.Container.validateTree(Container.java:1731)
	at java.desktop/java.awt.Container.validateTree(Container.java:1731)
	at java.desktop/java.awt.Container.validateTree(Container.java:1731)
	at java.desktop/java.awt.Container.validateTree(Container.java:1731)
	at java.desktop/java.awt.Container.validateTree(Container.java:1731)
	at java.desktop/java.awt.Container.validateTree(Container.java:1731)
	at java.desktop/java.awt.Container.validateTree(Container.java:1731)
	at java.desktop/java.awt.Container.validate(Container.java:1657)
	at java.desktop/javax.swing.RepaintManager$3.run(RepaintManager.java:745)
	at java.desktop/javax.swing.RepaintManager$3.run(RepaintManager.java:743)
	at java.base/java.security.AccessController.doPrivileged(AccessController.java:391)
	at java.base/java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:85)
	at java.desktop/javax.swing.RepaintManager.validateInvalidComponents(RepaintManager.java:742)
	at java.desktop/javax.swing.RepaintManager$ProcessingRunnable.run(RepaintManager.java:1883)
	at java.desktop/java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:316)
	at java.desktop/java.awt.EventQueue.dispatchEventImpl(EventQueue.java:770)
	at java.desktop/java.awt.EventQueue$4.run(EventQueue.java:721)
	at java.desktop/java.awt.EventQueue$4.run(EventQueue.java:715)
	at java.base/java.security.AccessController.doPrivileged(AccessController.java:391)
	at java.base/java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:85)
	at java.desktop/java.awt.EventQueue.dispatchEvent(EventQueue.java:740)
	at java.desktop/java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:203)
	at java.desktop/java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:124)
	at java.desktop/java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:113)
	at java.desktop/java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:109)
	at java.desktop/java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:101)
	at java.desktop/java.awt.EventDispatchThread.run(EventDispatchThread.java:90)

Attachments (1)

19551.patch (3.8 KB) - added by taylor.smock 3 weeks ago.
Avoid crashing by checking for a null object

Download all attachments as: .zip

Change History (4)

Changed 3 weeks ago by taylor.smock

Attachment: 19551.patch added

Avoid crashing by checking for a null object

comment:1 Changed 3 weeks ago by taylor.smock

Cc: simon04 added

@simon04: It looks like you fixed the crash after I filed this bug. Do you want the non-regression test from the patch? If not, I'll close this bug report.

comment:2 Changed 12 days ago by simon04

Resolution: fixed
Status: newclosed

In 16810/josm:

fix #19551 - Add ImageProviderTest.testTicket19551 (patch by taylor.smock)

comment:3 Changed 11 days ago by Klumbumbus

Milestone: 20.07

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.