Modify

Opened 4 years ago

Closed 4 years ago

Last modified 15 months ago

#18659 closed enhancement (fixed)

[Patch] change car=* to motorcar=* in the charging_station preset

Reported by: nlehuby Owned by: Don-vip
Priority: normal Milestone: 20.02
Component: Internal preset Version:
Keywords: preset motorcar charging_station Cc:

Description

Following a discussion on the tagging mailing list and on the wiki, we have changed the tag car=yes/no on amenity=charging_station to motorcar=yes/no to be consistent with the tag used for access.
The default preset should be updated accordingly.

I don't know how to do that, I'm not familiar with svn. The appropriate change should be done here:
https://josm.openstreetmap.de/browser/trunk/data/defaultpresets.xml#L2293

Attachments (1)

motorcar.patch (1.7 KB ) - added by nlehuby 4 years ago.
patch

Download all attachments as: .zip

Change History (11)

in reply to:  description comment:1 by skyper, 4 years ago

Replying to nlehuby:

I don't know how to do that, I'm not familiar with svn. The appropriate change should be done here:
https://josm.openstreetmap.de/browser/trunk/data/defaultpresets.xml#L2293

Simple .patch files, as attachment, are always welcome.

A validator warning with option to fix it automatically would be good.

comment:2 by Klumbumbus, 4 years ago

Component: CoreInternal preset

by nlehuby, 4 years ago

Attachment: motorcar.patch added

patch

comment:3 by nlehuby, 4 years ago

Hope this patch can help

comment:4 by skyper, 4 years ago

Summary: change car=* to motorcar=* in the charging_station preset[Patch] change car=* to motorcar=* in the charging_station preset

comment:5 by Don-vip, 4 years ago

Keywords: motorcar charging_station added
Milestone: 20.02
Owner: changed from team to Don-vip
Status: newassigned

comment:6 by Don-vip, 4 years ago

Ticket #18719 has been marked as a duplicate of this ticket.

comment:7 by Don-vip, 4 years ago

Resolution: fixed
Status: assignedclosed

In 15867/josm:

fix #18659 - change car=* to motorcar=* in the charging_station preset (patch by nlehuby) + add motorcycle=*

comment:8 by Don-vip, 4 years ago

In 15860/josm:

fix #18719 - see #18659 - Change car by motorcar in amenity=charging_station preset

comment:9 by Klumbumbus, 4 years ago

In 15919/josm:

see #18719, see #18659, see #18758 - Use "Motorcar" as caption for motorcar=yes in charging station preset similar to other occurrences of motorcar=*

comment:10 by Klumbumbus, 15 months ago

In 18644/josm:

fix #20539, see #18659, see #18719 - Deprecate car in favor for motorcar also for non charging stations

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Don-vip.
as The resolution will be set.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.