Modify

Opened 4 months ago

Closed 4 months ago

Last modified 4 months ago

#18660 closed enhancement (duplicate)

Ich habe die Schnauze (sorry) voll von der schlechten Programmierung der macOS-App

Reported by: cyigit19@… Owned by: team
Priority: normal Milestone:
Component: Installer MacOS Version: latest
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. Auf macOS heißt es „Ablage“ und „Darstellung“ und NICHT „Datei“ und „Ansicht"
  2. Was ist nach über vier Jahren der Einführung von Notarisierung von Apps das Problem JOSM für macOS signieren zu lassen? Ich meine, es wird einfach nur auf Schadsoftware von der Firma Apple überprüft. Jede erdenkliche App wird freigegeben. Beispielsweise die MediathekView-App oder ClipGrab, welche wohl sogar eine rechtliche Grauzone betreten. Es geht nur um die Sicherheit für schadsoftwarefreie Programme! Schade dass sich bis heute offenbar nicht von JOSM-Entwicklern darum bemüht wurde. Oder ist das Programm etwa mit Malware voll? (Wohl kaum).

What is the expected result?

What happens instead?

Please provide any additional information below. Attach a screenshot if possible.

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2020-02-01 01:10:57 +0100 (Sat, 01 Feb 2020)
Build-Date:2020-02-01 00:12:46
Revision:15806
Relative:URL: ^/trunk

Identification: JOSM/1.5 (15806 de) Mac OS X 10.13.6
OS Build number: Mac OS X 10.13.6 (17G11023)
Memory Usage: 406 MB / 1820 MB (81 MB allocated, but free)
Java version: 1.8.0_241-b07, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: Display 69731072 1920x1080
Maximum Screen Size: 1920x1080
VM arguments: [-Djava.library.path=/Applications/JOSM.app/Contents/MacOS, -DLibraryDirectory=${HOME}/Library, -DDocumentsDirectory=${HOME}/Documents, -DApplicationSupportDirectory=${HOME}/Library/Application Support, -DCachesDirectory=${HOME}/Library/Caches, -DApplicationDirectory=${HOME}/Applications, -DAutosavedInformationDirectory=${HOME}/Library/Autosave Information, -DDesktopDirectory=${HOME}/Desktop, -DDownloadsDirectory=${HOME}/Downloads, -DMoviesDirectory=${HOME}/Movies, -DMusicDirectory=${HOME}/Music, -DPicturesDirectory=${HOME}/Pictures, -DSharedPublicDirectory=${HOME}/Public, -DSystemLibraryDirectory=/Library, -DSystemApplicationSupportDirectory=/Library/Application Support, -DSystemCachesDirectory=/Library/Caches, -DSystemApplicationDirectory=/Applications, -DSystemUserDirectory=/Users, -DUserHome=${HOME}, -DSandboxEnabled=true, -DLaunchModifierFlags=0, -DLaunchModifierFlagCapsLock=false, -DLaunchModifierFlagShift=false, -DLaunchModifierFlagControl=false, -DLaunchModifierFlagOption=false, -DLaunchModifierFlagCommand=false, -DLaunchModifierFlagNumericPad=false, -DLaunchModifierFlagHelp=false, -DLaunchModifierFlagFunction=false, -Dapple.laf.useScreenMenuBar=true, -Dcom.apple.macos.use-file-dialog-packages=true, -Dcom.apple.macos.useScreenMenuBar=true, -Dcom.apple.mrj.application.apple.menu.about.name=JOSM, -Dcom.apple.smallTabs=true]

Map paint styles:
+ https://josm.openstreetmap.de/josmfile?page=Styles/iD&zip=1
- https://github.com/bastik/mapcss-tools/raw/osm/mapnik2mapcss/osm-results/mapnik.zip

Last errors/warnings:
- W: No configuration settings found.  Using hardcoded default values for all pools.

Attachments (0)

Change History (6)

comment:1 Changed 4 months ago by Don-vip

Your ticket is totally irrespectful. JOSM is made entirely by benevols.

comment:2 Changed 4 months ago by Klumbumbus

Duplicate of #14117 I guess.

comment:3 Changed 4 months ago by GerdP

Resolution: fixed
Status: newclosed

I wonder what happens when you compile JOSM on an Apple system. Will the OS complain each time when you start the program? If not, why don't Mac users go this way when Apple makes it so difficult to use software?

comment:4 Changed 4 months ago by Don-vip

Resolution: fixedduplicate

Marked as duplicate of #14117.

comment:5 Changed 4 months ago by GerdP

Sorry, I did not intend to change the status of the ticket.

comment:6 Changed 4 months ago by stoecker

Hmm, is the ticket creator a troll or an idiot? Nobody on earth can believe that opening such a ticket may yield any positive results...

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.