Modify

Opened 4 weeks ago

Closed 4 weeks ago

#17779 closed defect (fixed)

Josm doesn't show a local imagery WMS layer

Reported by: StephaneP Owned by: Don-vip
Priority: critical Milestone: 19.05
Component: Core imagery Version:
Keywords: template_report regression Cc:

Description

What steps will reproduce the problem?

  1. Load a Cyprus area in Josm (example https://www.openstreetmap.org/node/5252398804)
  2. Open the imagery menu

What is the expected result?

The imagery menu should show the DLS Imagery Orthophoto.

What happens instead?

I don't see it.

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2019-06-02 01:16:14 +0200 (Sun, 02 Jun 2019)
Build-Date:2019-06-02 01:30:52
Revision:15151
Relative:URL: ^/trunk

Identification: JOSM/1.5 (15151 en) Windows 10 64-Bit
OS Build number: Windows 10 Pro 1809 (17763)
Memory Usage: 1620 MB / 5461 MB (575 MB allocated, but free)
Java version: 1.8.0_191-b12, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: \Display0 1920x1080
Maximum Screen Size: 1920x1080
Dataset consistency test: No problems found

Plugins:
+ DirectUpload (34908)
+ ElevationProfile (34977)
+ Mapillary (1.5.18)
+ MicrosoftStreetside (34977)
+ OpeningHoursEditor (34977)
+ PolygonCutOut (v0.7)
+ apache-commons (34908)
+ apache-http (34908)
+ cadastre-fr (34977)
+ changeset-viewer (22)
+ continuosDownload (82)
+ contourmerge (v0.1.4)
+ ejml (34908)
+ geojson (124)
+ geotools (34908)
+ javafx-windows
+ jaxb (35014)
+ jna (34908)
+ jts (34908)
+ opendata (34997)
+ photo_geotagging (34908)
+ photoadjust (34977)
+ poly (34991)
+ reverter (34999)
+ tag2link (34977)
+ tageditor (34977)
+ todo (30306)
+ turnlanes-tagging (281)
+ turnrestrictions (34977)
+ undelete (34977)
+ utilsplugin2 (34977)

Tagging presets:
+ https://raw.githubusercontent.com/yopaseopor/traffic_signs_preset_JOSM/master/FR.zip

Map paint styles:
- https://josm.openstreetmap.de/josmfile?page=Styles/RecyclingMaterials&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Lane_and_Road_Attributes&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Maxspeed&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Sidewalks&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/MaxspeedIcons&zip=1
- https://raw.githubusercontent.com/species/josm-preset-traffic_sign_direction/master/direction.mapcss
- https://josm.openstreetmap.de/josmfile?page=Styles/Cycleways&zip=1
- https://github.com/GlassOceanos/indoor-JOSM-style/archive/master.zip

Last errors/warnings:
- W: Update plugins - org.openstreetmap.josm.plugins.PluginHandler$UpdatePluginsMessagePanel[,0,0,0x0,invalid,layout=java.awt.GridBagLayout,alignmentX=0.0,alignmentY=0.0,border=,flags=9,maximumSize=,minimumSize=,preferredSize=]
- W: Invalid jar file ''<josm.pref>\plugins\jaxb.jar.new'' (exists: false, canRead: false)
- W: Invalid jar file ''<josm.pref>\plugins\reverter.jar.new'' (exists: false, canRead: false)
- W: Invalid jar file ''<josm.pref>\plugins\PolygonCutOut.jar.new'' (exists: false, canRead: false)
- W: Plugin javafx-windows requires Java version 10. The current Java version is 8. You have to update Java in order to use this plugin.
- E: unable to find dependency javafx for plugin MicrosoftStreetside
- W: No configuration settings found.  Using hardcoded default values for all pools.

Attachments (2)

cyprus_no_local_orthophoto.jpg (149.3 KB) - added by StephaneP 4 weeks ago.
cyprus_local_orthophoto.jpg (60.8 KB) - added by StephaneP 4 weeks ago.

Download all attachments as: .zip

Change History (15)

Changed 4 weeks ago by StephaneP

comment:1 Changed 4 weeks ago by Klumbumbus

Milestone: 19.05
Priority: normalcritical

That seems to be a regression of #16301. The cyprus entry has no bounds shape specified, however that worked in previous stable r15031 nevertheless. We have lots of those entries. Should be hotfixed too imho.

Last edited 4 weeks ago by Klumbumbus (previous) (diff)

comment:2 Changed 4 weeks ago by Klumbumbus

Owner: changed from team to Don-vip

comment:3 Changed 4 weeks ago by StephaneP

Bounds are specified (<bounds min-lat='34.549824' min-lon='32.258650' max-lat='35.208233' max-lon='34.098145'/>)
Or you mean "no shape"?

comment:4 Changed 4 weeks ago by Klumbumbus

Yes, I meant shape :)

comment:5 Changed 4 weeks ago by StephaneP

Ok, I will add the shape right now.

comment:6 Changed 4 weeks ago by Klumbumbus

Other example for bugfixing: wiki:/Maps/Argentina#IGNorthophotoCrdobaWMTS

comment:7 Changed 4 weeks ago by StephaneP

Last edited 4 weeks ago by StephaneP (previous) (diff)

Changed 4 weeks ago by StephaneP

Attachment: cyprus_local_orthophoto.jpg added

comment:8 Changed 4 weeks ago by StephaneP

Resolution: fixed
Status: newclosed

comment:9 Changed 4 weeks ago by Klumbumbus

Resolution: fixed
Status: closedreopened

The ticket is not fixed. JOSM should be changed to show local entries in the menu even if they have no shape.

Last edited 4 weeks ago by Klumbumbus (previous) (diff)

comment:10 Changed 4 weeks ago by Klumbumbus

Regarding the cyprus entry, in northeast where there is the land border the shape should be a bit closer to the actual availability of the imagery, to avoid showing the menu entry in areas where this imagery is not available. Also the bounds must match the min/max values of the shape, see ImageryCompare.

comment:11 Changed 4 weeks ago by Don-vip

Keywords: regression added; imagery removed

comment:12 in reply to:  10 Changed 4 weeks ago by Don-vip

Replying to Klumbumbus:

Also the bounds must match the min/max values of the shape, see ImageryCompare.

I have just fixed this. @StephaneP always take a look to ImageryCompare after modifying an imagery entry, it's usually helpful :)

comment:13 Changed 4 weeks ago by Don-vip

Resolution: fixed
Status: reopenedclosed

In 15154/josm:

fix #17779 - make sure imagery entries without shapes are displayed in imagery menu

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Don-vip.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.