Modify

Opened 17 months ago

Closed 5 months ago

Last modified 5 months ago

#16301 closed enhancement (fixed)

Add filter and icon for map types

Reported by: stoecker Owned by: Don-vip
Priority: normal Milestone: 19.05
Component: Core imagery Version:
Keywords: Cc:

Description (last modified by Klumbumbus)

See #16103

The list of imagery in prefs should allow to filter for the types.

If possible the different types should be displayed with a small icon.

Category is already added to all entries in the wiki.

Attachments (0)

Change History (80)

comment:1 Changed 17 months ago by Klumbumbus

And a filter by text please too, (similar to the filterbox for projections), which allows to e.g. filter entries by country (filtertext "de") or city (filtertext "berlin").

comment:2 Changed 17 months ago by Klumbumbus

Ticket #16136 has been marked as a duplicate of this ticket.

comment:3 Changed 17 months ago by Don-vip

Why 18.08?

comment:4 Changed 17 months ago by stoecker

June is too early (first data needs to be added to Maps) and in July I will have no time...

comment:5 Changed 16 months ago by Klumbumbus

The wiki doesn't yet allow the category attribute.
Warnung: Ungültige Wiki-Seite: XML validation for map failed: Element '{http://josm.openstreetmap.de/maps-1.0}entry', attribute 'category': The attribute 'category' is not allowed.

comment:6 in reply to:  5 Changed 16 months ago by stoecker

Replying to Klumbumbus:

The wiki doesn't yet allow the category attribute.
Warnung: Ungültige Wiki-Seite: XML validation for map failed: Element '{http://josm.openstreetmap.de/maps-1.0}entry', attribute 'category': The attribute 'category' is not allowed.

Tried
<category>xxx</category>
and it worked fine. Where exactly did you try?

comment:7 Changed 16 months ago by Klumbumbus

I tried <entry category="photo"> cause it is listed under attributes at wiki:Maps

comment:9 Changed 16 months ago by Klumbumbus

Description: modified (diff)

comment:10 Changed 16 months ago by Don-vip

Description: modified (diff)

comment:11 Changed 16 months ago by Don-vip

Description: modified (diff)

comment:12 Changed 16 months ago by Klumbumbus

Description: modified (diff)

comment:13 Changed 16 months ago by Klumbumbus

Description: modified (diff)

comment:14 Changed 15 months ago by Klumbumbus

Description: modified (diff)

comment:15 Changed 14 months ago by Don-vip

Milestone: 18.0818.09

comment:16 Changed 13 months ago by Don-vip

Milestone: 18.0918.10

comment:17 Changed 12 months ago by Don-vip

Milestone: 18.1018.11

comment:18 Changed 12 months ago by Klumbumbus

Description: modified (diff)

comment:19 Changed 12 months ago by Klumbumbus

Description: modified (diff)

comment:20 Changed 12 months ago by Klumbumbus

Description: modified (diff)

comment:21 Changed 11 months ago by Don-vip

Milestone: 18.1118.12

comment:22 Changed 11 months ago by stoecker

We should icons now (also to honor Klumbumbus work). Any proposals for icons?

comment:23 Changed 11 months ago by Don-vip

Ideas. Licenses to check:

  • https://cdn0.iconfinder.com/data/icons/internet-line/512/Internet_Line-16-512.png photo aerial or satellite photo
  • https://cdn2.iconfinder.com/data/icons/essential-web-5/50/map-direction-diagram-path-route-512.png map a map
  • https://cdn1.iconfinder.com/data/icons/airline-flight-booking-mobile-app/15/recent-time-search-reload-time-512.png historicmap historic or otherwise outdated map
  • https://josm.openstreetmap.de/export/14475/josm/trunk/images/layer/osmdata_small.png osmbasedmap map based on OSM data
  • https://cdn1.iconfinder.com/data/icons/circus-element/64/Balloon-hot-transportation-transport-circus-512.png historicphoto historic or otherwise outdated aerial or satellite photo
  • https://cdn0.iconfinder.com/data/icons/glyphpack/34/question-circle-512.png other any other type
Last edited 11 months ago by Don-vip (previous) (diff)

comment:24 in reply to:  23 ; Changed 11 months ago by Klumbumbus

Replying to Don-vip:

Ideas.

Nice.
That one is not recognizable at 16px though. https://cdn1.iconfinder.com/data/icons/circus-element/64/Balloon-hot-transportation-transport-circus-512.png At least I didn't understand what that is until I opened the full size.

What about using the same icons for photo and historicphoto and for map and historicmap while the normal variant is coloured and the historic variant greyscale?

comment:25 in reply to:  24 Changed 11 months ago by stoecker

Replying to Klumbumbus:

Replying to Don-vip:

Ideas.

Nice.
That one is not recognizable at 16px though. https://cdn1.iconfinder.com/data/icons/circus-element/64/Balloon-hot-transportation-transport-circus-512.png At least I didn't understand what that is until I opened the full size.

Same for me. Also the historicmap is not really obvious.

What about using the same icons for photo and historicphoto and for map and historicmap while the normal variant is coloured and the historic variant greyscale?

I like that.

comment:26 Changed 11 months ago by Klumbumbus

Description: modified (diff)

comment:27 Changed 11 months ago by Klumbumbus

Description: modified (diff)

comment:28 Changed 10 months ago by Klumbumbus

Description: modified (diff)

comment:29 Changed 10 months ago by Klumbumbus

All categories are added. We have:

303x photo
70x historicphoto
63x map
93x historicmap
42x osmbasedmap
154x other

In total 725 active (i.e. not disabled) entries.

comment:30 Changed 10 months ago by Klumbumbus

Can we please have a check either in SyncEditorLayerIndex.groovy or make it mandatory in the xml checks in the wiki that every entry has an category property?

comment:31 Changed 10 months ago by Don-vip

154 other? That's a huge number, do you think we could add a new category? What are all these sources about?

comment:32 in reply to:  31 Changed 10 months ago by Klumbumbus

Replying to Don-vip:

154 other? That's a huge number, do you think we could add a new category? What are all these sources about?

Mostly overlays of one feature (streets, buildings, administrative boundaries,...), but also elevation modells (hill shading), contour lines, OSM validation overlays, WMTS/wms_endpoint sources containing layers of different categories.

comment:33 Changed 10 months ago by Don-vip

In 14541/josm:

see #16301 - make category mandatory

comment:34 Changed 10 months ago by Klumbumbus

In 14552/josm:

  • see #16301 - make id mandatory
  • see #17058 - add asserts to territories.mapcss

comment:35 Changed 10 months ago by stoecker

I'm not so happy to make these attributes mandatory. That may be true for our wiki, but not necessary elsewhere. Making them mandatory prevents loading when the attributes aren't there.

I'd rather test them with the Sync script.

comment:36 Changed 10 months ago by stoecker

Hmm, seems minOccurs does not do anything at all. You can remove all these arguments without an error.

comment:37 Changed 10 months ago by stoecker

In 14554/josm:

see #16301 - make sync script stable against missing data

comment:38 in reply to:  35 ; Changed 10 months ago by Klumbumbus

Replying to stoecker:

I'm not so happy to make these attributes mandatory.

OK, I thought maps.xsd is only for the wiki. Please change it to a better solution.

comment:39 in reply to:  38 Changed 10 months ago by stoecker

Replying to Klumbumbus:

Replying to stoecker:

I'm not so happy to make these attributes mandatory.

OK, I thought maps.xsd is only for the wiki. Please change it to a better solution.

No. These XSD are the files JOSM uses for validation.

But as said it seems minOccurs doesn't have an effect. The Sync script now screams if these fields are missing :-)

comment:40 Changed 10 months ago by Don-vip

Milestone: 18.1219.01

comment:41 Changed 9 months ago by Don-vip

Milestone: 19.0119.02

comment:42 Changed 8 months ago by Don-vip

Milestone: 19.0219.03

comment:43 Changed 7 months ago by Klumbumbus

Milestone: 19.0319.04

comment:44 Changed 6 months ago by Don-vip

Milestone: 19.0419.05

comment:45 Changed 6 months ago by Don-vip

@Dirk: do you plan to work on this? I didn't touch it because I thought when you created the ticket that it was your intention.

comment:46 Changed 6 months ago by stoecker

Please go on, when you have time for this.

comment:47 Changed 6 months ago by Don-vip

@Stefan: I'd like to use https://www.iconfinder.com/icons/1587506/internet_line_satellite_icon for the first icon but the SVG file is 2Mb. I can't reduce it using svg-cleaner, do you know how we can improve it? It shouldn't be more than a few kilobytes.

comment:48 Changed 6 months ago by Don-vip

Ah, the SVG includes a font. WTF. without it it's only 4Kb :)

comment:49 Changed 6 months ago by Don-vip

Owner: changed from team to Don-vip
Status: newassigned

comment:50 Changed 6 months ago by Don-vip

In 15049/josm:

see #16301 - add category icons in imagery preferences

comment:51 Changed 6 months ago by Don-vip

TODO:

  • add tooltip above icon, displaying name and description of the imagery category. Probably requires custom renderers
  • add tooltip above country, using Java Locale class
  • add filter text field searching on all columns (category, country, title, url)

comment:52 Changed 6 months ago by Don-vip

@Dirk the icon script is not happy with my dynamic loading:
https://josm.openstreetmap.de/jenkins/job/JOSM-Integration/3078/warnings4Result/

How can we ignore these warnings?

comment:53 Changed 6 months ago by stoecker

Simply add /* ICON(data/imagery/) */ in front of the names in ImageryInfo.java ;-)

comment:54 Changed 6 months ago by Don-vip

OK thanks :)

comment:55 Changed 6 months ago by Don-vip

In 15057/josm:

see #16301 - suppress icon warning

comment:57 Changed 6 months ago by stoecker

You took ImageryType enum. You should have used ImageryCategory enum. :-)

I saw your commit first and though: Ah, he implemented type image display as well. Fine. But found no related change :-)

Last edited 5 months ago by stoecker (previous) (diff)

comment:58 Changed 5 months ago by Don-vip

Appfff I was so tired I shouldn't have committed this xD My eyes were probably half-closed already :)

comment:59 Changed 5 months ago by Don-vip

In 15059/josm:

see #16301 - suppress icon warning (on the correct enum this time)

comment:60 Changed 5 months ago by stoecker

You should go to your boss and say: "I make silly mistakes in my open source free time coding - I need a vacation". He sure will grant it :-)

comment:61 in reply to:  60 Changed 5 months ago by stoecker

Replying to stoecker:

You should go to your boss and say: "I make silly mistakes in my open source free time coding - I need a vacation". He sure will grant it :-)

Or maybe not when you use your free time coding for JOSM...

comment:62 Changed 5 months ago by Don-vip

:D I was on vacation and exhausted because of it, just got back to work today so it does not work ;)

comment:63 Changed 5 months ago by Don-vip

In 15114/josm:

see #16301 - display tooltips for all columns

comment:64 Changed 5 months ago by Don-vip

In 15115/josm:

see #16301 - extract ImageryProvidersPanel

comment:65 Changed 5 months ago by Don-vip

Resolution: fixed
Status: assignedclosed

In 15116/josm:

fix #16301 - add filter for default imagery entries

comment:66 Changed 5 months ago by Klumbumbus

Thats great, thanks!
One thing: the map on the right side in the preferences displays only error tiles for me. It seems that got broken.

comment:67 Changed 5 months ago by Don-vip

I didn't touch this part. Probably a network error or something.

comment:68 Changed 5 months ago by Klumbumbus

the console says Failed loading https://c.tile.openstreetmap.org/3/5/2.png: class java.io.IOException: Server returned HTTP response code: 429 for URL: https://a.tile.openstreetmap.org/3/5/2.png however in browser i can load https://a.tile.openstreetmap.org/3/5/2.png without problems.

comment:69 Changed 5 months ago by stoecker

429 is "rate limit".

comment:70 in reply to:  69 Changed 5 months ago by Klumbumbus

Replying to stoecker:

429 is "rate limit".

Seems justified. JOSM is doing strange things. See attached gifs.

comment:71 Changed 5 months ago by stoecker

Seems justified. JOSM is doing strange things. See attached gifs.

Please open a ticket for that for the TMS image loader (assigned to wiktorn?).

comment:72 Changed 5 months ago by Klumbumbus

Ahh, I think we need a hotfix:

What steps will reproduce the problem?

  1. type "cy" in the filter box above the list in the imagery preferences
  2. select the cyprus entry on position 5
  3. click activate

What is the expected result?

the cyprus entry is added to the list below

What happens instead?

the entry which is on position 5 in the unfiltered list is added (Digital Globe Standard Imagery)

comment:73 Changed 5 months ago by Don-vip

Problem of HTTP 429 fixed in #17772.
Also deleting the big gif files, I did some cleanup of giant attachments with #17757 because it complexifies #16857.

I'm fixing the "Cyprus" selection problem plus also the problem reported in #17779.

comment:74 Changed 5 months ago by Don-vip

In 15153/josm:

see #16301 - fix activation problem when filtering imagery sources

comment:75 Changed 5 months ago by Klumbumbus

BTW, not only the "Activate" button but also the "Edit" button from the xml bounds plugin is affected. Not sure if the plugin needs an own fix.

comment:76 in reply to:  75 Changed 5 months ago by Don-vip

Replying to Klumbumbus:

also the "Edit" button from the xml bounds plugin is affected.

Thanks, plugin fixed in [o35023:35024].

comment:77 Changed 5 months ago by Don-vip

Hotfix released: r15155

comment:78 Changed 5 months ago by Klumbumbus

Thanks. Works fine for me.

comment:79 in reply to:  77 Changed 5 months ago by Klumbumbus

Replying to Don-vip:

Hotfix released: r15155

Also nice that you managed to use a fancy number for the hotfix too, similar to the stable release. I'm very pleased. :)

comment:80 Changed 5 months ago by Don-vip

I wanted 15151 initially. It's a palindrome.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Don-vip.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.