Modify

Opened 4 weeks ago

Closed 3 weeks ago

#16302 closed defect (fixed)

IAE when switching map mode while offset dialog is open

Reported by: ralleon@… Owned by: Don-vip
Priority: normal Milestone: 18.05
Component: Core imagery Version:
Keywords: template_report offset Cc:

Description

What steps will reproduce the problem?

  1. add Bing imagery/Strava cycling heatmap (stable editing)
  2. add DigitalGlobe Standard layer (toggling between Bing-DigitalGlobe to do offset corrections makes JOSM unstable)
  3. prsssing A (add) or uploading can trigger the bug (error message)

What is the expected result?

What happens instead?

Please provide any additional information below. Attach a screenshot if possible.

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2018-05-06 23:56:40 +0200 (Sun, 06 May 2018)
Build-Date:2018-05-06 21:59:07
Revision:13710
Relative:URL: ^/trunk

Identification: JOSM/1.5 (13710 en) Windows 7 64-Bit
OS Build number: Windows 7 Professional (7601)
Memory Usage: 711 MB / 910 MB (219 MB allocated, but free)
Java version: 1.8.0_171-b11, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: \Display0 1366x768, \Display1 1280x1024
Maximum Screen Size: 1366x1024
Dataset consistency test: No problems found

Plugins:
+ Mapillary (v1.5.12+post13643)
+ OpenStreetCam (144)
+ apache-commons (34109)
+ apache-http (34109)
+ buildings_tools (34109)
+ ejml (34126)
+ fieldpapers (v0.4.3)
+ geotools (34125)
+ imagery_offset_db (34109)
+ jts (34038)
+ opendata (34153)
+ photo_geotagging (34109)
+ turnrestrictions (34129)
+ utilsplugin2 (34109)

Map paint styles:
- %UserProfile%\Dropbox\MapWorks\Kaart MySandbox\Kaart Styles 3.1.mapcss
- %UserProfile%\Dropbox\MapWorks\Kaart MySandbox\geometry_adjusted_paint.mapcss.css

Last errors/warnings:
- W: Already here java.net.UnknownHostException: ecn.t1.tiles.virtualearth.net
- W: java.net.UnknownHostException: ecn.t2.tiles.virtualearth.net
- W: Already here java.net.UnknownHostException: ecn.t2.tiles.virtualearth.net
- W: java.net.UnknownHostException: ecn.t2.tiles.virtualearth.net
- W: Already here java.net.UnknownHostException: ecn.t2.tiles.virtualearth.net
- E: Handled by bug report queue: java.lang.IllegalArgumentException: Listener org.openstreetmap.josm.actions.ImageryAdjustAction@45450cd6 (instance of org.openstreetmap.josm.actions.ImageryAdjustAction) was not registered before or already removed.
- E: Handled by bug report queue: java.lang.IllegalArgumentException: Listener org.openstreetmap.josm.actions.ImageryAdjustAction@45450cd6 (instance of org.openstreetmap.josm.actions.ImageryAdjustAction) was not registered before or already removed.
- E: Handled by bug report queue: java.lang.IllegalArgumentException: Listener org.openstreetmap.josm.actions.ImageryAdjustAction@45450cd6 (instance of org.openstreetmap.josm.actions.ImageryAdjustAction) was not registered before or already removed.
- E: Handled by bug report queue: java.lang.IllegalArgumentException: Listener org.openstreetmap.josm.actions.ImageryAdjustAction@45450cd6 (instance of org.openstreetmap.josm.actions.ImageryAdjustAction) was not registered before or already removed.
- E: Handled by bug report queue: java.lang.IllegalArgumentException: Listener org.openstreetmap.josm.actions.ImageryAdjustAction@45450cd6 (instance of org.openstreetmap.josm.actions.ImageryAdjustAction) was not registered before or already removed.


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: AWT-EventQueue-0 (19) of main
java.lang.IllegalArgumentException: Listener org.openstreetmap.josm.actions.ImageryAdjustAction@45450cd6 (instance of org.openstreetmap.josm.actions.ImageryAdjustAction) was not registered before or already removed.
	at org.openstreetmap.josm.tools.ListenerList.failRemove(ListenerList.java:132)
	at org.openstreetmap.josm.tools.ListenerList.removeListener(ListenerList.java:126)
	at org.openstreetmap.josm.data.Preferences.removePreferenceChangeListener(Preferences.java:164)
	at org.openstreetmap.josm.actions.mapmode.MapMode.exitMode(MapMode.java:83)
	at org.openstreetmap.josm.actions.ImageryAdjustAction.doExitMode(ImageryAdjustAction.java:129)
	at org.openstreetmap.josm.actions.ImageryAdjustAction.exitMode(ImageryAdjustAction.java:118)
	at org.openstreetmap.josm.gui.MapFrame.selectMapMode(MapFrame.java:480)
	at org.openstreetmap.josm.gui.MapFrame.selectMapMode(MapFrame.java:462)
	at org.openstreetmap.josm.actions.mapmode.MapMode.actionPerformed(MapMode.java:111)
	at javax.swing.SwingUtilities.notifyAction(Unknown Source)
	at javax.swing.JComponent.processKeyBinding(Unknown Source)
	at javax.swing.KeyboardManager.fireBinding(Unknown Source)
	at javax.swing.KeyboardManager.fireKeyboardAction(Unknown Source)
	at javax.swing.JComponent.processKeyBindingsForAllComponents(Unknown Source)
	at javax.swing.JComponent.processKeyBindings(Unknown Source)
	at javax.swing.JComponent.processKeyEvent(Unknown Source)
	at java.awt.Component.processEvent(Unknown Source)
	at java.awt.Container.processEvent(Unknown Source)
	at java.awt.Component.dispatchEventImpl(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.KeyboardFocusManager.redispatchEvent(Unknown Source)
	at java.awt.DefaultKeyboardFocusManager.dispatchKeyEvent(Unknown Source)
	at java.awt.DefaultKeyboardFocusManager.preDispatchKeyEvent(Unknown Source)
	at java.awt.DefaultKeyboardFocusManager.typeAheadAssertions(Unknown Source)
	at java.awt.DefaultKeyboardFocusManager.dispatchEvent(Unknown Source)
	at java.awt.Component.dispatchEventImpl(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Window.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
	at java.awt.EventQueue.access$500(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.run(Unknown Source)

Attachments (0)

Change History (7)

comment:1 Changed 4 weeks ago by ralleon@…

Reproduction of problem (using Digital Globe & offset correction only):

  1. Download OSM data
  2. Open DigitalGlobe Standard Imagery
  3. Imagery > Imagery Offset > New Offset (for Digital Globe)
  4. While "Adjust Imagery offset" is open, go to main Window,
  5. Hit A or S (without closing Adjust Imagery offset window)
  6. Error window shows up (and will keep on showing up)


comment:2 Changed 4 weeks ago by anonymous

The error message also happens with Bing imagery.

It looks like the trigger is trying to edit the map by pressing with a keyboard shortcut (eg. A or S), while
"Adjust Imagery offset" window is still open.

comment:3 Changed 4 weeks ago by Don-vip

Component: CoreCore imagery
Keywords: offset added
Milestone: 18.05

Thank you for the reproduction steps, I'm able to reproduce the issue.

comment:4 Changed 4 weeks ago by Don-vip

Summary: Crashing when doing a oouple of offset corrections while Digital Globe Layer and Bing imagery are loadedIAE when switching map mode while offset dialog is open

comment:5 Changed 4 weeks ago by Don-vip

Ticket #16303 has been marked as a duplicate of this ticket.

comment:6 Changed 4 weeks ago by Don-vip

Owner: changed from team to Don-vip
Status: newassigned

comment:7 Changed 3 weeks ago by Don-vip

Resolution: fixed
Status: assignedclosed

In 13847/josm:

fix #16302 - IAE when switching map mode while offset dialog is open

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Don-vip.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.