Modify

Opened 2 months ago

Closed 2 months ago

#16725 closed defect (fixed)

numeric attributes of GPX waypoints are no longer exported

Reported by: anonymous Owned by: team
Priority: normal Milestone: 18.09
Component: Core Version:
Keywords: template_report gpx hdop vdop pdop export nmea regression Cc:

Description (last modified by Don-vip)

What steps will reproduce the problem?

  1. NMEA-Log imported contains HDOP,PDOP,VDOP
  2. export as GPX discards HDOP VDOP PDOP

What is the expected result?

GPX1.1 allows HDOP,PDOP,VDOP, which are also reported from NMEA-Logs
JOSM should save as much data is present and possible to the currently used standard:

$xxGSV reports visible/used satelites their position in the sky and signal quality
$xxGSA reports used satelites and HDOP,VDOP,PDOP which are allowed in GPX1.1

<HDOP> float </HDOP>
<sat> 13 </sat>

What happens instead?

JOSM does not export HDOP,VDOP,PDOP, even if present in the loaded/converted data, but does use/display them

Please provide any additional information below. Attach a screenshot if possible.

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2018-08-22 23:02:00 +0200 (Wed, 22 Aug 2018)
Build-Date:2018-08-23 01:32:18
Revision:14180
Relative:URL: ^/trunk

Identification: JOSM/1.5 (14180 de) Linux Mint 18.3 Sylvia
Memory Usage: 1628 MB / 3548 MB (1242 MB allocated, but free)
Java version: 1.8.0_151-8u151-b12-0ubuntu0.16.04.2-b12, Oracle Corporation, OpenJDK 64-Bit Server VM
Screen: :0.0 1920x1080
Maximum Screen Size: 1920x1080
Java package: openjdk-8-jre:amd64-8u151-b12-0ubuntu0.16.04.2

Plugins:
+ gpsblam (34515)
+ gpxfilter (34506)

Last errors/warnings:
- W: No configuration settings found.  Using hardcoded default values for all pools.
- E: NMEA-Einlesen fehlgeschlagen! - <html>Importierte Koordinaten: 0<br>Ungültige Einträge: 0<br>Prüfsummenfehler: 1<br>Unbekannte Einträge: 1<br>Leere Koordinaten: 0</html>
- W: java.lang.ArrayIndexOutOfBoundsException: 17
- W: java.lang.ArrayIndexOutOfBoundsException: 17
- W: java.lang.ArrayIndexOutOfBoundsException: 17
- W: java.lang.ArrayIndexOutOfBoundsException: 17
- W: java.lang.ArrayIndexOutOfBoundsException: 17

Attachments (0)

Change History (6)

comment:1 Changed 2 months ago by Don-vip

Ticket #16724 has been marked as a duplicate of this ticket.

comment:2 Changed 2 months ago by Don-vip

Keywords: gpx hdop vdop pdop export nmea added
Priority: trivialnormal

comment:3 Changed 2 months ago by Don-vip

Description: modified (diff)
Milestone: 18.09

comment:4 Changed 2 months ago by Don-vip

Keywords: regression added

We used to export these keys, this is a regression from #14103

comment:5 Changed 2 months ago by Don-vip

Summary: gpx export cripples datanumeric attributes of GPX waypoints are no longer exported

comment:6 Changed 2 months ago by Don-vip

Resolution: fixed
Status: newclosed

In 14243/josm:

fix #16725 - numeric attributes of GPX waypoints were no longer exported (regression from #14103)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.