Modify

Opened 11 days ago

Closed 11 days ago

#16727 closed defect (worksforme)

wrong validator warning: "duplicate housenumbers"

Reported by: dieterdreist Owned by: dieterdreist
Priority: normal Milestone:
Component: Core validator Version: latest
Keywords: validator, housenumber Cc:

Description

Josm warns about "duplicate housenumbers", but it is completely normal that many things have the same address, at least with regard to the housenumber. Please try to only make validator rules that apply globally, or add a boundary property for tests that should only be performed in a certain geographic area.

Attachments (0)

Change History (2)

comment:1 Changed 11 days ago by Don-vip

Owner: changed from team to dieterdreist
Status: newneedinfo

Please attach a sample data set showing your problem.

comment:2 Changed 11 days ago by dieterdreist

Resolution: worksforme
Status: needinfoclosed

the cause was a housenumber on a building and on a gate (the latter being the correct position in Italy), and a POI which hadn't an address explicitly tagged (had the building as outer member in a multipolygon relation). I have now moved the address from the building to the POI and the warning disappeared.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain dieterdreist.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.