Modify

Opened 7 weeks ago

Closed 7 weeks ago

Last modified 5 weeks ago

#16350 closed defect (fixed)

WMS raise error 'Can't parse XML request'

Reported by: kuemmling@… Owned by: team
Priority: normal Milestone: 18.06
Component: Core imagery Version:
Keywords: template_report wms germany regression Cc: wiktorn

Description

What steps will reproduce the problem?

  1. load a data set in Saxony
  2. open Background Sachsen Digitales Geländemodell/Schummerungsbilder/Relief
  3. no tiles appears. only a red error message

What is the expected result?

tiles with relief as background

What happens instead?

error message, this happens since last update of JOSM

Please provide any additional information below. Attach a screenshot if possible.

I used Java 8 by today, now I installed Java 10 but the error Comes again.

Relative:URL: ^/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2018-05-31 00:51:20 +0200 (Thu, 31 May 2018)
Revision:13878
Build-Date:2018-05-30 22:58:01
URL:https://josm.openstreetmap.de/svn/trunk

Identification: JOSM/1.5 (13878 de) Windows 10 64-Bit
OS Build number: Windows 10 Pro 1803 (17134)
Memory Usage: 237 MB / 1972 MB (44 MB allocated, but free)
Java version: 10.0.1+10, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: \Display0 1920x1080
Maximum Screen Size: 1920x1080
Dataset consistency test: No problems found

Plugins:
+ print (34109)

Map paint styles:
- https://github.com/bastik/mapcss-tools/raw/osm/mapnik2mapcss/osm-results/mapnik.zip

Last errors/warnings:
- E: Can't parse XML request.
- E: Can't parse XML request.
- E: Can't parse XML request.
- E: Can't parse XML request.
- E: Can't parse XML request.
- E: Can't parse XML request.
- E: Can't parse XML request.
- E: Can't parse XML request.
- E: Can't parse XML request.
- E: Can't parse XML request.

Attachments (0)

Change History (5)

comment:1 Changed 7 weeks ago by Don-vip

Component: CoreCore imagery
Keywords: wms germany added

comment:2 Changed 7 weeks ago by Don-vip

Cc: wiktorn added
Milestone: 18.06

The URL being called is:
https://geodienste.sachsen.de/wms_geosn_hoehe/guest??FORMAT=image/png&TRANSPARENT=TRUE&VERSION=1.1.1&SERVICE=WMS&REQUEST=GetMap&LAYERS=aktualitaet&STYLES=&SRS=EPSG:3857&WIDTH=512&HEIGHT=512&BBOX=1530268.3793108,6632288.6463892,1530421.2533608,6632441.5204392

Result:

<ServiceExceptionReport version="1.1.1"><ServiceException code="InvalidFormat">
Can't parse XML request.
  </ServiceException></ServiceExceptionReport>

There's a double "??" causing the error. It seems to be the error causing WMSEndpointTileSourceTest.testDefaultLayerSetInMaps to fail too. Seems to be a regression from r13878.

comment:3 Changed 7 weeks ago by Don-vip

Keywords: regression added

comment:4 Changed 7 weeks ago by wiktorn

Resolution: fixed
Status: newclosed

In 13883/josm:

Fix double quotation marks in get map queries.

Closes: #16350

comment:5 Changed 5 weeks ago by Don-vip

Ticket #16384 has been marked as a duplicate of this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.