Modify

Opened 4 months ago

Closed 3 days ago

Last modified 3 days ago

#16242 closed enhancement (fixed)

JOSM validation, suggested warning: "way with bicycle=no is part of a bicycle route relation".

Reported by: AnkEric Owned by: team
Priority: normal Milestone: 18.08
Component: Core validator Version:
Keywords: Cc:

Description (last modified by Klumbumbus)

Already in relation.mapcss:
JOSM validation, warning: "way with bicycle=use_sidepath is part of a bicycle route relation".

Also suggested:
JOSM validation, warning: "way with bicycle=no is part of a bicycle route relation".

Attachments (1)

Molenlaan [route=bicycle] and [bicycle=no].osm (656.3 KB) - added by AnkEric 9 days ago.

Download all attachments as: .zip

Change History (9)

comment:1 Changed 4 months ago by Klumbumbus

Component: CoreCore validator
Description: modified (diff)

Bicyle routes may include very short parts where bicyclists are not allowed to ride and must dismount, e.g. pedestrian underpasses. So if we add the test for bicycle=no too then we should maybe skip short (<75m?) ways .

comment:2 Changed 4 months ago by AnkEric

Even a short way (<1m) having [bicycle=no] will stop a router from navigating this bicycle route.
So a Warning (not an Error) is justified, even for short ways.
It might be advisable to set [bicyle=dismount] if "bicyclists are not allowed to ride and must dismount". Which is common and good practice.
Also [bicycle=use_sidepath] is less restrictieve than [bicycle=no] is. [Bicycle=no] has no room for exceptions ("no" is "no"), so a warning is even more justified.

comment:3 in reply to:  2 ; Changed 3 months ago by Klumbumbus

Replying to AnkEric:

Even a short way (<1m) having [bicycle=no] will stop a router from navigating this bicycle route.

Thats the decision of the router if it will route there or not. Bicycle routers even route along steps (https://github.com/graphhopper/graphhopper/issues/390).

It might be advisable to set [bicyle=dismount] if "bicyclists are not allowed to ride and must dismount". Which is common and good practice.

There was no clear consensus about this tag in the past (#9158). However maybe it could be reconsidered.

Also [bicycle=use_sidepath] is less restrictieve than [bicycle=no] is.

No, in detail it may depend a bit on the specific laws of the country, however bicycle=use_sidepath ususally means that you have to use the sidepath and are not allowed to use the main road. Therefore these are usually only longer sections.

[Bicycle=no] has no room for exceptions ("no" is "no"), so a warning is even more justified.

A bicycle route is rather a signposted recommendation where you could do a nice bicycle tour on your sunday afternoon and has nothing to do with the laws which sections are allowed to ride with the bicycle. Of cause it makes sense to use mainly cycleways but a route may contain also short sections where cycling is not allowed e.g. to avoid long dertours.

comment:4 Changed 3 months ago by AnkEric

Everything is a router decision. If a router decides to allow for bicycle routing over water than that's possible.
But for a good bicycle router it makes more sense to only route over steps having [ramp=yes], to avoid [bicycle=use_sidepath] and to block routing over [bicycle=no] sections.

[bicycle=use_sidepath] is less restrictieve than [bicycle=no] is. [bicycle=use_sidepath] was created to mitigate non-acceptable [bicycle=no] where exceptions to the rule are possible/allowed/necessary.
A bicycle route has nothing to do with law. But cycling where [bicycle=no] applies (traffic_sign!) is an offence and therefore not allowed. So routing a bicyle route over a bicycle section having bicycle=no or bicycle=use_sidepath is at least unlikely. Therefore a Warning and not an Error.

My main argument: JOSM is now warning for [bicycle=use_sidepath] on a cycle route. In my view it makes perfect sense to also warn for [bicycle=no] on a cycle route.
I recently made this mistake, blocking bicycle routing over a bridge and JOSM did not warn me: "Are you sure...?".

comment:5 in reply to:  3 Changed 3 months ago by anonymous

Replying to Klumbumbus:

A bicycle route is rather a signposted recommendation where you could do a nice bicycle tour on your sunday afternoon and has nothing to do with the laws which sections are allowed to ride with the bicycle. Of cause it makes sense to use mainly cycleways but a route may contain also short sections where cycling is not allowed e.g. to avoid long dertours.

A cycle route has only a minor relation to cycleways.
A good bicycle router allows you to follow (prefer) bicycle routes.
A cyclist - sometimes - wants to follow a bicycle route ("signposted recommendation") and therefore creates a GPS route that will follow this route. For most (or if you want: for some) routers a section having [bicycle=no/use_sidepath] will be blocked for routing. Which makes sense. Although for specific bicycles (more than 75 cm wide) [bicycle=use_sidepath] is not applicable (depending on country law). This is one of the exceptions to the rule...
Cycling where cycling is not allowed e.g. to avoid long detours is a violation of law: "not allowed". Which makes a bicycle route having [bicycle=no/use_sidepath] sections unlikely, or a temporary exception (construction).

Changed 9 days ago by AnkEric

comment:6 Changed 9 days ago by AnkEric

A decision would be appreciated. Or does "priority=normal" mean the RFC has been approved, but I'm just impatience?

Each highway not routing for bicycle is a show-stopper during holiday trip preparation.

Again:

IF JOSM DOES NOT warn for: "way with bicycle=use_sidepath is part of a bicycle route relation"...
... AND JOSM DOES NOT warn for: "way with bicycle=no is part of a bicycle route relation"...
... than that's okay. I don't agree, but I have to accept this as a fact of life.
JOSM doesn't validate bicycle access and bicycle route relation.

IF JOSM DOES NOT warn for: "way with bicycle=use_sidepath is part of a bicycle route relation"...
... AND JOSM DOES warn for: "way with bicycle=no is part of a bicycle route relation"
... than that's okay. I don't agree but I have to accept this as a fact of life.
Perhaps because [bicycle=no] is more restrictive than [bicycle=use_sidepath]?

But:

IF JOSM DOES warn for: "way with bicycle=use_sidepath is part of a bicycle route relation"...
... AND JOSM DOES NOT warn for: "way with bicycle=no is part of a bicycle route relation"...
... than that's NOT OK!

One example of an ERROR: Netherlands, Texel, Cocksdorp, Molenlaan.
Create cycling route from hub=24 to hub=32.
Gap in bicycle route.
Route will detour.
The error is most likely due to the cyleway (traffic_sign=NL:G11 (not mapped), so compulsory cycleway) at the beginning (west side) of Molenlaan.
Therefore [bicycle=no] was set. Correct would be: [bicycle=use_sidepath]. This is a common (minor) error on OSM.
But the real error is the fact [bicycle=no] has also been set on Molenlaan not having a cycleway parallel. Instead: a footway is parallel. The cycleway ends by a footway and therefore now [bicycle=no/use_sidepath] is incorrect. Cocksdorp cannot be reached by bicycle (without a detour)!
In my view: a JOSM warning would be very helpful and appreciated.

Attached: "Molenlaan [route=bicycle] and [bicycle=no].osm", after making the mapping corrections. See: history for error state.

https://s25.postimg.cc/wcg6tqrwf/2018-08-05_15-05-18.png

Osmose is already showing this warning...

https://s25.postimg.cc/ol8nms54f/2018-08-06_02-56-38.png

And JOSM is still ignoring: "A bicycle route is rather a signposted recommendation where you could do a nice bicycle tour on your sunday afternoon and has nothing to do with the laws which sections are allowed to ride with the bicycle."

Please also consider one of the dedicated Validation Tools for bicycle: "Bicycle tags on OSM" (http://mijndev.openstreetmap.nl/~ligfietser/fiets/).
This tool also reports this as a "bug in tags": "cycle routes & bicycle=no|use_sidepath".
This example is less painful, because the highway can be routed by bicycle, using the cycleway. As intended. Only the bicycle route is not respecting [bicycle=no] (and this is "only" a lcn route).

https://s25.postimg.cc/qo9w2uv9r/2018-08-05_15-23-42.png

Last edited 9 days ago by AnkEric (previous) (diff)

comment:7 Changed 3 days ago by Klumbumbus

Resolution: fixed
Status: newclosed

In 14124/josm:

fix #16242, see #15208 - warn about bicycle=no ways being part of bicycle route relations

comment:8 Changed 3 days ago by Klumbumbus

Milestone: 18.08

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.