Modify

Opened 4 months ago

Closed 4 months ago

Last modified 4 months ago

#16243 closed defect (fixed)

Unable to load files via Windows shortcut files (*.lnk)

Reported by: maarten Owned by: team
Priority: normal Milestone: 18.04
Component: Core Version: latest
Keywords: windows shortcut link Cc:

Description

Tested with the webstart 13576 version.

In windows you can make shortcuts to files (like in Unix), but JOSM will not load them. The error message is "Cannot open 1 file because it does not exist or no suitable file importer is available."
This probably due to the fact that windows calls shortcut files [something] - Shortcut.lnk and JOSM sees .lnk as extension and uses that to decide what to do with it.
Windows itself seems ok with it, when I double-click a shortcut if a .jpg file, it opens Irfanview, which is my default image viewer for .jpg files.
This error does not occur in Unix, Unix handles links more gracefully.
Renaming the file in a cmd box works when you remove the .lnk extension (renaming it in the explorer does not remove the .lnk extension), so there is no inherit problem opening links.

Attachments (0)

Change History (6)

comment:1 Changed 4 months ago by Don-vip

Milestone: 18.04

comment:2 Changed 4 months ago by Don-vip

Keywords: link added; image removed
Summary: Windows shortcut images will not load in josmUnable to load files via Windows shortcut files (*.lnk)

comment:3 Changed 4 months ago by Don-vip

Resolution: fixed
Status: newclosed

In 13691/josm:

fix #16243 - load files via Windows shortcut files (*.lnk)

comment:4 Changed 4 months ago by Don-vip

In 13692/josm:

see #16243 - do not rely on internal JDK classes, not available on Linux

comment:5 Changed 4 months ago by Don-vip

Ticket #16244 has been marked as a duplicate of this ticket.

comment:6 Changed 4 months ago by Don-vip

In 13697/josm:

see #16243 - fix introduced SonarQube issues

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.