Modify

Opened 4 weeks ago

Closed 3 weeks ago

#16244 closed defect (duplicate)

Windows shortcut images EXIF data is not read

Reported by: maarten Owned by: maarten
Priority: normal Milestone:
Component: Core Version: latest
Keywords: windows shortcut image EXIF Cc:

Description (last modified by Don-vip)

Tested with the webstart 13576 version.

If you have a shortcut to an image in Windows (with proper filename, see #16243) and open the image in JOSM, the GPS location is not being read from the EXIF data and JOSM opens the dialog to correlate the image to a GPX file.
When you open the image itself, JOSM reads the GPS location from the EXIF data no problem.
When I open the shortcut image in Irfanview, I can view the GPS location in the EXIF data.

Attachments (0)

Change History (4)

comment:1 Changed 3 weeks ago by Don-vip

Description: modified (diff)

comment:2 Changed 3 weeks ago by Don-vip

Owner: changed from team to maarten
Status: newneedinfo

I believe this is fixed in r13692, can you please check with latest?

comment:3 Changed 3 weeks ago by maarten

Yes, this is fixed in 13692. It only works correctly with proper shortcut links (.lnk files), GPS EXIF data still does not get read when you manually rename the file to a .jpg file, but I think that is not really worth trying to fix (as you need to jump through hoops to remove the .lnk extension anyway).
Big thanks.

comment:4 Changed 3 weeks ago by Don-vip

Resolution: duplicate
Status: needinfoclosed

Closed as duplicate of #16243.
OK thanks for testing! :)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain maarten.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.