Modify

Opened 13 months ago

Last modified 25 hours ago

#15918 new enhancement

Confusing English texts

Reported by: Hb--- Owned by: Hb---
Priority: normal Milestone:
Component: Core Version:
Keywords: i18n english Cc:

Description

Select Panel

The Select button on several panel dialogs has the string
"Set the selected elements on the map to the selected items in the list above."
The German translation in tested "Ausgewählte Elemente auf der Karte auf die obige Liste der ausgewählten Objekte setzen." is wrong because the button selects elements on the map according to the list. The original string is in the code since r86 and also used in plugins/opendata/src/org/openstreetmap/josm/plugins/opendata/core/gui/OdDialog.java

The new German translation in latest "Wählt jene Elemente auf der Karte aus, die in obiger Liste markiert sind." does not solve this issue for all other languages.

I suggest "Selects those elements on the map which are chosen on the list above." but that might be far away from being good English.

File/

Menu items usually have three periods after their names to indicated that a dialog follows and no direct action, i.e. Save As.... These dots are currently missing for

So please add ... the source strings.

AlignImageryPanel

The nag panel for misaligned imagery has a checkbox "Do not show this message again" and a button with the tooltipText "Hide this message and never show it again" to close the panel in line 55.

  1. Open Bing aerial
  2. Close the nag while leaving the checkbox=false
  3. Delete the imagery layer
  4. Open Bing aerial again

The nag appears as expected. So the "never again" part is wrong. The tooltip text should be set to "Hide this."

Attachments (0)

Change History (12)

comment:1 Changed 13 months ago by Don-vip

Owner: changed from team to Hb---
Status: newneedinfo

You already almost made the job, could you please attach a patch?

comment:2 Changed 5 months ago by simon04

Milestone: 18.11
Owner: changed from Hb--- to team
Status: needinfonew

comment:3 Changed 5 months ago by simon04

Owner: changed from team to simon04

comment:4 Changed 5 months ago by simon04

Resolution: fixed
Status: newclosed

In 14390/josm:

fix #15918 - Confusing English texts (thanks to Hb---)

comment:5 Changed 4 months ago by Klumbumbus

Resolution: fixed
Status: closedreopened

There was a little mistake in r14390. The dots for Imagery preferences were added in the preferences itself instead of in the menu entry.

comment:6 Changed 4 months ago by Don-vip

Milestone: 18.1118.12

comment:7 Changed 3 months ago by Don-vip

Milestone: 18.1219.01

comment:8 Changed 3 months ago by simon04

Resolution: fixed
Status: reopenedclosed

In 14629/josm:

fix #15918 - Confusing English texts (Imagery preferences)

comment:9 Changed 8 weeks ago by simon04

Milestone: 19.0119.02
Resolution: fixed
Status: closedreopened

I found a few more (actions displaying a dialog w/o ... in their name):

  • Jump to Position
  • Preset preferences
  • Search menu items

comment:10 Changed 4 weeks ago by Don-vip

Milestone: 19.0219.03

comment:11 in reply to:  1 Changed 9 days ago by Hb---

Milestone: 19.03
Owner: changed from simon04 to Hb---
Priority: minornormal
Status: reopenednew

Replying to Don-vip:

You already almost made the job, could you please attach a patch?

Current efforts are visible in Glossary and in the en_CA translation. While the source strings have 673 occurrences of "select" the Canadian dialect has only 68. Affected are around 400 source strings. Seems not to be ready by March.

comment:12 Changed 25 hours ago by Hb---

Ticket #13689 has been marked as a duplicate of this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as new The owner will remain Hb---.
as The resolution will be set.
to The owner will be changed from Hb--- to the specified user.
The owner will change to Hb---
as duplicate The resolution will be set to duplicate.The specified ticket will be cross-referenced with this ticket
The owner will be changed from Hb--- to anonymous.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.