Modify

Opened 7 months ago

Closed 3 months ago

Last modified 3 weeks ago

#15497 closed enhancement (fixed)

Missing pedestrian crossing information on highway=crossing node

Reported by: mkoniecz Owned by: team
Priority: normal Milestone: 18.02
Component: Core validator Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. download area around https://www.openstreetmap.org/node/415796576#map=19/53.13318/23.15927
  2. select https://www.openstreetmap.org/node/415796576#map=19/53.13318/23.15927
  3. run validator

What is the expected result?

nothing

What happens instead?

Missing pedestrian crossing information (1)

Please provide any additional information below. Attach a screenshot if possible.

It is unclear what should be added - highway=crossing is already present

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2017-10-27 01:11:39 +0200 (Fri, 27 Oct 2017)
Build-Date:2017-10-27 01:32:02
Revision:13044
Relative:URL: ^/trunk

Identification: JOSM/1.5 (13044 en) Linux Ubuntu 16.04.3 LTS
Memory Usage: 450 MB / 871 MB (140 MB allocated, but free)
Java version: 1.8.0_151-b12, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: :0.0 1920x1080
Maximum Screen Size: 1920x1080
Dataset consistency test: No problems found

Plugins:
+ OpeningHoursEditor (33185)
+ buildings_tools (33735)
+ lakewalker (33712)
+ reverter (33572)
+ undelete (33480)

Map paint styles:
- https://josm.openstreetmap.de/josmfile?page=Styles/AdvertisingStyle&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/MaxspeedIcons&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/LessObtrusiveNodes&zip=1
+ ${HOME}/Documents/install_moje/josm_style_sidewalks/Styles_Sidewalks-style.mapcss
+ https://josm.openstreetmap.de/josmfile?page=Styles/NumberedWalkingNodeNetworks&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Styles/HU-HighlightHikingTrailSigns&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Fixme&zip=1
+ ${HOME}/Desktop/tmp/josmfile

Validator rules:
+ ${HOME}/Documents/install_moje/josm_validator/josm.validator.mapcss

Last errors/warnings:
- W: New conflict: Conflict [my={Node id=4746820598 version=2 D }, their={Node id=4746820598 version=0 IV lat=53.1320023,lon=23.1638778}]
- W: New conflict: Conflict [my={Node id=4746820599 version=2 D }, their={Node id=4746820599 version=0 IV lat=53.1319844,lon=23.1638436}]
- W: New conflict: Conflict [my={Node id=4746820600 version=2 D }, their={Node id=4746820600 version=0 IV lat=53.1319738,lon=23.163794}]
- W: New conflict: Conflict [my={Node id=4746820595 version=2 D }, their={Node id=4746820595 version=0 IV lat=53.1319328,lon=23.1635205}]
- W: New conflict: Conflict [my={Node id=4746820593 version=2 D }, their={Node id=4746820593 version=0 IV lat=53.1319169,lon=23.1634563}]
- W: New conflict: Conflict [my={Node id=4746820594 version=2 D }, their={Node id=4746820594 version=0 IV lat=53.1318951,lon=23.1633683}]
- W: New conflict: Conflict [my={Node id=4746820592 version=2 D }, their={Node id=4746820592 version=0 IV lat=53.1317465,lon=23.1628882}]
- W: Conflicts detected - <html>There were 72 conflicts detected.</html>
- W: Conflicts detected - <html>There were 2 conflicts detected.</html>
- W: Merging deleted objects failed - <html>The following objects could not be copied to the target object<br>because they are deleted in the target dataset:<ul><li>node 5194306705</li><li>node 5194306689</li><li>node 5194306691</li><li>node 5194306690</li><li>node 5194306688</li><li>30 more...</li></ul></html>

Attachments (0)

Change History (7)

comment:1 Changed 7 months ago by Don-vip

Resolution: invalid
Status: newclosed

comment:2 Changed 7 months ago by anonymous

Resolution: invalid
Status: closedreopened

I suggest changing message to mention that crossing=* is missing. It is not obvious what should be added - especially for new mappers.

I think that "Missing pedestrian crossing information. crossing tag should be added" would be far better, also for an experienced users.

comment:3 Changed 7 months ago by anonymous

Type: defectenhancement

comment:4 Changed 3 months ago by Klumbumbus

Resolution: fixed
Status: reopenedclosed

In 13405/josm:

fix #15497 - Improve "Missing pedestrian crossing information." validator message.

comment:5 Changed 3 months ago by Klumbumbus

Milestone: 18.02

comment:6 Changed 5 weeks ago by Klumbumbus

regression, see #16186

comment:7 Changed 3 weeks ago by Klumbumbus

In 13687/josm:

fix #16186, see #15497 - fix "Incomplete pedestrian crossing tagging" validator message.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.