Modify

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#15496 closed defect (duplicate)

Need help to upload changed data to server

Reported by: mhai Owned by: team
Priority: normal Milestone:
Component: unspecified Version: latest
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. Do some changes within the map
  2. Click onto upload button to save changed data to the JOSM serverFill in
  3. Fill in necessary data to describe changes

What is the expected result?

Data will be uploaded to the server

What happens instead?

Legitimation refused and i will be forced to check my username and password

Please provide any additional information below. Attach a screenshot if possible.

Double checked username and password and it should be correct as it is possible for me with these data to login via web interface onto JOSM Server

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2017-10-03 21:43:00 +0200 (Tue, 03 Oct 2017)
Build-Date:2017-10-03 19:50:21
Revision:12921
Relative:URL: ^/trunk

Identification: JOSM/1.5 (12921 de) Windows 10 64-Bit
OS Build number: Windows 10 Home 1703 (15063)
Memory Usage: 375 MB / 910 MB (173 MB allocated, but free)
Java version: 1.8.0_66-b18, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: \Display0 1920x1080, \Display1 1280x1024
Maximum Screen Size: 1920x1080

Plugins:
+ poly (33570)
+ turnrestrictions (33537)
+ utilsplugin2 (33704)

Last errors/warnings:
- W: No configuration settings found.  Using hardcoded default values for all pools.
- W: org.openstreetmap.josm.io.OsmApiException: ResponseCode=401

Attachments (1)

JOSM Upload Error.JPG (43.5 KB) - added by mhai 3 years ago.
screenshot with error message after upload

Download all attachments as: .zip

Change History (3)

Changed 3 years ago by mhai

Attachment: JOSM Upload Error.JPG added

screenshot with error message after upload

comment:1 Changed 3 years ago by Don-vip

Resolution: duplicate
Status: newclosed

Closed as duplicate of #15435.
You probably entered a wrong password the first time, and encountered bug #15435.
You need to restart JOSM. The bug is fixed in latest version.

comment:2 in reply to:  description Changed 3 years ago by Klumbumbus

Replying to mhai:

as it is possible for me with these data to login via web interface onto JOSM Server

Also make sure to use your login data from osm.org, not from the josm website. These are different accounts.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.