Modify

Opened 6 years ago

Closed 6 years ago

#13511 closed defect (duplicate)

Crash of Improve Accuracy

Reported by: anonymous Owned by: team
Priority: normal Milestone:
Component: Plugin Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. Start plug-in without choosing way first.
  2. Close plug-in using ESC

What is the expected result?

I would thing that you could activate the tool then make the choice of which way.

What happens instead?

Plugin crashes and yields bug report dialog box in the event of either action, beginning or ending. Otherwise if you select the way first no problem or if you close by picking another tool it seems to work.

Please provide any additional information below. Attach a screenshot if possible.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2016-08-11 21:54:24 +0200 (Thu, 11 Aug 2016)
Build-Date:2016-08-11 22:36:05
Revision:10786
Relative:URL: ^/trunk

Identification: JOSM/1.5 (10786 en) Windows 10 64-Bit
Memory Usage: 526 MB / 910 MB (147 MB allocated, but free)
Java version: 1.8.0_65-b17, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Dataset consistency test: No problems found

Plugins:
+ AddrInterpolation (32699)
+ BuildingGeneralization (1010)
+ FastDraw (32773)
+ FixAddresses (32796)
+ ImproveWay (1452443304)
+ PicLayer (32796)
+ RoadSigns (32796)
+ ShapeTools (1210)
+ alignways (32796)
+ apache-commons (32699)
+ auto_tools (1471534390)
+ buildings_tools (32796)
+ continuosDownload (53)
+ contourmerge (1021)
+ dataimport (32699)
+ editgpx (32699)
+ fieldpapers (v0.4.0)
+ imagery_offset_db (32796)
+ imageryadjust (32699)
+ measurement (32732)
+ merge-overlap (32699)
+ pdfimport (32796)
+ photoadjust (32863)
+ reltoolbox (32796)
+ reverter (32796)
+ terracer (32699)
+ turnlanes (32796)
+ turnlanes-tagging (1471546398)
+ utilsplugin2 (32815)
+ walkingpapers (32796)
+ wikipedia (32884)

Tagging presets:
+ https://josm.openstreetmap.de/josmfile?page=Presets/BuildingPreset&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Crafts&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Historical_Objects&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Mountains&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/OneClick&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Playground_Equipment&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Quick-highways&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/PublicTransportOneClick&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/BicycleJunction&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Communication_Towers&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/NewParkingFeatures&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Quick-stops&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Golf_Course&zip=1

Last errors/warnings:
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- E: java.lang.NoSuchFieldError: isSelectablePredicate
- E: java.lang.NoSuchFieldError: isSelectablePredicate


=== REPORTED CRASH DATA ===
BugReportExceptionHandler$BugReporterThread#askForBugReport:
No data collected.

=== STACK TRACE ===
Thread: AWT-EventQueue-0 (20) of main
java.lang.NoSuchFieldError: isSelectablePredicate
	at hu.kolesar.josm.plugin.ImproveWay.ImproveWayAccuracyHelper.findWay(ImproveWayAccuracyHelper.java:43)
	at hu.kolesar.josm.plugin.ImproveWay.ImproveWayAccuracyAction.updateCursorDependentObjectsIfNeeded(ImproveWayAccuracyAction.java:875)
	at hu.kolesar.josm.plugin.ImproveWay.ImproveWayAccuracyAction.mouseMoved(ImproveWayAccuracyAction.java:679)
	at java.awt.AWTEventMulticaster.mouseMoved(Unknown Source)
	at java.awt.Component.processMouseMotionEvent(Unknown Source)
	at javax.swing.JComponent.processMouseMotionEvent(Unknown Source)
	at java.awt.Component.processEvent(Unknown Source)
	at java.awt.Container.processEvent(Unknown Source)
	at java.awt.Component.dispatchEventImpl(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Unknown Source)
	at java.awt.LightweightDispatcher.processMouseEvent(Unknown Source)
	at java.awt.LightweightDispatcher.dispatchEvent(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Window.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
	at java.awt.EventQueue.access$500(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.run(Unknown Source)

Attachments (0)

Change History (2)

comment:1 Changed 6 years ago by Klumbumbus

Component: CorePlugin improvewayaccuracy

comment:2 Changed 6 years ago by simon04

Component: Plugin improvewayaccuracyPlugin
Resolution: duplicate
Status: newclosed

Closed as duplicate of #13356.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.