Modify

Opened 3 years ago

Closed 3 years ago

#13512 closed defect (fixed)

Fehler wenn Versatzdialog nicht geschlossen wird.

Reported by: brogo Owned by: team
Priority: normal Milestone: 16.08
Component: Core imagery Version:
Keywords: template_report regression gsoc-core Cc: michael2402

Description

What steps will reproduce the problem?

  1. Datenlayer und Bing-Hintergrundlayer öffnen
  2. Bing-Luftbilder über "neuer Versatz" ausrichten, Fenster NICHT mit OK bestätigen
  3. Anfangen zu Mappen mit "a".

What is the expected result?

keine Fehlermeldung

What happens instead?

Fehlermeldung

Please provide any additional information below. Attach a screenshot if possible.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2016-08-20 01:28:07 +0200 (Sat, 20 Aug 2016)
Build-Date:2016-08-20 01:36:08
Revision:10859
Relative:URL: ^/trunk

Identification: JOSM/1.5 (10859 de) Windows 7 64-Bit
Memory Usage: 200 MB / 247 MB (88 MB allocated, but free)
Java version: 1.8.0_101-b13, Oracle Corporation, Java HotSpot(TM) Client VM
VM arguments: [-Duser.home=%UserProfile%]
Dataset consistency test: No problems found

Plugins:
+ DirectUpload (32699)
+ FixAddresses (32796)
+ HouseNumberTaggingTool (32699)
+ InfoMode (32789)
+ OpeningHoursEditor (32699)
+ PicLayer (32796)
+ RoadSigns (32796)
+ apache-commons (32699)
+ apache-http (32699)
+ buildings_tools (32796)
+ editgpx (32699)
+ ejml (32680)
+ geotools (32813)
+ gpxfilter (32699)
+ imagery_offset_db (32796)
+ jts (32699)
+ measurement (32732)
+ opendata (32811)
+ pbf (32865)
+ poly (32699)
+ print (32699)
+ reltoolbox (32796)
+ reverter (32796)
+ terracer (32699)
+ tofix (267)
+ undelete (32699)
+ utilsplugin2 (32815)

Tagging presets:
+ Y:\JOSM\gebäude.xml

Map paint styles:
+ https://josm.openstreetmap.de/josmfile?page=Styles/Coloured_Streets&style&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Coloured_buildings&style&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Maxspeed&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Lane_and_Road_Attributes&zip=1
- https://github.com/bastik/mapcss-tools/raw/osm/mapnik2mapcss/osm-results/mapnik.zip
- Y:\JOSM\knick.mapcss

Last errors/warnings:
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: AWT-EventQueue-0 (16) of main
java.lang.IllegalArgumentException: Listener org.openstreetmap.josm.actions.ImageryAdjustAction@ce306b (instance of org.openstreetmap.josm.actions.ImageryAdjustAction) was not registered before or already removed.
	at org.openstreetmap.josm.tools.ListenerList.failRemove(ListenerList.java:129)
	at org.openstreetmap.josm.tools.ListenerList.removeListener(ListenerList.java:123)
	at org.openstreetmap.josm.data.Preferences.removePreferenceChangeListener(Preferences.java:240)
	at org.openstreetmap.josm.actions.mapmode.MapMode.exitMode(MapMode.java:78)
	at org.openstreetmap.josm.actions.ImageryAdjustAction.exitMode(ImageryAdjustAction.java:88)
	at org.openstreetmap.josm.gui.MapFrame.selectMapMode(MapFrame.java:450)
	at org.openstreetmap.josm.gui.MapFrame.selectMapMode(MapFrame.java:432)
	at org.openstreetmap.josm.actions.ImageryAdjustAction$ImageryOffsetDialog.setVisible(ImageryAdjustAction.java:306)
	at org.openstreetmap.josm.actions.ImageryAdjustAction.exitMode(ImageryAdjustAction.java:93)
	at org.openstreetmap.josm.gui.MapFrame.selectMapMode(MapFrame.java:450)
	at org.openstreetmap.josm.gui.MapFrame.selectMapMode(MapFrame.java:432)
	at org.openstreetmap.josm.actions.mapmode.MapMode.actionPerformed(MapMode.java:99)
	at javax.swing.SwingUtilities.notifyAction(Unknown Source)
	at javax.swing.JComponent.processKeyBinding(Unknown Source)
	at javax.swing.KeyboardManager.fireBinding(Unknown Source)
	at javax.swing.KeyboardManager.fireKeyboardAction(Unknown Source)
	at javax.swing.JComponent.processKeyBindingsForAllComponents(Unknown Source)
	at javax.swing.JComponent.processKeyBindings(Unknown Source)
	at javax.swing.JComponent.processKeyEvent(Unknown Source)
	at java.awt.Component.processEvent(Unknown Source)
	at java.awt.Container.processEvent(Unknown Source)
	at java.awt.Component.dispatchEventImpl(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.KeyboardFocusManager.redispatchEvent(Unknown Source)
	at java.awt.DefaultKeyboardFocusManager.dispatchKeyEvent(Unknown Source)
	at java.awt.DefaultKeyboardFocusManager.preDispatchKeyEvent(Unknown Source)
	at java.awt.DefaultKeyboardFocusManager.typeAheadAssertions(Unknown Source)
	at java.awt.DefaultKeyboardFocusManager.dispatchEvent(Unknown Source)
	at java.awt.Component.dispatchEventImpl(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Window.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
	at java.awt.EventQueue.access$500(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.run(Unknown Source)

Attachments (0)

Change History (3)

comment:1 Changed 3 years ago by Klumbumbus

Component: CoreCore imagery

comment:2 Changed 3 years ago by Klumbumbus

Cc: michael2402 added
Keywords: regression gsoc-core added
Milestone: 16.08

comment:3 Changed 3 years ago by michael2402

Resolution: fixed
Status: newclosed

In 10930/josm:

Fix #13512: Do not attempt to restore old map mode when imagery dialog change was caused by map mode change.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.