Modify

Opened 3 years ago

Closed 2 years ago

Last modified 2 years ago

#13356 closed defect (fixed)

NoSuchFieldError: isSelectablePredicate - plugin.ImproveWay.ImproveWayAccuracyAction

Reported by: skquinn Owned by: kolesar
Priority: normal Milestone:
Component: Plugin ImproveWay Version:
Keywords: template_report github Cc: Don-vip

Description

What steps will reproduce the problem?

  1. Install improveway plugin in version 10786 of JOSM
  2. Select a closed way
  3. Deselect it

What is the expected result?

No error message, normal operation as in previous versions.

What happens instead?

Error message appears.

Please provide any additional information below. Attach a screenshot if possible.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2016-08-11 21:54:24 +0200 (Thu, 11 Aug 2016)
Build-Date:2016-08-11 22:36:05
Revision:10786
Relative:URL: ^/trunk

Identification: JOSM/1.5 (10786 en) Linux Ubuntu 14.04.5 LTS
Memory Usage: 452 MB / 452 MB (161 MB allocated, but free)
Java version: 1.8.0_101-b13, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
VM arguments: [-Djosm.restart=true, -Djava.net.useSystemProxies=true, -Djosm.home=<josm.pref>]
Dataset consistency test: No problems found

Plugins:
+ AddrInterpolation (32699)
+ ColorPlugin (1414145445)
+ CommandLine (32796)
+ Create_grid_of_ways (32699)
+ FastDraw (32773)
+ FixAddresses (32796)
+ HouseNumberTaggingTool (32699)
+ ImproveWay (1452443304)
+ OpeningHoursEditor (32699)
+ RoadSigns (32796)
+ SeaMapEditor (32767)
+ alignways (32796)
+ auto_tools (1468620578)
+ buildings_tools (32796)
+ continuosDownload (53)
+ contourmerge (1021)
+ graphview (32796)
+ junctionchecking (32699)
+ log4j (32699)
+ matsim (v0.7.0)
+ measurement (32732)
+ merge-overlap (32699)
+ michigan_left (32699)
+ osmarender (32699)
+ pbf (32699)
+ poly (32699)
+ reltoolbox (32796)
+ reverter (32796)
+ rex (1928)
+ routing (32796)
+ splinex (32796)
+ tageditor (32796)
+ terracer (32699)
+ todo (29154)
+ turnlanes-tagging (1470950886)
+ turnrestrictions (32796)
+ utilsplugin2 (32796)
+ waydownloader (32699)

Tagging presets:
+ https://josm.openstreetmap.de/josmfile?page=Presets/OneClick&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Towers&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Disc_Golf_Course&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Golf_Course&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Bus_lanes&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/ParkingLanes&zip=1

Map paint styles:
+ https://josm.openstreetmap.de/josmfile?page=Styles/Lane_and_Road_Attributes&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Styles/ParkingLanes&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Maxspeed&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Coloured_Streets&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Coloured_Suburb&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/NoFeature&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Surface&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/LayerChecker&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Modified&zip=1
- https://raw.githubusercontent.com/species/josm-preset-traffic_sign_direction/master/direction.mapcss
- https://josm.openstreetmap.de/josmfile?page=Styles/Noname&zip=1

Last errors/warnings:
- W: Old style SideButton usage for action org.openstreetmap.josm.plugins.JunctionChecker.JunctionCheckDialog$2@9815ce4
- W: Old style SideButton usage for action org.openstreetmap.josm.plugins.JunctionChecker.JunctionCheckDialog$3@6fac9352
- W: Old style SideButton usage for action org.openstreetmap.josm.plugins.todo.TodoDialog$SelectAction@34317910
- W: Old style SideButton usage for action org.openstreetmap.josm.plugins.todo.TodoDialog$AddAction@4b36a0f8
- W: Old style SideButton usage for action org.openstreetmap.josm.plugins.todo.TodoDialog$PassAction@4a02f8ba
- W: Old style SideButton usage for action org.openstreetmap.josm.plugins.todo.TodoDialog$MarkAction@577c6f45
- W: java.net.SocketTimeoutException: Read timed out
- E: java.net.SocketTimeoutException: Read timed out
- W: org.openstreetmap.josm.io.OsmTransferException: Could not connect to the OSM server. Please check your internet connection.. Cause: java.net.SocketTimeoutException: Read timed out
- E: java.lang.NoSuchFieldError: isSelectablePredicate

OSM API: http://opengeofiction.net/api


=== REPORTED CRASH DATA ===
BugReportExceptionHandler$BugReporterThread#askForBugReport:
No data collected.

=== STACK TRACE ===
Thread: AWT-EventQueue-0 (16) of main
java.lang.NoSuchFieldError: isSelectablePredicate
	at hu.kolesar.josm.plugin.ImproveWay.ImproveWayAccuracyHelper.findWay(ImproveWayAccuracyHelper.java:43)
	at hu.kolesar.josm.plugin.ImproveWay.ImproveWayAccuracyAction.updateCursorDependentObjectsIfNeeded(ImproveWayAccuracyAction.java:875)
	at hu.kolesar.josm.plugin.ImproveWay.ImproveWayAccuracyAction.mouseMoved(ImproveWayAccuracyAction.java:679)
	at java.awt.AWTEventMulticaster.mouseMoved(AWTEventMulticaster.java:330)
	at java.awt.Component.processMouseMotionEvent(Component.java:6578)
	at javax.swing.JComponent.processMouseMotionEvent(JComponent.java:3342)
	at java.awt.Component.processEvent(Component.java:6302)
	at java.awt.Container.processEvent(Container.java:2236)
	at java.awt.Component.dispatchEventImpl(Component.java:4889)
	at java.awt.Container.dispatchEventImpl(Container.java:2294)
	at java.awt.Component.dispatchEvent(Component.java:4711)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4888)
	at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4538)
	at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4466)
	at java.awt.Container.dispatchEventImpl(Container.java:2280)
	at java.awt.Window.dispatchEventImpl(Window.java:2746)
	at java.awt.Component.dispatchEvent(Component.java:4711)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:758)
	at java.awt.EventQueue.access$500(EventQueue.java:97)
	at java.awt.EventQueue$3.run(EventQueue.java:709)
	at java.awt.EventQueue$3.run(EventQueue.java:703)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:86)
	at java.awt.EventQueue$4.run(EventQueue.java:731)
	at java.awt.EventQueue$4.run(EventQueue.java:729)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:728)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:201)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:116)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:105)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:101)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:93)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:82)

Attachments (0)

Change History (10)

comment:1 Changed 3 years ago by michael2402

We cannot change the type of public fields. This will break binary compatibility. See #12890 about the issue.

I suggest leaving the field type a JOSM predicate, deprecating it and then removing it.

comment:2 Changed 3 years ago by michael2402

Cc: Don-vip added

comment:3 Changed 3 years ago by Don-vip

Keywords: github added

That's unnecessary work, plugins will have to be updated anyway, and as most plugins are abandoned, the update are never completely done until we remove the deprecated features.

For this case we simply need to create a PR to https://github.com/kolesar-andras/josm-plugin-improve-way

comment:4 Changed 3 years ago by Don-vip

Component: CorePlugin

comment:6 Changed 3 years ago by skquinn

Is this related at all to #13340?

comment:7 Changed 3 years ago by simon04

Ticket #13511 has been marked as a duplicate of this ticket.

comment:8 Changed 2 years ago by Don-vip

Component: PluginPlugin ImproveWay
Owner: changed from team to kolesar

comment:9 Changed 2 years ago by Don-vip

Resolution: fixed
Status: newclosed

Author abandoned his plugin and we needed to fork it, this issue was solved in https://github.com/JOSM/improve-way/releases/tag/v1.0

comment:10 Changed 2 years ago by Don-vip

Summary: Improveway plugin causes error dialogNoSuchFieldError: isSelectablePredicate - plugin.ImproveWay.ImproveWayAccuracyAction

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain kolesar.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.