Modify

Opened 3 years ago

Closed 2 weeks ago

#13474 closed defect (fixed)

Upload comment and source get reset to previous values

Reported by: SanderH Owned by: Don-vip
Priority: major Milestone: 19.04
Component: Core Version:
Keywords: template_report upload comment source changeset Cc: josm@…

Description

What steps will reproduce the problem?

  1. Make a change in OSM
  2. Upload the change with upload comment and source 'first'
  3. Make another change in OSM
  4. Upload the change and change the comment and source to 'second' on the Settings tab
  5. On the changesets tab, choose to upload to a new changeset instead of the existing changeset
  6. On the Settings tab, both the comment and source is reset to 'first'

What is the expected result?

I expect the changed upload comment and source to be retained when choosing to upload to a new changeset.
It's natural to fill the dialog from left to right, so first filling in the Settings tab, then the Changeset tab.

What happens instead?

The just entered upload comment is gone and replaced by the previous upload comment.

Please provide any additional information below. Attach a screenshot if possible.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2016-08-11 21:54:24 +0200 (Thu, 11 Aug 2016)
Build-Date:2016-08-11 22:36:05
Revision:10786
Relative:URL: ^/trunk

Identification: JOSM/1.5 (10786 en) Windows 10 64-Bit
Memory Usage: 2015 MB / 2015 MB (1136 MB allocated, but free)
Java version: 1.8.0_102-b14, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
VM arguments: [-Djava.security.manager, -Djava.security.policy=file:<java.home>\lib\security\javaws.policy, -DtrustProxy=true, -Djnlpx.home=<java.home>\bin, -Djnlpx.origFilenameArg=%UserProfile%\AppData\LocalLow\Sun\Java\Deployment\cache\6.0\56\1ee8cfb8-5ee29e1d, -Djnlpx.remove=false, -Djava.util.Arrays.useLegacyMergeSort=true, -Djnlpx.splashport=10071, -Djnlp.application.href=https://josm.openstreetmap.de/download/josm.jnlp, -Djnlpx.jvm=<java.home>\bin\javaw.exe, -Djnlpx.vmargs=LURqYXZhLnV0aWwuQXJyYXlzLnVzZUxlZ2FjeU1lcmdlU29ydD10cnVlAC1Eam5scC5hcHBsaWNhdGlvbi5ocmVmPWh0dHBzOi8vam9zbS5vcGVuc3RyZWV0bWFwLmRlL2Rvd25sb2FkL2pvc20uam5scAA=]
Dataset consistency test: No problems found

Attachments (0)

Change History (11)

comment:1 Changed 3 years ago by Don-vip

Keywords: upload comment source added

comment:2 Changed 3 years ago by Don-vip

Keywords: changeset added

comment:3 Changed 23 months ago by michael2402

I could not reproduce. It is probably fixed in r12265.

comment:4 Changed 23 months ago by SanderH

Could still replicate the issue in 12306

comment:5 Changed 15 months ago by Don-vip

Ticket #15879 has been marked as a duplicate of this ticket.

comment:6 Changed 15 months ago by Don-vip

Cc: josm@… added
Priority: normalmajor

From #15879:

Click the upload button on the toolbar
Type a changeset comment and then press Ctrl+Enter

comment:7 Changed 12 months ago by ff5722

Still had this bug, I used the normal workflow of only filling in comment and source, then clicking upload.

I did merge layers before uploading, could this be related?

comment:8 Changed 2 weeks ago by Don-vip

Owner: changed from team to Don-vip
Status: newassigned

comment:9 Changed 2 weeks ago by Don-vip

Reproduced with r14976

comment:10 Changed 2 weeks ago by Don-vip

Milestone: 19.04

comment:11 Changed 2 weeks ago by Don-vip

Resolution: fixed
Status: assignedclosed

In 14977/josm:

ensures consistency of upload comment:

  • fix #11168 - ctrl-z/undo could reset unwanted old changeset comment
  • fix #13474 - selecting "new changeset" after having entered a changeset comment did reset it to the previous value
  • fix #17452 - ctrl-enter while typing a changeset comment did upload with the previous value
  • fix behaviour of upload.comment.max-age: values were reset after 5 months instead of intended 4 hours because seconds were compared to milliseconds
  • avoid creation of unneeded undo/redo internal classes for non-editable text fields
  • ensures consistency of upload dialog if upload.comment properties are modified manually from advanced preferences
  • add a source attribute to preference events to know which class modified the preference entry
  • refactor reflection utils

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Don-vip.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.