Modify

Opened 7 months ago

Closed 6 months ago

#15879 closed defect (duplicate)

Incorrect changeset comment being uploaded

Reported by: josm@… Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: template_report changeset upload comment Cc:

Description

What steps will reproduce the problem?

  1. Make some changes in JOSM
  2. Click the upload button on the toolbar
  3. Type a changeset comment and then press Ctrl+Enter
  4. Find the changeset on OSM and check the comment

What is the expected result?

  • Changeset comment shown on OSM matches that entered in JOSM

What happens instead?

  • The changeset comment is the same as for the changeset before it

Please provide any additional information below. Attach a screenshot if possible.

This has happened to me on the following changesets

After step 4 perform the following actions:

  1. Make another change in JOSM
  2. Click the upload button on the toolbar

The text I entered for the previous changeset is displayed

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2018-01-28 23:08:56 +0100 (Sun, 28 Jan 2018)
Build-Date:2018-01-28 22:25:44
Revision:13367
Relative:URL: ^/trunk

Identification: JOSM/1.5 (13367 en_GB) Linux Ubuntu 17.10
Memory Usage: 622 MB / 1292 MB (245 MB allocated, but free)
Java version: 1.8.0_151-8u151-b12-0ubuntu0.17.10.2-b12, Oracle Corporation, OpenJDK 64-Bit Server VM
Screen: :0.0 1920x1080
Maximum Screen Size: 1920x1080
Java package: openjdk-8-jre:amd64-8u151-b12-0ubuntu0.17.10.2
Java ATK Wrapper package: libatk-wrapper-java:all-0.33.3-13
VM arguments: [-Djosm.restart=true, -Djava.net.useSystemProxies=true]
Dataset consistency test: No problems found

Plugins:
+ reverter (34036)
+ terracer (33839)
+ undelete (33980)
+ utilsplugin2 (33991)

Last errors/warnings:
- W: No configuration settings found.  Using hardcoded default values for all pools.
- W: Conflict in data - <html>This relation has been changed outside of the editor.<br>You cannot apply your changes and continue editing.<br><br>Do you want to create a conflict and close the editor?</html>

Attachments (0)

Change History (2)

comment:1 Changed 6 months ago by Don-vip

Keywords: changeset upload comment added

comment:2 Changed 6 months ago by Don-vip

Resolution: duplicate
Status: newclosed

Closed as duplicate of #13474.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.