Modify

Opened 6 weeks ago

Closed 2 weeks ago

#17452 closed defect (fixed)

"Ctrl-Enter" in the upload window sends the current changeset with the summary of the previous one.

Reported by: Dettorer Owned by: Don-vip
Priority: normal Milestone: 19.04
Component: Core Version:
Keywords: template_report upload summaries changesets comment Cc:

Description

What steps will reproduce the problem?

  1. add any modification anywhere on the map;
  2. open the upload window (with Ctrl-Shift-Up or by clicking on the corresponding button);
  3. type a summary;
  4. send the changeset by clicking on the "Upload changes" button;
  5. add another modification to the map;
  6. open the upload window;
  7. type a different summary than the previous one;
  8. send the changeset by typing the shortcut Ctrl-Enter.

What is the expected result?

The second changeset is uploaded with the summary that was just typed.

What happens instead?

The second changeset is uploaded with the summary of the previous changeset.

Please provide any additional information below. Attach a screenshot if possible.

This shortcut seems undocumented so the "expected behavior" is really only what I assumed it should do, which is partly on me. The actual behavior, though, isn't intuitive and I think it should be either documented, changed, or the shortcut disabled.

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2019-03-03 00:16:03 +0100 (Sun, 03 Mar 2019)
Build-Date:2019-03-02 23:16:53
Revision:14824
Relative:URL: ^/trunk

Identification: JOSM/1.5 (14824 en) Linux Arch Linux
Memory Usage: 1183 MB / 3513 MB (574 MB allocated, but free)
Java version: 1.8.0_202-b26, Oracle Corporation, OpenJDK 64-Bit Server VM
Screen: :0.0 1920x1080
Maximum Screen Size: 1920x1080
VM arguments: [-Djosm.restart=true]
Dataset consistency test: No problems found

Last errors/warnings:
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet

Attachments (0)

Change History (7)

comment:1 Changed 6 weeks ago by anonymous

Summary: "Ctrl-Enter" in the upload window, while being an undocumented shortcut, has a misleading behavior."Ctrl-Enter" in the upload window sends the current changeset with the summary of the previous one.

comment:2 Changed 6 weeks ago by Dettorer

Owner: changed from team to Dettorer
Status: newassigned

comment:3 Changed 6 weeks ago by Dettorer

Owner: changed from Dettorer to team
Status: assignednew

comment:4 Changed 2 weeks ago by Don-vip

Keywords: comment added

comment:5 Changed 2 weeks ago by Don-vip

Owner: changed from team to Don-vip
Status: newassigned

comment:6 Changed 2 weeks ago by Don-vip

Milestone: 19.04

Reproduced with r14976

comment:7 Changed 2 weeks ago by Don-vip

Resolution: fixed
Status: assignedclosed

In 14977/josm:

ensures consistency of upload comment:

  • fix #11168 - ctrl-z/undo could reset unwanted old changeset comment
  • fix #13474 - selecting "new changeset" after having entered a changeset comment did reset it to the previous value
  • fix #17452 - ctrl-enter while typing a changeset comment did upload with the previous value
  • fix behaviour of upload.comment.max-age: values were reset after 5 months instead of intended 4 hours because seconds were compared to milliseconds
  • avoid creation of unneeded undo/redo internal classes for non-editable text fields
  • ensures consistency of upload dialog if upload.comment properties are modified manually from advanced preferences
  • add a source attribute to preference events to know which class modified the preference entry
  • refactor reflection utils

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Don-vip.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.